1. AC Question's Avatar
    i have a moto g (2nd gen.) and it says its connected to the internet, so i went on snapchat to snap my boyfriend back and it didn't send, so i tried again, and again, and again. it still didnt send. then it said "no internet connection." so i went on facebook and messaged him then it didn't send. so i turned off my phone then turned it back on, it still didnt work. so i turned it on airplane mode and turned it off, that didn't even work. then i turned off my wifi and turned it back on....it still didn't work, please help. thanks, kelly.
    07-03-2015 01:36 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! What wi-fi network are you connecting to? Is it your home network or a public network? If it's public, did you have you enter a wi-fi password? If no password was needed, you might still have to go to a welcome screen on the browser to accept the network's terms and conditions--open the browser and go to any site (like google.com) and see if a welcome screen appears.

    Does your phone have a mobile data connection? If wi-fi isn't working, you should be able to connect to the web using 3G/4G mobile data (assuming you have a data plan).
    07-03-2015 02:54 PM

Similar Threads

  1. Why won't my HTC EVO 4G LTE accept voicemails?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-03-2015, 03:55 PM
  2. Replies: 1
    Last Post: 07-03-2015, 03:07 PM
  3. Replies: 1
    Last Post: 07-03-2015, 03:04 PM
  4. How do I install apk files on Android Lollipop?
    By AC Question in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 07-03-2015, 03:04 PM
  5. Replies: 1
    Last Post: 07-03-2015, 03:02 PM
LINK TO POST COPIED TO CLIPBOARD