1. mapppps's Avatar
    Hi all

    I have a Moto G 2014 and up until 2 days aog it was working fine (dual sim) 1 uk and 1 spanish sim for my 3g

    anyway, WhatsApp crashed and said do you want to restore history, i clicked yes and was presented with a black screen

    since then I haven't been able to get past this stage, the phone must be working as it boots up/boot logos are shown, and sometimes it will say 'Android is optimising apps' and THEN go to the black screen

    I tried going into the recovery menu and clearing the cache - also tried resetting to factory - neither worked still the same issues

    any help greatly appreciated

    is it ok to talk about ROMs and flashing firmware etc here?

    thanks
    08-05-2015 08:51 PM
  2. Tee Wei Zhong's Avatar
    What recovery mode are you using? CWM or TWRP? Either way, just go to "advance wipe", "wipe dalvik cache", "install" (make sure you have the ROM file on your SD/Internal storage), and install the ROM. Make sure the ROM is stable and is applicable for your locale so that you won't face too much problems in the future.
    08-05-2015 09:02 PM
  3. mapppps's Avatar
    What recovery mode are you using? CWM or TWRP?
    Thanks for such a quick reply - neither, I unfortunately dont have either on the device

    I did try to put both CWM and TWRP on the phone and fastboot said succesful but when enterring recovery mode I was presented with the android icon on his belly with no command and from here I could only get into the normal android recovery mode --- any idea why I can't get CWM orTWRP on?

    I also tried to flash the device..at the time it went wrong it was running Lollipop, so I tried to flash it to a factory version of Lollipop - again it apparent worked, but upon rebooting i got the same black screen


    below is a paste from when I flashed to stock Lollipop

    Press any key to continue . . .

    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *

    To cancel Unplug and Close program

    Press any key to continue

    erasing 'userdata'...
    OKAY [ 0.035s]
    formatting 'userdata' partition...
    Erase successful, but not automatically formatting.
    File system type raw not supported.
    OKAY [ 0.022s]
    erasing 'cache'...
    OKAY [ 0.018s]
    formatting 'cache' partition...
    Erase successful, but not automatically formatting.
    File system type raw not supported.
    OKAY [ 0.028s]
    finished. total time: 0.135s
    FLASHING PARTITIONS.
    target max-sparse-size: 256MB
    sending 'partition' (32 KB)...
    OKAY [ 0.036s]
    writing 'partition'...
    OKAY [ 0.310s]
    finished. total time: 0.354s

    FLASHING BOOT LOADER..
    target max-sparse-size: 256MB
    sending 'motoboot' (2184 KB)...
    OKAY [ 0.112s]
    writing 'motoboot'...
    (bootloader) flashing tz ...
    (bootloader) flashing rpm ...
    (bootloader) flashing sdi ...
    (bootloader) flashing aboot ...
    (bootloader) flashing sbl1 ...
    OKAY [ 0.969s]
    finished. total time: 1.088s

    FLASHING LOGO...
    target max-sparse-size: 256MB
    sending 'logo' (697 KB)...
    OKAY [ 0.079s]
    writing 'logo'...
    OKAY [ 0.051s]
    finished. total time: 0.136s

    FLASHING BOOT....
    target max-sparse-size: 256MB
    sending 'boot' (10200 KB)...
    OKAY [ 0.390s]
    writing 'boot'...
    OKAY [ 0.217s]
    finished. total time: 0.615s

    FLASHING RECOVERY.....
    target max-sparse-size: 256MB
    sending 'recovery' (10280 KB)...
    OKAY [ 0.400s]
    writing 'recovery'...
    OKAY [ 0.211s]
    finished. total time: 0.625s

    FLASHING SYSTEM IMAGE IN MULTIPLE SECTIONS......
    target max-sparse-size: 256MB
    sending 'system' (258868 KB)...
    OKAY [ 8.879s]
    writing 'system'...
    OKAY [ 4.770s]
    finished. total time: 17.575s
    target max-sparse-size: 256MB
    sending 'system' (254994 KB)...
    OKAY [ 8.729s]
    writing 'system'...
    OKAY [ 5.009s]
    finished. total time: 13.750s
    target max-sparse-size: 256MB
    sending 'system' (260623 KB)...
    OKAY [ 9.289s]
    writing 'system'...
    OKAY [ 4.744s]
    finished. total time: 14.039s
    target max-sparse-size: 256MB
    sending 'system' (255649 KB)...
    OKAY [ 8.650s]
    writing 'system'...
    OKAY [ 4.390s]
    finished. total time: 13.044s
    target max-sparse-size: 256MB
    sending 'system' (32272 KB)...
    OKAY [ 1.126s]
    writing 'system'...
    OKAY [ 0.553s]
    finished. total time: 1.687s

    FLASHING MODEM.......
    target max-sparse-size: 256MB
    sending 'modem' (49364 KB)...
    OKAY [ 1.738s]
    writing 'modem'...
    OKAY [ 0.835s]
    finished. total time: 2.578s
    erasing 'modemst1'...
    OKAY [ 0.015s]
    finished. total time: 0.018s
    erasing 'modemst2'...
    OKAY [ 0.015s]
    finished. total time: 0.019s
    target max-sparse-size: 256MB
    sending 'fsg' (651 KB)...
    OKAY [ 0.096s]
    writing 'fsg'...
    OKAY [ 0.047s]
    finished. total time: 0.150s

    ERASING CACHE ......
    erasing 'cache'...
    OKAY [ 0.022s]
    finished. total time: 0.031s

    ERASING USERDATA.......
    erasing 'userdata'...
    OKAY [ 0.033s]
    finished. total time: 0.043s

    DONE!.........PRESS ANY KEY TO REBOOT

    rebooting...

    finished. total time: 0.005s

    Press any key to exit
    08-05-2015 09:11 PM
  4. Tee Wei Zhong's Avatar
    How did you flash recovery mode (CWM/TWRP) if the phone is bricked? Did you use ADB?

    Posted via the Android Central App
    08-06-2015 09:06 AM

Similar Threads

  1. Replies: 20
    Last Post: 01-09-2016, 07:55 AM
  2. Moto G3 and Android Auto
    By Pedrore in forum Android Auto
    Replies: 14
    Last Post: 10-27-2015, 09:18 AM
  3. My Moto e doesn't see update 5.1?
    By Xabier Granja in forum Moto E (2015)
    Replies: 4
    Last Post: 08-08-2015, 04:52 PM
  4. Replies: 1
    Last Post: 08-07-2015, 04:57 PM
  5. Moto Maker Cards?
    By oboefiend in forum Moto X Pure Edition
    Replies: 4
    Last Post: 08-05-2015, 09:00 PM
LINK TO POST COPIED TO CLIPBOARD