1. AC Question's Avatar
    I've never had a smart phone before and I'm having a major problem with my Moto G 2 and I wonder if anyone can help me. Suddenly I can not access my keyboard in text or email. Whenever I try to send a text the "tap to speak" voice input option is all that comes up. I can't seem to access the keyboard by tapping the "keyboard" icon to the left of the mic. I tried disabling Google Voice Input but can't seem to make that work.

    Now I more or less cannot use my smartphone without my keyboard.
    How can I get my keyboard back? Please help!
    08-28-2015 10:07 AM
  2. Javier P's Avatar
    It seems that you have voice input selected as default. Try this. Tap on a text window to open the keyboard, tap on the tiny keyboard icon bottom right. A menu should pop up, select Google keyboard. Tell us if this fixed your problem or not so can offer different solutions.
    08-28-2015 10:25 AM
  3. neets456's Avatar
    I can't get a keyboard icon anywhere, there is just "google speak now" filling the bottom half of the screen
    08-28-2015 10:55 AM
  4. Javier P's Avatar
    Hello Neets, thanks for signing in and welcome to the forums! Are you still running kitkat? There could be two places where you can change your input method. Bottom right (Lollipop) or in your notification shade (kitkat). Take a screenshot with that keyboard opened and I'll try find a solution.
    08-28-2015 11:20 AM
  5. neets456's Avatar
    Hi

    Thanks for your help

    When I say I am new to smartphones, I do mean that. I didn't understand any of your reply and I don't know how to take a screenshot, sorry.
    08-28-2015 11:55 AM
  6. Javier P's Avatar
    OK, don't worry, all of us were newbies at some point

    Lollipop and Kitkat are different Android versions and the process to change the keyboard will depend on which one you've got. Let's try this. Tap on a text window and when that voice input pops up swipe down from the top edge to open the notifications. If there's one about "input method" tap on it and a menu should appear. Select Google keyboard. This is how it works in Kitkat.

    With Lollipop you need to tap on the little icon bottom right (see screenshots) and after that the process is the same.
    Attached Thumbnails Why can't I get the keyboard up on my new MotoG 2?-1440780479973.jpg   Why can't I get the keyboard up on my new MotoG 2?-1440780503318.jpg  
    08-28-2015 12:47 PM
  7. neets456's Avatar
    Thanks
    When I have a text window open and try to swipe down from the top nothing happens.
    When I have the screen showing like your screenshot I don't have that icon bottom right.
    I just have the 3 icons you have at the very bottom of the screen.

    Sorry. Feeling like throwing the damn thing out the window, thankfully it is a work phone, so my life can continue without it
    No one I've spoken to from work has been able to help me today.
    08-28-2015 01:08 PM
  8. Javier P's Avatar
    That's very strange. Do you have the same "X" symbol as in my screenshot? (Top right of the mic box). What happens if you tap on it?

    Let's try a couple more things. This is getting personal now

    Power your phone off, wait 30 seconds and back on. Open the keyboard. Same problem? If so then try to download a new keyboard. Open Play Store, tap on the hamburger menu top left, store home - apps - categories - scroll down and tap on productivity - top free - scroll down until you find SwiftKey - tap on it and install.

    This is a long process just because you don't have a functional keyboard to help your search.

    Now repeat all the process to change keyboard and the tiny keyboard icon SHOULD be there Select SwiftKey in the menu. I've got it in my screenshot as well. Tell me how it goes.
    neets456 likes this.
    08-28-2015 01:56 PM
  9. neets456's Avatar
    Thank you so much. You are wonderful.
    I have managed to do this and I can now use a keyboard.

    Sorry for the delay but I've been away.
    08-31-2015 03:30 PM
  10. Javier P's Avatar
    Glad it helped! Which process did the trick? It can be helpful for other people with a similar problem
    08-31-2015 04:20 PM
  11. neets456's Avatar
    I had to download the swiftkey and then it just worked

    Thanks again
    Javier P likes this.
    09-01-2015 04:50 AM

Similar Threads

  1. Replies: 0
    Last Post: 08-28-2015, 09:58 AM
  2. My operating system on Android phone is 2.2.1 will it update Google?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 08-28-2015, 09:56 AM
  3. How do I shuffle music on my Samsung S2 lite using music Paradise?
    By AC Question in forum Samsung Galaxy S2
    Replies: 0
    Last Post: 08-28-2015, 09:52 AM
  4. Replies: 0
    Last Post: 08-28-2015, 09:42 AM
  5. Replies: 0
    Last Post: 08-28-2015, 09:21 AM
LINK TO POST COPIED TO CLIPBOARD