1. d_dorman's Avatar
    Hi, after installing Good for Enterprise onto a MOTO G handset running Android 5.1 and security patch level 2016-03-01, on the O2 network in the UK, I get an error on launching it that says ''Good for Enterprise is not supported for this type of handheld'.

    Does anyone have any experience of resolving this issue?

    This document says that the handset and network should be compatible with the app, https://community.good.com/servlet/J...ure%20Apps.pdf

    Thanks,
    David
    05-26-2016 11:17 AM
  2. hallux's Avatar
    Should be, but your company can also block device models they've had problems with and that may be what you're seeing. Have you confirmed with your IT department that they will support that model phone?
    05-26-2016 11:55 AM
  3. Rukbat's Avatar
    1. Did you install it from the Play Store? There could be many versions of the app - the Play Store will download the proper one for your phone (or not show it if it has none). Installing a "generic" version may not always work.

    2. It lists the G as unlocked. If it's locked to O2, that could be causing problems.
    05-26-2016 04:46 PM

Similar Threads

  1. what do I do when my samsung s5 does not vibrate any longer?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 06-05-2016, 08:03 AM
  2. Replies: 1
    Last Post: 05-26-2016, 05:12 PM
  3. not tech savvy
    By AC Question in forum Samsung Galaxy S7 edge
    Replies: 2
    Last Post: 05-26-2016, 05:05 PM
LINK TO POST COPIED TO CLIPBOARD