1. LeviCituaist's Avatar
    My phone ran out of battery today and once I plugged it in a charger it wouldn't charge. Sometimes a white screen with the symbol of a battery bar and a plug inside of it would show but it seems that doesn't mean it's charging (I think it only charges when it shows the battery bar symbol and a percentage of battery). I've tried holding the down and power button together and tried some options in the menu but nothing worked. I also can't remove my battery.

    Help, please, how do I fix this?
    Thanks
    05-02-2016 02:25 PM
  2. NucleBAH's Avatar
    Try a different cable

    Posted via the Android Central App
    05-02-2016 04:30 PM
  3. LeviCituaist's Avatar
    I also can't remove my battery
    05-02-2016 05:00 PM
  4. Rukbat's Avatar
    I think you ran the battery down to zero, then plugged the charger in and expected to see results immediately. Plug the charger in and let it sit overnight. The first 30-60 minutes it's precharging, and the battery will barely have enough charge to turn itself off if you turn it on.
    LeviCituaist likes this.
    05-02-2016 06:31 PM
  5. LeviCituaist's Avatar
    Hey guys, so I solved my problem my leaving the phone charging for a long while connected to a pc. Turns out once again a motorola phone I own got its usb entrance easily broken
    05-02-2016 06:48 PM

Similar Threads

  1. Nexus 5X not saving contacts on phone?
    By ccelectricplus in forum Nexus 5X
    Replies: 3
    Last Post: 05-04-2016, 07:31 AM
  2. Replies: 2
    Last Post: 05-02-2016, 04:32 PM
  3. my system launcher of xiaomi phone has stoped what i do ???
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-02-2016, 02:23 PM
  4. Replies: 1
    Last Post: 05-02-2016, 02:20 PM
  5. Replies: 0
    Last Post: 05-02-2016, 01:51 PM
LINK TO POST COPIED TO CLIPBOARD