1. KatieManning's Avatar
    Boxing Day of 2015 I upgraded my 1st gen Moto G for the 3rd gen, and by God was it the worst mistake I've ever made in my entire life. I don't know if I even had the phone for a month before it started slowing down. As of today it runs like a desktop running Windows 95. If I want to unlock my phone and load an app, it's going to take at LEAST five minutes. No exaggeration, five full minutes. 300 seconds. And that's assuming the entire system doesn't freeze up, which it will do three times out of five I try to load anything, ever.

    I've scored the internet for months and NOTHING works. Clearing the cache doesn't work, wiping the cache partition doesn't work, nothing. Even resetting to factory settings doesn't work. If there's any improvement at all, it's very minor, and lasts less than a day. My father's six-year-old flip phone works better than this piece of garbage. I've deleted almost all the apps from my phone, and moved the rest to my SD card to clear space, still nothing. I have absolutely no idea what to do except go back to the mall and throw the phone directly at the person who scammed me into buying this crap.
    06-15-2016 10:24 PM
  2. pankaj981's Avatar
    Looks like you clearly got a lemon (hardware defect) or your phone's software is really jacked up. I have used a Moto G3 on Marshmallow briefly for a couple of weeks and it no way felt the same as you describe here. If a factory reset hasn't helped I guess you can perform a full firmware wipe as a last resort before reaching out to Moto Support (warranty claim provided its still in warranty).
    06-16-2016 12:11 AM
  3. Javier P's Avatar
    Hello Katie, welcome to the forums. As stated above this phone shouldn't behave like that, it's a good phone so either you have a bad unit or there's something wrong in your software.

    You could try booting into safe mode to rule out any conflict with a third party app. Also, unmount your SD card, restart the phone and see if it makes any difference.
    06-16-2016 07:30 AM
  4. Rover Pow's Avatar
    I do not think he got a lemon, these phones are just like that. Got the same problem, and many others as well!
    06-23-2016 05:34 AM
  5. Kris2277's Avatar
    Not me! Love mine!
    Ry likes this.
    06-24-2016 12:27 PM
  6. TgeekB's Avatar
    Hello Katie, welcome to the forums. As stated above this phone shouldn't behave like that, it's a good phone so either you have a bad unit or there's something wrong in your software.

    You could try booting into safe mode to rule out any conflict with a third party app. Also, unmount your SD card, restart the phone and see if it makes any difference.
    I was wondering about the sd card also.
    06-26-2016 05:18 PM
  7. Ry's Avatar
    What SD card are you using?

    After the factory reset, are you restoring from a backup or truly starting fresh?

    Posted via the Android Central App on the Moto X Pure Edition
    06-26-2016 07:57 PM

Similar Threads

  1. Replies: 1
    Last Post: 06-16-2016, 09:15 AM
  2. Moto X won't save files
    By jcassell1 in forum Moto X Pure Edition
    Replies: 3
    Last Post: 06-16-2016, 08:52 AM
  3. Moto Droid Maxx chargers
    By Abby Normal in forum Marketplace Archive
    Replies: 1
    Last Post: 06-16-2016, 07:43 AM
  4. Moto Droid Maxx chargers
    By Abby Normal in forum Motorola Droid MAXX
    Replies: 0
    Last Post: 06-15-2016, 12:50 PM
  5. Buy the OnePlus 3 or wait for the Moto Z
    By AC Question in forum OnePlus 3 & 3T
    Replies: 3
    Last Post: 06-15-2016, 08:44 AM
LINK TO POST COPIED TO CLIPBOARD