1. theytsejam's Avatar
    Hi,

    I have noticed sometimes when I take a photo the jpg file gets saved slightly corrupted. I noticed this when I was flicking through the photos in the photo gallery. Thumbnail view shows everything ok, but some photos will show as solid grey when opened to full screen viewing. The photo metadata (time, date, camera parameters etc) is valid (select three dots from upper right corner, then Info).

    I transferred such a photo to computer and Windows photo viewer opens it without problem. When opening with Gimp a message about corrupted data or something flashes quickly but the photo opens without problem. I cannot see anything wrong in the images when they're opened on computer so the actual image data seems to be correct.
    I ran the "identify" program from Imagemagick on a corrupted file and it shows following error:

    identify: Premature end of JPEG file `IMG_20160626_094102817.jpg' @ warning/jpeg.c/JPEGWarningHandler/352.
    identify: Corrupt JPEG data: premature end of data segment `IMG_20160626_094102817.jpg' @ warning/jpeg.c/JPEGWarningHandler/352.

    The photos don't get corrupted that often, I just checked 170 photos from last three weeks and two were corrupted. Still, there should not be any.
    They have similar errors, i.e. thumbnails ok, solid grey on phone but can be opened on computer, and running "identify" show same error.

    I can sort of fix them by re-saving the file on computer to have error-free jpg and moving to phone with same filename.

    Has anyone experienced anything similar?

    I have 2/16GB model of the Moto G 2015, all photos on flash (no microSD installed). Currently running Android Marshmallow but I just recently upgraded so I think the problem existed with Lollipop also.

    Thanks,
    Tomi
    06-29-2016 02:00 AM

Similar Threads

  1. How can I fix apps, stuck on moving to SD card?
    By alexandrew74 in forum Ask a Question
    Replies: 7
    Last Post: 10-17-2017, 03:49 PM
  2. Replies: 1
    Last Post: 06-29-2016, 04:23 AM
  3. Can't find tethering/hotspot selection in my phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-29-2016, 04:21 AM
  4. I can hardly type! Help!
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-29-2016, 04:14 AM
  5. signal loss on oneplus 3 for airtel
    By anandbs155 in forum OnePlus 3 & 3T
    Replies: 0
    Last Post: 06-29-2016, 12:24 AM
LINK TO POST COPIED TO CLIPBOARD