1. paininthenuts's Avatar
    My G3 was sent back 4 days after I got it because it crashed when formatting the SD card. This time it is not connecting to the PC. I have tried 3 cables, and two PC's. My wifes G2, also on Android 6.0 is fine. After I had about 20 attempts, I eventually downloaded the photos I had on the SD card. The phone connects briefly, and then after a few seconds, it disconnects, so I would presume it is a faulty USB port. To be honest I am getting pretty fed up now.

    I have been on the live chat with Motorola, and on 2 occasions got cut off because the agents had no patience whist I was trying their fixes. Each time I had to go through the same questions until I virtually insisted on the returns procedure
    10-10-2016 09:14 AM
  2. B. Diddy's Avatar
    Man, that's frustating. When you say it connects briefly, then disconnects, do you mean that it initially detects the USB connection, and then that icon completely disappears from the notification panel? If you swipe down the notification panel, is there any option to change the USB connection to MTP?

    Also, try using a can of compressed air to blow out the microUSB port, or a small cotton swab moistened with rubbing alcohol to clean the USB contacts.
    10-11-2016 03:47 PM
  3. paininthenuts's Avatar
    Man, that's frustating. When you say it connects briefly, then disconnects, do you mean that it initially detects the USB connection, and then that icon completely disappears from the notification panel? If you swipe down the notification panel, is there any option to change the USB connection to MTP?

    Also, try using a can of compressed air to blow out the microUSB port, or a small cotton swab moistened with rubbing alcohol to clean the USB contacts.
    I know I have to swipe down, and occasionally the notification is there, then it disconnects. It is definitely a faulty USB port
    10-12-2016 08:21 AM
  4. acejavelin's Avatar
    I know I have to swipe down, and occasionally the notification is there, then it disconnects. It is definitely a faulty USB port
    Assuming you have already tried different cable(s) and ports on the PC?
    10-12-2016 09:47 AM
  5. paininthenuts's Avatar
    Assuming you have already tried different cable(s) and ports on the PC?
    Please read original thread post
    10-12-2016 12:29 PM
  6. Javier P's Avatar
    I know I have to swipe down, and occasionally the notification is there, then it disconnects. It is definitely a faulty USB port
    I'm inclined to agree with you, it sounds like there's something wrong on the USB port. Frustrating, I know.
    10-12-2016 12:45 PM
  7. B. Diddy's Avatar
    Please read original thread post
    You mentioned trying different PCs, but not different ports. Although unlikely, it's conceivable that you might be using a USB hub on both PCs, which could cause some issues. But that's not the case, right?
    10-12-2016 02:25 PM
  8. paininthenuts's Avatar
    You mentioned trying different PCs, but not different ports. Although unlikely, it's conceivable that you might be using a USB hub on both PCs, which could cause some issues. But that's not the case, right?
    Yep. 3 different leads directly from the phone to different usb ports on 2 different computers. Like I said, my wife's G2 works perfectly when doing the same thing. What's more, I have done the same exercise with my G3 on several occasions prior. I am now managing to get my G3 married up to my PC intermittently, so am in two minds whether to send it back or not.
    10-13-2016 04:30 AM
  9. B. Diddy's Avatar
    Intermittent still isn't good. It's a hassle, but I'd ask for another replacement.
    acejavelin likes this.
    10-13-2016 12:19 PM
  10. paininthenuts's Avatar
    Intermittent still isn't good. It's a hassle, but I'd ask for another replacement.
    They didn't replace it last time, so I doubt they will this time. A repair at best I would think
    10-14-2016 09:27 AM
  11. Laura Knotek's Avatar
    I had a Moto X Pure Edition that completely died. They did send me a refurbished device, since the IMEI was different on the one I got than the original one I purchased. So I'd suggest escalating the trouble ticket and asking to speak with a manager in order to get the device replaced.
    B. Diddy likes this.
    10-14-2016 10:15 AM
  12. paininthenuts's Avatar
    I had a Moto X Pure Edition that completely died. They did send me a refurbished device, since the IMEI was different on the one I got than the original one I purchased. So I'd suggest escalating the trouble ticket and asking to speak with a manager in order to get the device replaced.
    I live in the UK, and retail laws aren't as liberal here
    10-14-2016 12:57 PM
  13. Laura Knotek's Avatar
    I live in the UK, and retail laws aren't as liberal here
    It's still worth a try. I don't live in a state such as California, with really liberal consumer protection laws.
    10-14-2016 01:53 PM

Similar Threads

  1. Replies: 0
    Last Post: 10-10-2016, 07:11 AM
  2. How to fix "sustem ui has stopped"
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-10-2016, 07:08 AM
  3. How to install micro sd card in ZTE avid plus phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-10-2016, 05:44 AM
  4. Not able to download anything
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-10-2016, 05:31 AM
LINK TO POST COPIED TO CLIPBOARD