1. adityaakshay's Avatar
    My phone is Moto g3 and mobile data is not working. I applied for MNP and changed my SIM from Vodafone to Airtel and since morning as soon as entered Airtel SIM, mobile data isn't working.. mobile data switch is greyed out and when i click on mobile data it shows "mobile data change in progress"..I have tried clearing the cache memory but it doesn't work..Tried restarting the phone, reinserting the SIM, doesn't work data is working on the SIM when. Tried on another phone..Kindly help ..I don't want tof factory reset and my phone is not in warranty
    04-11-2017 12:50 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are you sure you have the correct APN settings for Airtel? Which region of the world are you in?

    What is an APN, and how do I change it? | Android Central
    04-11-2017 03:18 PM

Similar Threads

  1. Replies: 6
    Last Post: 04-11-2017, 01:29 PM
  2. Replies: 0
    Last Post: 04-11-2017, 12:32 PM
  3. I cannot get my IMAP email to work in the outlook app on my new S7 Edge,
    By AC Question in forum Samsung Galaxy S7 edge
    Replies: 0
    Last Post: 04-11-2017, 11:26 AM
  4. Replies: 0
    Last Post: 04-11-2017, 11:26 AM
LINK TO POST COPIED TO CLIPBOARD