1. Rejesto's Avatar
    I use a Motorola G4, fully updated to the latest version, with no notable damage. I have never encountered any bugs/errors with the phone up until now.

    About two weeks ago I tried to use Google with voice using "Ok Google" and received no response. When pressing the microphone button I was prompted with "Google is not available right now."

    Google worked fine in-app and I could search - my internet was working fine. I figured it was an issue with my microphone.

    Later I found my music would not play through play music. When I chose the shuffle option, it would seem my phone was attempting to play the song, but finding it was not possible and rapidly going through them until reaching the end of my playlist.

    Finally I found that video didn't work either. Boomerang loops on Instagram do, so I figured it was because they were audio free - other videos on Instagram did not work. When trying to record video, the phone says it "failed".

    I am now left with a phone that's speaker will not function, and even when plugging I'm external audio hardware such as speakers or headphones no audio will work, including making calls. It will not play videos associated with audio, even refusing to play on platforms such as VLC and YouTube. It will not record video, or register audio.

    One might understand why this has left me a little miffed.

    Is this a problem that can be fixed by disabling some hidden away function in my phone? Or is it likely that I will have to send this back to the manufacturer?
    08-12-2017 07:15 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try wiping the cache partition: https://motorola-mobility-en-in.cust...p/30,6720,9686. If that doesn't work, does it also happen in Safe Mode? https://motorola-mobility-en-in.cust...p/30,6720,9686
    08-12-2017 11:41 PM
  3. Rejesto's Avatar
    I did all that you suggested, and it showed up some interesting results

    Partition Clear: I had to try this a couple times as my volume buttons fell off, I had to use a fork. I was a bit surprised at first, as I expected it would take between 5 - 10 minutes, however, it took just little under 3 seconds. I booted up the phone once more, but found no change

    Safe Mode: Safe mode presented more favourable results. I started by saying "Ok Google", and was pleasantly surprised to see the phone recognise the phrase and pull up Google. I could search using my voice, and my microphone seemed to function perfectly. Sadly the phone would not output audio from the speaker, but videos were no longer giving out error messages, and shuffling my music allowed the songs to play (in silence) until the end, without switching almost instantly to the next song. This sparked an idea, and I plugged my headphones in, and they worked fine.

    Would a fair assumption be that a third party application is causing audio related problems, and my speaker is just broken?
    08-13-2017 07:54 PM
  4. Rejesto's Avatar
    Update*

    I have just attempted to launch the phone in safe mode for the second time, and it is not performing in the same way it did originally, no sound, play music bugging out, headphones refusing to work.

    If this information is of any use, the first time I loaded up safe mode it was the first time I had gotten the "intro", the video with the dog, lips, daft punk doing s backup ect..

    I also tried uninstalling apps and completing another cache clear before going back into safe mode for a third time, no change.
    08-13-2017 08:30 PM
  5. B. Diddy's Avatar
    Has the phone had any trauma, like drops? When you mentioned that the volume button fell off, that made me wonder if the phone has been knocked around a little, which would mean that anything is possible.
    08-13-2017 10:30 PM
  6. Rejesto's Avatar
    The phone has had drops, but none that I would have thought to damage the phone, all less than two meters. The phone also has a protective case.
    08-14-2017 08:13 AM
  7. B. Diddy's Avatar
    Might have been enough to disrupt the speaker, perhaps by loosening a connection. If you're handy, you could try opening it up and seeing if anything is loose:

    08-14-2017 12:16 PM

Similar Threads

  1. Overheats when outside after 5 min on camera (but not surprised)
    By PaulQ in forum Samsung Galaxy S8 & S8+
    Replies: 5
    Last Post: 08-14-2017, 07:58 AM
  2. Samsung Tab S not turning on or charging
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-12-2017, 11:42 PM
  3. Email attachments with outlook on android
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-12-2017, 11:29 PM
  4. Notification sound not working when i get a text
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-12-2017, 11:15 PM
  5. Replies: 1
    Last Post: 08-12-2017, 06:14 PM
LINK TO POST COPIED TO CLIPBOARD