1. klayton88's Avatar

    First time poster.

    I have had the phone about 3 days, everything was going great and am hugley impressed with the battery life.

    Just scrolling through sky news app on around 60% battery and it just shut off, no warning, no blinkering, just a black screen instantly.

    I have tried a normal boot with the power button - no joy
    I have tried volume down & power button for 2 mins - no joy
    I have tried volume up, volume down & power button for 30s - no joy

    Various YouTube videos later and im still stuck with a dead phone. In my old galaxy i would simply just remove the battery if this happened and it would fix it but the 2nd Gen Moto G as you know does not have an easily accessible battery,

    Anybody have any suggestions?

    Thanks in advance.

    01-12-2015 08:16 PM
  2. Rukbat's Avatar
    1) The (almost) equivalent of pulling the battery is holding down the power button until the phone restarts.

    2) Try leaving the charger plugged in overnight.

    3) The phone is under warranty. If one of the first two things doesn't fix the problem, I'd bring it back. It's Motorola's problem, not yours. After only 3 days, they should just replace the phone on the spot.
    01-12-2015 08:37 PM
  3. klayton88's Avatar
    Thanks for the reply....

    It was somewhat charged this morning (80%) when overnight it should have easily done a full charge so im convinced there is an issue with the battery.

    It is still crashing a lot today and restarting itself and I've noticed some app shortcuts on my homepage keep disappearing.... and the apps in question are the apps saved on my "Integral 32GB UltimaPro Micro SDHC Card 40MB/s - Class 10" SD Card...

    Could the SD card be a part of the problem?

    Would i contact tescodirect (who i bought the phone from online) or contact motorola in regards to getting it replaced?

    Thankyou again...
    01-13-2015 10:57 AM

Similar Threads

  1. When will Song ID be a part of Android Wear
    By red.foxx15 in forum Android Wear / Wear OS
    Replies: 7
    Last Post: 06-19-2015, 06:05 PM
  2. Who wants to help me port a ROM?
    By Fredo Fosco in forum Software Development and Hacking
    Replies: 12
    Last Post: 01-15-2015, 03:54 PM
  3. The soak test is out, NOT Lollipop
    By Moo Cow in forum Motorola Droid MAXX
    Replies: 5
    Last Post: 01-13-2015, 02:58 PM
  4. apps not installing
    By marge64 in forum Ask a Question
    Replies: 3
    Last Post: 01-13-2015, 02:38 AM
  5. Why am I getting an error message when trying to use my internet keyboard?
    By queenie marie legaspi in forum Ask a Question
    Replies: 1
    Last Post: 01-12-2015, 10:14 PM