1. Nitin CR's Avatar
    Hi All,

    I have a Moto G first gen, yday night got the update and its done, however post which the operator data is NOT working. Its just WiFi which is working.
    What I have done:
    Updated to Lollipop - Thru WiFi
    Checked - Operator Data Not Working

    Solutions which I did, which was recieved from Google Plus community & Moto Care Agent (Live Chat)
    1. Cleared Cache
    2. Did a soft reset & rebooted With Sim & Without Sim
    3. Did a hard reset & rebooted with Sim & Without SIM

    I have been trying all methods to get this going, but of no use. Kindly help! I wouldn't hesitate to go back to Kit Kat now!
    01-25-2015 01:59 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! What do you mean by Operator Data? Do you mean mobile data (3G/4G)? Have you checked your APN settings to make sure they match your carrier's settings?
    01-26-2015 01:53 AM
  3. Nitin CR's Avatar
    Thank you.
    Yes I mean mobile data, checked the APN settings too, my SIM works well on my wife's windows phone.
    01-26-2015 07:16 AM
  4. B. Diddy's Avatar
    Hmm, not sure what else to suggest. What did Moto Care say after you did all of that?
    01-26-2015 11:23 AM
  5. Nitin CR's Avatar
    The latest feedback, is they agree that they have this issue, & said they are working on it & would be resolved soon, when asked how soon? They had no reply
    01-27-2015 04:12 AM
  6. Nitin CR's Avatar
    An update:

    Spoke to Moto care again as its been now three days since the update. They asked me to visit a local authorized service ctr, which I did. Being there one of the executives at the ctr told me that they would need the pone for about a week as they have to check the mother board! I was surprised as why that, when it was working very well till the update. So he said they would check & also check the s/w to see for issues.

    I'm a little not happy about the whole thing & Im yet to give this phone there. So any thoughts? Or do you have any updates?
    01-28-2015 07:33 AM
  7. Javier P's Avatar
    Just a thought. After the factory reset, did you update your apps automatically before testing the mobile network? I've read that some people had the same problem and the culprit was a locker app (I don't remember which one).

    You can take a look at this Google forum. Different fixes for the same problem.

    https://productforums.google.com/for...us/enLbrvYA8cg
    B. Diddy and Nitin CR like this.
    01-28-2015 08:17 AM
  8. B. Diddy's Avatar
    If Javier P's suggestion doesn't pan out, then go with the Moto service center. If it were me, I'd be glad they agreed it was a problem and would look into it in that much detail. It would presumably be covered under warranty. It's much better than having a store tell you there's no problem, or that there isn't anything they can do!
    01-28-2015 10:39 AM
  9. Nitin CR's Avatar
    Thanks for the link, I checked & tried but of no use. I had a launcher DoDo i have uninstalled the same & the phone locker too
    02-06-2015 03:51 AM
  10. Nitin CR's Avatar
    If Javier P's suggestion doesn't pan out, then go with the Moto service center. If it were me, I'd be glad they agreed it was a problem and would look into it in that much detail. It would presumably be covered under warranty. It's much better than having a store tell you there's no problem, or that there isn't anything they can do!
    Im not sure Im still pondering on the fact why did they say it would be an issue with the mother board? The other issue with my phone is SIM 1 slot is not working as my son tampered it & so my warranty is lost.
    02-06-2015 03:52 AM
  11. Javier P's Avatar
    Im not sure Im still pondering on the fact why did they say it would be an issue with the mother board? The other issue with my phone is SIM 1 slot is not working as my son tampered it & so my warranty is lost.
    Being a dual SIM there's a couple of things you could try. Maybe the update changed you previous settings.

    Go to settings - SIM cards. Tap on "mobile data", not on the switch, on the text. A little menu will pop up. Make sure that the right sim is checked.

    After that check that "preferred network type" is correct (2g for the broken slot and 3g for the one you use). This is in settings - more - mobile network - swipe between tabs.
    02-06-2015 06:33 AM
  12. Nitin CR's Avatar
    Being a dual SIM there's a couple of things you could try. Maybe the update changed you previous settings.

    Go to settings - SIM cards. Tap on "mobile data", not on the switch, on the text. A little menu will pop up. Make sure that the right sim is checked.

    After that check that "preferred network type" is correct (2g for the broken slot and 3g for the one you use). This is in settings - more - mobile network - swipe between tabs.
    Whn i tap on the text of mobile data on the SIM, there is no menu popping up, I can select the SIm which would just take me to the colour of the SIM & an option to change the SIM name. The SIM1 where I dont have a SIM card inserted (As it doesnt work) is not highlighted.
    02-14-2015 06:44 AM
  13. Benjamin Mackie's Avatar
    Try booting into Lollipop safe mode and then switch on data and then automatically register on your preferred network.

    Then switch off phone and reboot into normal mode.

    This solved the prob for me.

    Boot into safe mode: Switch off phone as normal but when the dialogue comes up, press and hold this dialogue.
    03-10-2015 04:59 PM
  14. Nitin CR's Avatar
    Try booting into Lollipop safe mode and then switch on data and then automatically register on your preferred network.

    Then switch off phone and reboot into normal mode.

    This solved the prob for me.

    Boot into safe mode: Switch off phone as normal but when the dialogue comes up, press and hold this dialogue.
    Im going to try this tonight! thanks for the update
    03-16-2015 07:30 AM
  15. Saravanan Manoharan1's Avatar
    I am exactly facing the similar problems like your but the phone is moto E.

    The SIM 1 slot is not working as I played with different SIM insertions.
    The mobile date is not working at all after upgrading to lollipop. This is the major issue.

    Have you resolved the issues in your phone?

    Thanks,
    Sarmano.
    03-27-2015 07:14 AM
  16. Jaimini P's Avatar
    Im not sure Im still pondering on the fact why did they say it would be an issue with the mother board? The other issue with my phone is SIM 1 slot is not working as my son tampered it & so my warranty is lost.
    Your son is innocent. Even I doubted my son in the beginning, until I saw in the forums that a number of people who did this update had the same issue. I have the following problems.

    SIM slot 1 not recognized
    Mobile internet (data) does not work

    If you have a solution, please post it so that everyone can benefit from that. None of the methods i came across in forums worked for me yet.
    04-09-2015 08:15 AM
  17. Looby18's Avatar
    Your son is innocent. Even I doubted my son in the beginning, until I saw in the forums that a number of people who did this update had the same issue. I have the following problems.

    SIM slot 1 not recognized
    Mobile internet (data) does not work

    If you have a solution, please post it so that everyone can benefit from that. None of the methods i came across in forums worked for me yet.
    I had this issue and found that the lollipop upgrade had defaulted mobile data to 'off'. I went into 'settings' then 'data usage' and chose the mobile data tag. Then set mobile data on. This sorted it for me
    06-17-2015 07:38 PM
  18. dixitrohit01's Avatar
    i also tried this trick. but unable to register on mobile network. my phone is receiving any signal from operator... plz help
    06-20-2015 04:54 PM

Similar Threads

  1. Replies: 1
    Last Post: 01-26-2015, 01:54 AM
  2. Why isn't my tablet turning on?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-25-2015, 02:08 PM
  3. What is mobile data on my Android phone?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-25-2015, 02:06 PM
  4. How do I know if the imei works still on samsung s5 ?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-25-2015, 01:43 PM
LINK TO POST COPIED TO CLIPBOARD