1. AC Question's Avatar
    I use a Moto G 2nd gen. I've had it for about two months. I went to transfer photos onto my SD card, and it wasn't registered on my phone. I did the typical on-and-off-again, take-it-out-and-reinsert-it, didn't work. It eventually recognised my SD card but every time I tried to mount it, it would say 'SD card is blank or has unsupported file system'. There was an option to "format your SD card", and I tried it, to no avail. I put the card into my Macbook and ran Disk Utility over it, and it didn't detect any errors. I tried erasing all the data on my SD card (somehow that option was available on my phone and laptop) and that didn't work either. What do I do?
    06-12-2015 03:04 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! The card is either defective, old and worn-out, or counterfeit. You probably can't save it.
    06-13-2015 02:19 AM

Similar Threads

  1. My mobile data icon is missing, how can I get it back?
    By AC Question in forum Samsung Galaxy S6 edge
    Replies: 4
    Last Post: 07-08-2015, 12:21 PM
  2. Why was there a sudden drop is battery life?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-12-2015, 04:20 PM
  3. Replies: 2
    Last Post: 06-12-2015, 03:28 PM
  4. Replies: 1
    Last Post: 06-12-2015, 03:05 PM