1. ClayUpNorth's Avatar
    Cross posted...
    I've searched the forums, and haven't found anyone with a similar problem, moto G7 running 9, build PPO29.114-16-7;

    My issue is that I have my phone on vibrate for notifications, (this includes ring) media volume at zero, while on an active phone call, with the call on speaker, I'm getting notification sounds from emails and apps, it's very annoying and I can't find the setting that is causing this behavior.

    It's been suggested to use DND settings, but there's no such setting during a call that I can find. It's also been state that notification are tied to ringer volume, which as I stated was set to vibrate, but I'm still getting audible notifications. I don't see any setting to allow or deny notifications during a call, am I missing some secret setting?
    Suggestions?
    thebat1 and elcomatix like this.
    03-28-2019 12:57 PM
  2. Scott337's Avatar
    That has been the way my last few Moto phones have functioned. I assumed it was just normal Android behavior
    03-28-2019 01:19 PM
  3. thebat1's Avatar
    Ok I have same issue.. Verizon Droid Z3 Pie,
    DRIVING ME NUTS.. not to mention I cant turn down the sounds for anyting annoying it seems.
    Can someone help how to keep all these notifications from blasting in my ear while on a call? Mine happens with headset and on all calls. And its so loud you cant hear who your talking to through the LOUD notifications... UUGGHHH
    Hoping someone can help us out...
    05-15-2019 01:16 AM
  4. ScottMGS's Avatar
    I don't think it's a Moto or G7 issue, it's Android 9. The notifications seem to need to be turned off app by app in the Apps & Notifications section of system settings or in each app's settings. I agree that it's annoying.
    06-24-2019 12:42 PM
  5. elcomatix's Avatar
    It's so annoying, my ear almost blast every whatsapp, email or any any mini tiny notification comes up while I'm on the phone, what I do is to put the phone on silent while having a phone call, or turn off each and every notification app.

    I have looked on the Android phone and there is no way to turn this off, it used to be on Android 7, but the updates took this off.

    There is also another sound that almost burns my ear everytime: when you hang up or the phonecall looses signal, then it sounds a HUGE beep, I can't understand this Google guys, in a single button, TURN OFF ALL THOSE ANNOYING SOUNDS.

    You should be able to have a simple phone call without interruptions.
    08-07-2019 12:34 PM
  6. PapaGary's Avatar
    Uh, I have a G7 on Android 9 and I don't have these issues.
    maxman1 likes this.
    08-07-2019 09:06 PM

Similar Threads

  1. Replies: 4
    Last Post: 05-01-2019, 09:08 AM
  2. Two notifications after AT&T update
    By Turp386 in forum Samsung Galaxy Note 9
    Replies: 8
    Last Post: 03-29-2019, 08:07 AM
  3. Disable notifications by time
    By Android Central Question in forum Samsung Galaxy Note 9
    Replies: 2
    Last Post: 03-29-2019, 06:04 AM
  4. Note 9 android (sprint) can't call a specific number
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-28-2019, 04:42 PM
  5. Can't answer incoming calls on my Samsung s9+
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-28-2019, 10:33 AM
LINK TO POST COPIED TO CLIPBOARD