10-10-2013 09:24 AM
57 123
tools
  1. Jlb139's Avatar
    I was having this issue for the last several days but it seems to have stopped as of today. It could be just coincidental, but I updated the TalkBack app in the Play Store and the issue with every text being read aloud went away. It's also weird that TalkBack wasn't appearing in my "Needs to be updated" section but when I clicked on it, an update was available. Hope this helps.
    09-02-2013 11:15 AM
  2. duke1231's Avatar
    I just bought the phone about 3 hours ago, and I haven't had this issue that everyone has been talking about.
    09-02-2013 12:12 PM
  3. bp3dots's Avatar
    I had this problem too, did a factory reset. I hadn't put driving mode back on, but I will and see if it's still happening.
    09-02-2013 01:22 PM
  4. asylvia's Avatar
    after disabling talk to me service, how do you enable it?

    I think I got it to stop by disabling the Motorola Assist Talk to Me service under All Apps. A temporary fix but it doesn't seem to affect anything else by disabling it.

    Sent from my XT1058 using Tapatalk 4
    09-03-2013 11:55 AM
  5. whtchdr's Avatar
    It will now be listed at the bottom of your application list under the "all" column instead of in alphabetical order. Just scroll all the way down and click on it.

    Sent from my XT1058 using Tapatalk 4
    09-03-2013 12:34 PM
  6. snookasnoo's Avatar
    that is correct, it is not 100% touchless.
    That is surprising. I would expect it to be totally touchless.
    09-03-2013 12:48 PM
  7. Valaar's Avatar
    Hey all, I posted this question to Motorola over at their official forum. One of their MOTOXPRT's or forum managers replied and said he was submitting this issue to the dev team. I highly suggest anyone here who's having this issue too, visit the page and let them know. Perhaps with more input, we can figure out what's causing the damn annoyance.

    https://forums.motorola.com/posts/1d412ab123

    Later

    Valaar (aka TechHog)
    09-03-2013 02:15 PM
  8. asylvia's Avatar
    great, thanks Valaar

    Hey all, I posted this question to Motorola over at their official forum. One of their MOTOXPRT's or forum managers replied and said he was submitting this issue to the dev team. I highly suggest anyone here who's having this issue too, visit the page and let them know. Perhaps with more input, we can figure out what's causing the damn annoyance.

    https://forums.motorola.com/posts/1d412ab123

    Later

    Valaar (aka TechHog)
    09-03-2013 02:30 PM
  9. bp3dots's Avatar
    After using this today, the problem seems solved. I did the Talkback update via the play store, after a factory reset. YMMV, but worth a shot.
    09-03-2013 09:05 PM
  10. lilnate's Avatar
    ive spent the last three hours trying to figure this out, but didnt. I couldnt google it cause apparently downloading my apps used up all my prorated 2gb of data for the rest of the month, i already miss unlimited...Hopefully this **** gets fixed soon, its the most annoying thing ive ever had happen to a phone
    09-04-2013 12:13 AM
  11. asylvia's Avatar
    what did you change to get it to work?

    After using this today, the problem seems solved. I did the Talkback update via the play store, after a factory reset. YMMV, but worth a shot.
    09-04-2013 08:33 AM
  12. Strawdawg's Avatar
    He said he did the Talkback update from the play store
    09-04-2013 08:45 AM
  13. Raring's Avatar
    FWIW, this issue with Assist talking all the time was raised in one of the very early reviews of the Moto X as a critical bug. Engineers assured the journalist they were already working on the problem. Looks like a manual update for Talkback is the solution. Anyone have the problem post-update?
    09-04-2013 11:06 AM
  14. theobject's Avatar
    I did a manual update for TalkBack and I still have the same issue. TalkBack is even turned off on the accessibility settings. Finding this quite annoying.

    Update:I disabled Motorola Assist Talk to Me and now I don't get the screen at all just a notification in the notification bar. So it appears to be related to that app.
    09-04-2013 08:41 PM
  15. ffemt300's Avatar
    Disable Motorola Assist Talk To Me. This fixed the issue for me...for now. I hope they fix this soon.
    09-05-2013 04:49 PM
  16. bp3dots's Avatar
    Disable Motorola Assist Talk To Me. This fixed the issue for me...for now. I hope they fix this soon.
    Does it still read your messages when actually driving though?
    09-05-2013 07:38 PM
  17. mkreef's Avatar
    Reading this thread and one on the moto forums has really soured me on this phone. All the reviews had me itching to get it, but I think I'll wait for some of these bugs to be worked out (and maybe the Q4 price drop?) The driving mode and voice assist is the number one feature for me. And having my phone talk when its in silent mode would definitely be embarrassing at work
    09-05-2013 08:31 PM
  18. Progenitor42's Avatar
    Was just going through this same issue. I posted my solution in a thread I had made. Here is what I did.

    Manually updated TalkBack. Verified TalkBack was turned off. In the app settings I unchecked the box next to "speak notifications when screen is off". I then had someone send me a test SMS. No more voice.

    Sent from my XT1060 using AC Forums mobile app
    09-14-2013 12:22 PM
  19. tk-093's Avatar
    Just got my X today. I'm having the same issue. Where is that checkbox you are talking about?

    Sent from my XT1060 using AC Forums mobile app
    09-16-2013 11:13 PM
  20. clif3247's Avatar
    Just got my X today. I'm having the same issue. Where is that checkbox you are talking about?

    Sent from my XT1060 using AC Forums mobile app
    When you go to Settings>Accessibility, click TalkBack on the top. Verify it is off then click Settings at the bottom. There you will be able to check/uncheck whatever boxes you need.

    Hope this helps. I'm not sure if this is the fix or if disabling Motorola Assist Talk to Me is what did the trick. Hope they fix this bug
    09-18-2013 09:49 AM
  21. kinime77's Avatar
    I figured it out... go to settings -> apps -> all -> Moto Assist Talk to me -> Disable. (You can always re-enable there if you want it while driving).
    Aquila and davidnc like this.
    09-18-2013 09:44 PM
  22. SteenAZ's Avatar
    This is a sad development for a phone that otherwise I really like. A key selling point for me was the drive mode so turning it off to keep every call and text I get from being announced is a real downer. Please let's keep this thread alive so we can follow if it gets fixed. Worse yet I work for AT&T and this is not something I want to show off to my coworkers. I am the only person on my team with this phone.
    09-22-2013 11:01 AM
  23. davidnc's Avatar
    I haven't this issue of it to not stop talking if you disable like shown in post #46
    09-22-2013 11:09 AM
  24. bp3dots's Avatar
    This is a sad development for a phone that otherwise I really like. A key selling point for me was the drive mode so turning it off to keep every call and text I get from being announced is a real downer. Please let's keep this thread alive so we can follow if it gets fixed. Worse yet I work for AT&T and this is not something I want to show off to my coworkers. I am the only person on my team with this phone.
    Did you update the talkback app in the play store? That fix worked perfectly for me, and I haven't had to disable anything.
    09-27-2013 06:46 PM
  25. TechTinker's Avatar

    Doesn't this update fix it?
    09-27-2013 07:50 PM
57 123

Similar Threads

  1. What app are you using to block texts when you are sleeping?
    By blue lion in forum Samsung Galaxy S4
    Replies: 27
    Last Post: 09-15-2014, 07:37 PM
  2. Droidx2 just won't curse anymore. Voice to text
    By flampher in forum Motorola Droid X2
    Replies: 2
    Last Post: 11-02-2013, 01:56 PM
  3. Moto X block calls and txt
    By trido#AC in forum Moto X (2013)
    Replies: 8
    Last Post: 10-31-2013, 07:19 AM
  4. Moto X Power Saver?
    By Stang68 in forum Moto X (2013)
    Replies: 2
    Last Post: 08-28-2013, 05:13 PM
  5. Group messaging after update
    By Latino293 in forum AT&T Galaxy S III
    Replies: 0
    Last Post: 08-27-2013, 04:03 PM
LINK TO POST COPIED TO CLIPBOARD