05-16-2015 01:41 AM
39 12
tools
  1. techitrucker's Avatar
    This may sound dumb, but try Settings/Bluetooth/ and check the phone and multimedia boxes. My husband's Moto X won't speak the phone's nav instructions through the car speakers unless he turns the multimedia OFF, but then he can't play music from the phone through the car speakers.
    2013 Jeep Grand Cherokee Trail.
    Also, EVERY call made from the car is ended as soon as the other person picks up. He really hates his Moto X. It freezes and resets itself often. He couldn't get into his Verizon app until he called Verizon from another phone and reset some things.
    Thanks for the multimedia tip. After doing that I could finally hear voice to text while connected. What works for me as a temp solution until moto gets this bt thing licked is to hook the phone up thru the aux port at the same time. Voice to text and media audio play over that and phone calls still come over BT. Voice commands only go thru the phone mic though doing it that way so you need to have the phone in a good place to do the Google Now stuff. This crap with Moto seems to happen every other update. By now you'd think they would know that their own bt stack is crap.

    Posted via Android Central App
    02-15-2014 04:16 AM
  2. Jim Cushing's Avatar
    I am having a similar problem with my Moto X and 2013 Subaru Outback. Bluetooth doesn't automatically hook up with my stereo either. I can get it to connect by messing with the settings but it wont automatically connect when I enter the car. When it does connect, it says no phone but I can play music. This didn't happen when I was using my old Droid Razr in this car. It would connect as soon as I entered my car and the phone and media would work perfectly. I really want to like this phone but am wondering if I should have kept my old trusty Razr. Anyone figured this out yet?
    03-23-2014 12:37 PM
  3. techitrucker's Avatar
    You might try removing the car in Bluetooth, turning off the phone then re-pair them after you reboot the phone. Also make sure you keep and eye on screen for the popup that asks if you want to sync your phone book. That can disappear before you notice it and cause problems. If you want announcements and text messaging read to you go into the Assist app then driving and click the link for Bluetooth issues then choose alternate audio sources. You may also want to check with Suburu and make sure there are no updates for your stereo. New firmware may also resolve some issues. The issues your having aren't necessarily the phone in this case. Most likely the car is on BT 2.0 like your old RAZR was and just needs and update to play nice. You would must likely have the same problem with any modern phone if that is the case. BT is voodoo.

    Posted via Android Central App
    03-24-2014 02:46 AM
  4. KWKSLVR's Avatar
    Interesting stuff. Just to add another vehicle to the list, I borrowed my folk's 2013 Toyota Camry for a few days and noticed that the Moto X wouldn't do anything more than recognize the car as a trusted device and make voice calls. Total bummer.

    Posted via Android Central App
    03-24-2014 05:18 AM
  5. mekano's Avatar
    I think it's a Uconnect issue. Mine does phone calls fine but playing music it plays it in fast forward and skips. Go to the dealership and see if there is an update for your vehicles Uconnect

    Optimizing my Moto X
    03-24-2014 09:01 AM
  6. mekano's Avatar
    I have a 2011 Compass

    Optimizing my Moto X
    03-24-2014 09:01 AM
  7. techitrucker's Avatar
    Interesting stuff. Just to add another vehicle to the list, I borrowed my folk's 2013 Toyota Camry for a few days and noticed that the Moto X wouldn't do anything more than recognize the car as a trusted device and make voice calls. Total bummer.

    Posted via Android Central App
    That may also be the stereo. A lot of vehicles with touch screens, for instance my Kia don't do A2DP. You either need to use aux or a USB cable. Makes playing audio books and podcasts a *****. I guess they figure you'll just store your studio locally.

    Posted via Android Central App
    03-24-2014 11:19 AM
  8. compuguy1088's Avatar
    I have a Subaru Impreza 2011 with Bluetooth. Have had this problem with multiple phones off and on (HTC One M7, M8, OnePlus One, Sony Z2. Since reading this post, I've come to conclusion that the Bluetooth on the stock unit sucks. Anyone have recommendations for a good replacement head unit?
    10-02-2014 11:57 AM
  9. KingKondiment's Avatar
    Fine people of AC, today I bring you a solution to all of your Subaru Bluetooth problems.

    I started writing up a back story on my woes w/ my Subaru Impreza and my phone's Bluetooth connectivity, but I'm going to cut right to the chase. Follow these steps:

    - Delete pairing in stereo menu, and CAR M_MEDIA from Bluetooth devices menu on phone
    - Re-pair device using voice control buttons on steering wheel

    It's that simple. Rejoice, for all the Bluetooth pleasures are yours!!
    10-03-2014 03:14 PM
  10. jordan_patten's Avatar
    I experienced the skipping issue as well. I wasn't even moving the phone though when I experienced it. The phone did seem to connect fine however and I didn't notice any static issues. It seemed to skip on some songs but not others; was streaming music from Google Play. My vehicle is a 2012 Jeep with the UConnect bluetooth system.

    Posted via Android Central App
    I also have a 2012 jeep and experience skipping with spotify.
    10-24-2014 09:52 AM
  11. Nick Tates's Avatar
    This seems to be a generic bluetooth streaming issue, not related to being connected to a specific vehicle. I have a 2012 Moto X. I have encountered this issue over the last few months with my car (2012 Subaru Legacy). The issue sseems to happen periodically on the drive, every few minutes. I also have the issue when I am streaming at home, where the WiFi has been on and off. There might be an activity running on that might be slowing down the phone and affecting the streaming. Since the Moto X has that shake feature to go straight to camera, movement detection could take some processing time and cause interruption. I've noticed that as I navigate around my phone while streaming, it interrupts the playing. I do not know the exact issue, but from what I have seen (connections to 5 different bluetooth devices, two being different car models), when my phone is doing any kind of work on its main thread (navigating the phone at times to some background thread running), my streaming interrupts and stutters, but keeps playing. I have repaired too and did not see a difference with any device.
    11-24-2014 09:41 AM
  12. DoktorJohn's Avatar
    Good morning and I am having issues with my Droid Turbo's bluetooth. I have it synced to my vehicle and can place calls fine thru the bluetooth but when using the sync for my music nothing plays and before that I have a LG phone and never had a problem with it. What do you think could be causing the issues/problems with the streaming to my vehicle?
    05-15-2015 10:15 AM
  13. dmark44's Avatar
    Bluetooth streaming has stuttered in the car for my 2013 Moto X pretty frequently lately. It's at its worst for the first 5-10 minutes then settles down.

    I though it was my car stereo because my Bluetooth ear buds still worked well. But they were stuttering for the first 10 minutes of my running workout today and then once in a while after that.

    Sent from my Moto X
    05-16-2015 01:04 AM
  14. cdmta's Avatar
    I've figured out that in my Prius it is positional. I move the phone in a certain position and it gets better. May want to try that.
    05-16-2015 01:41 AM
39 12

Similar Threads

  1. Replies: 24
    Last Post: 02-22-2014, 06:35 PM
  2. Straight Talk with android / no mms
    By tylerhudson01 in forum Other US Carriers
    Replies: 2
    Last Post: 02-14-2014, 12:59 AM
  3. N4 with AT&T
    By grunt0300 in forum Google Nexus 4
    Replies: 30
    Last Post: 09-06-2013, 05:10 PM
  4. Potential bluetooth issue
    By xweb10 in forum Motorola Droid MAXX
    Replies: 8
    Last Post: 09-02-2013, 01:26 PM
  5. Samsung Galaxy 4 64GIG SD/Music ISSUE. HELP
    By Dann_93 in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 09-02-2013, 11:45 AM
LINK TO POST COPIED TO CLIPBOARD