1. esone1ll's Avatar
    Hi, all. I have an AT&T branded X, running the factory software at 4.2.2.

    When I go to the Play Store to update Motorola Connect and Assist, the store says they aren't compatible with my device.

    What's weird is that other Motorola store updates, like camera and Touchless Control, worked properly.

    Any ideas? Thanks!

    Posted via Android Central App
    11-22-2013 07:05 AM
  2. Chase Lilly's Avatar
    You need Kitkat for those to work.
    11-22-2013 07:12 AM
  3. esone1ll's Avatar
    You need Kitkat for those to work.
    Ah, got it. I thought they were only *compatible* with KitKat, not that they *required* it. Thanks!
    11-22-2013 08:38 AM

Similar Threads

  1. Where is the 4.3 Update for the Verizon Galaxy S3?
    By dadathepanda in forum Verizon Galaxy S III
    Replies: 410
    Last Post: 12-23-2013, 09:22 PM
  2. galaxy s3 4.3 update help
    By Bradley Moore1 in forum AT&T Galaxy S III
    Replies: 3
    Last Post: 11-22-2013, 02:49 PM
  3. 4.4 update gone wrong (Nexus 4)
    By Fedya Brodski in forum Android 4.4 KitKat
    Replies: 2
    Last Post: 11-22-2013, 09:12 AM
  4. Help me please... Nexus 4 update to Kit Kat error
    By ollwien in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 11-22-2013, 07:47 AM
  5. Updated to 4.3 (the update available this morning 22nd nov 13)
    By Dareel in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 11-22-2013, 04:28 AM
LINK TO POST COPIED TO CLIPBOARD