12-31-2013 05:03 PM
54 123
tools
  1. mynameis's Avatar
    Just be sure to turn off iMessage on the iPhone while it still has active cellular service. If you use any other iOS devices that you also have iMessage turned on and associated with your cell number be sure to check iMessage settings on them and unselect your cell number as an option on that device, this goes for Mac computers too if you use them. You can also unregister your iPhone from your Apple ID if you are not going to use it anymore but I only do that if I'm selling the device. I have switched back and forth many times and only use the first steps of turning off iMessage on my devices that use my cell number and it has always worked without issue. The real problems happen when people don't turn iMessage off before they activate their cell number on a non-apple phone.
    So, today was the day. I went out and got my Moto X. I turned off iMessage last night and unfortunately I have hit the "Not getting texts" wall. I still kept my iPhone because of this reason. Anybody have any ideas of what else I could do? I'm sure there is a simple fix. Thanks in advance!

    Other than the texts, loving my X. Glad I made the switch back.

    Sent from my XT1056 using Tapatalk
    12-31-2013 03:50 PM
  2. androidatic's Avatar
    My son got an S4 for Christmas. We made sure he turned off iMessage, Facetime and also removed the iPhone from his profile on iCloud. It took over 24 hours for all texts to start to come through. On Christmas morning my wife was not able to text him but my daughter was (they both have iPhones). It is all good now.

    Sent via the X!
    12-31-2013 04:10 PM
  3. mhunter6378's Avatar
    So, today was the day. I went out and got my Moto X. I turned off iMessage last night and unfortunately I have hit the "Not getting texts" wall. I still kept my iPhone because of this reason. Anybody have any ideas of what else I could do? I'm sure there is a simple fix. Thanks in advance!

    Other than the texts, loving my X. Glad I made the switch back.

    Sent from my XT1056 using Tapatalk
    The problem may not be on your end. In iOS 6 and iOS 7 there is a setting within general settings under Messages, Send as SMS, and it has an on/off slider switch. By default iPhones have this function turned off when using iMessage. If you send a text to someone you have previously texted who has an iPhone and the new text is received in a conversation thread started while you used an iPhone and their iPhone is setup up with the SMS switch in the off position they will receive your text but any reply they send back will fail. I had this very same situation happen to me today with a friend who I have not texted since I used an iPhone. My text showed up in an old iMessage thread and he replied within that thread and it failed. When I saw him, we checked his phone and SMS was turned off as I described. When turned on I got his text without any problem. This situation only seems to occur as described when the text are exchanged within a thread where you once used iMessage and now are not. New text conversation threads don't seem to be affected by this.
    21stNow likes this.
    12-31-2013 04:34 PM
  4. mynameis's Avatar
    The problem may not be on your end. In iOS 6 and iOS 7 there is a setting within general settings under Messages, Send as SMS, and it has an on/off slider switch. By default iPhones have this function turned off when using iMessage. If you send a text to someone you have previously texted who has an iPhone and the new text is received in a conversation thread started while you used an iPhone and their iPhone is setup up with the SMS switch in the off position they will receive your text but any reply they send back will fail. I had this very same situation happen to me today with a friend who I have not texted since I used an iPhone. My text showed up in an old iMessage thread and he replied within that thread and it failed. When I saw him, we checked his phone and SMS was turned off as I described. When turned on I got his text without any problem. This situation only seems to occur as described when the text are exchanged within a thread where you once used iMessage and now are not. New text conversation threads don't seem to be affected by this.
    It works now!.. I think! I had to turn on "send SMS" on my girlfriends phone for it to work. But I can't do that with everyone. I switched to using hangouts instead of the default SMS and my cousin started texting me. It worked completely fine with her and she has an iPhone, but I'm kinda worried that it's not gonna work with others for some reason. Maybe just paranoia, but I guess I'll have to wait and see.

    Sent from my XT1056 using Tapatalk
    12-31-2013 05:03 PM
54 123

Similar Threads

  1. Note 3: play music through bluetooth to car stereo?
    By clevin in forum Samsung Galaxy Note 3
    Replies: 22
    Last Post: 08-26-2017, 06:01 AM
  2. u8800 Pro Upgrade to ICS fails
    By bob972 in forum Huawei
    Replies: 2
    Last Post: 01-01-2014, 10:48 AM
  3. Replies: 43
    Last Post: 12-27-2013, 08:00 AM
  4. It is still time to buy an HTC one ?
    By lurkerzz in forum HTC One M7
    Replies: 20
    Last Post: 11-29-2013, 05:57 PM
  5. Replies: 1
    Last Post: 11-26-2013, 05:43 AM
LINK TO POST COPIED TO CLIPBOARD