1. NoAck's Avatar
    MotoMaker build problem-motoxflaw.jpg

    I just got my phone yesterday. I noticed that on the lower left edge of the screen, I can feel some roughness. See red section in the attached image. Seems like the glass is not quite flush with the body. So when swiping horizontally and can feel a sharp edge. The other edges of the phone are smooth. Anyone else have the same problem with their screens?
    12-17-2013 02:44 PM
  2. snoking's Avatar
    Did you contact Motorola? We are a two M.X family and both are fine! Chris
    12-17-2013 02:55 PM
  3. NoAck's Avatar
    Did you contact Motorola? We are a two M.X family and both are fine! Chris
    I emailed them and they said to call to get a refund and re-design the phone. Kind of disappointed to have to return.

    Posted via Android Central App
    12-17-2013 03:10 PM
  4. omega1300's Avatar
    That's annoying - especially with how long you waited to get it. I suppose this is what comes of them getting slammed with orders and rushing them out.

    I just received my order, I haven't activated the phone yet but it looks okay (though I had to pop a corner of the backing into place).

    However, the case I ordered was not shipped (despite being on the packing list), and the skips I ordered separately cannot be found with the tracking number (and its been over a week since they shipped).

    So, don't mean to hijack your thread, but at least you're not alone in having your order come through less than perfect!

    Posted via Android Central App
    12-17-2013 03:16 PM
  5. still1's Avatar
    I emailed them and they said to call to get a refund and re-design the phone. Kind of disappointed to have to return.

    Posted via Android Central App
    that sucks but i kindoff like it... maybe if i see it in person i wouldn't like it
    12-17-2013 03:24 PM
  6. NoAck's Avatar
    That's annoying - especially with how long you waited to get it. I suppose this is what comes of them getting slammed with orders and rushing them out.

    I just received my order, I haven't activated the phone yet but it looks okay (though I had to pop a corner of the backing into place).

    However, the case I ordered was not shipped (despite being on the packing list), and the skips I ordered separately cannot be found with the tracking number (and its been over a week since they shipped).

    So, don't mean to hijack your thread, but at least you're not alone in having your order come through less than perfect!

    Posted via Android Central App
    Hopefully this was just an anomaly and not an overall quality issue.

    Posted via Android Central App
    12-17-2013 03:25 PM

Similar Threads

  1. New Tablet/Authentication Problem with Wifi
    By p1emtangel in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 25
    Last Post: 04-10-2017, 12:34 PM
  2. problem z samsungiem
    By michuuu26 in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 12-17-2013, 02:28 PM
  3. Problem with freeing up internal storage
    By Fern Porras in forum LG Optimus G
    Replies: 1
    Last Post: 12-17-2013, 10:44 AM
  4. Samsung Galaxy S4 - Photo editing problems
    By ktrem626 in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 12-17-2013, 08:51 AM
  5. Android Jelly Bean 4.3 Update Problem
    By seangamadia in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 12-17-2013, 02:49 AM
LINK TO POST COPIED TO CLIPBOARD