1. bang_bang's Avatar
    I've had my motox for about a week now. My text messaging is extremely slow. When I bring up a conversation with somebody it takes several seconds for the conversation to display. Also, when I send a text that takes a lot of time to display. It's overall just really laggy. Anything I can do about that?

    Sent from my XT1058 using Tapatalk
    12-18-2013 09:42 AM
  2. tonymhoffman's Avatar
    I've had my motox for about a week now. My text messaging is extremely slow. When I bring up a conversation with somebody it takes several seconds for the conversation to display. Also, when I send a text that takes a lot of time to display. It's overall just really laggy. Anything I can do about that?

    Sent from my XT1058 using Tapatalk
    You using hangouts or stock message service?

    Posted via Android Central App
    12-18-2013 11:21 AM
  3. bang_bang's Avatar
    You using hangouts or stock message service?

    Posted via Android Central App
    Stock message service.

    Sent from my XT1058 using Tapatalk
    12-18-2013 11:31 AM
  4. tonymhoffman's Avatar
    Stock message service.

    Sent from my XT1058 using Tapatalk
    Have you tried clearing the cache and app data for message service?

    You can find that by going to settings then apps then slide to all and scroll to message.

    Let me know if this helps?

    Posted via Android Central App
    Vamsi Kiran3 likes this.
    12-18-2013 11:40 AM
  5. bang_bang's Avatar
    I cleared the cache. Seems to have helped a little, but I don't feel like that's something I should have to do frequently.

    Sent from my XT1058 using Tapatalk
    12-18-2013 11:49 AM
  6. tonymhoffman's Avatar
    I cleared the cache. Seems to have helped a little, but I don't feel like that's something I should have to do frequently.

    Sent from my XT1058 using Tapatalk
    Its definitely not! What keyboard are you using?

    Posted via Android Central App
    12-18-2013 11:59 AM
  7. tonymhoffman's Avatar
    I ask because I've used swype and it was terrible slow.

    How new are you to the device, how long have you had it?

    You may consider a factory reset.

    Posted via Android Central App
    12-18-2013 12:02 PM
  8. bang_bang's Avatar
    I ask because I've used swype and it was terrible slow.

    How new are you to the device, how long have you had it?

    You may consider a factory reset.

    Posted via Android Central App
    I'm using the stock keyboard. I've had the phone about a week and a half now.

    Sent from my XT1058 using Tapatalk
    12-18-2013 12:09 PM
  9. tonymhoffman's Avatar
    I'm using the stock keyboard. I've had the phone about a week and a half now.

    Sent from my XT1058 using Tapatalk
    I'd love for someone else to chime in but you may want to factory reset. You shouldn't have any lag or need to clear caches routinely. My messaging is very quick. I've had the lag issue when I first got my phone but I always factory reset when I get a brand new device.

    Posted via Android Central App
    12-18-2013 12:15 PM
  10. bang_bang's Avatar
    I'd love for someone else to chime in but you may want to factory reset. You shouldn't have any lag or need to clear caches routinely. My messaging is very quick. I've had the lag issue when I first got my phone but I always factory reset when I get a brand new device.

    Posted via Android Central App
    Ok, how do I go about doing the reset? Will I have to re-download kit Kat?

    Sent from my XT1058 using Tapatalk
    12-18-2013 12:22 PM
  11. j.howe3887's Avatar
    I haven't touched the stock messaging app... Only hangouts and swift keyboard and it has been lightning fast.

    Posted via Android Central App
    12-18-2013 12:33 PM
  12. Ry's Avatar
    I use the stock app (and Motorola Connect on my laptop). No apparent delays on my Verizon Moto X (XT1060).
    12-18-2013 12:51 PM
  13. tonymhoffman's Avatar
    Ok, how do I go about doing the reset? Will I have to re-download kit Kat?

    Sent from my XT1058 using Tapatalk
    You will not have to redownload kit Kat.

    You can do a simple reset by going into settings then back up and restore. There is an option to factory reset.

    Keep in mind you will lose all data on the phone, this includes texts, pictures and apps. However when you log into your Google account once reset is finished Google will begin to reinstall all the apps you had before reset. So if data is limited do this over WiFi.

    Posted via Android Central App
    12-18-2013 02:57 PM
  14. Vamsi Kiran3's Avatar
    This really helped me..thanks a lottt
    12-11-2015 11:50 PM

Similar Threads

  1. Galaxy S4 Extremely Slow After 4.3 Update
    By RyyanJamess in forum Samsung Galaxy S4
    Replies: 14
    Last Post: 11-03-2015, 12:25 PM
  2. Please help. New Goophone i5C has no icons...just black screen with Chinese text
    By oldbutreliable in forum General News & Discussion
    Replies: 3
    Last Post: 12-20-2013, 07:25 AM
  3. How do I get icons but not text on my home screen?
    By cybernutte in forum Google Nexus 7 Tablet (2013)
    Replies: 7
    Last Post: 12-18-2013, 04:39 PM
  4. deleted
    By jmettee in forum AT&T Samsung Galaxy S4
    Replies: 1
    Last Post: 12-18-2013, 10:04 AM
LINK TO POST COPIED TO CLIPBOARD