09-18-2014 05:13 PM
56 123
tools
  1. KyonCoraeL's Avatar
    Sorry, I was really busy for the last two months but if you haven't figured it out yet. You can set your network speed through the following steps: Settings->Under Wireless & Networks More... -> Mobile Network Settings-> Preferred network type

    I changed mine from LTC to 3G. I get alot less disconnects during the day when the mobile network signal bar is yellow or grey in the battery app.
    06-11-2014 08:05 PM
  2. Tarek Midani's Avatar
    all I know on my end is that when I reboot my phone it stops or prevents the problem for me. Maybe it doesn't work for everyone or there are different issues for different people. People discus this all over the place all the time, so I give my input on what I do and what has worked for me. When a lot of the people are ones who had no problem on 4.4 or 4.2.2 but get considerably less battery life with 4.4.2... then it is a bug.
    I have exactly the same problem, after the update to 4.4.2 and it does me mad because there is literally nothing u can do about except wait for the update on my Moto X. Thanks for clarifying it for me. At least I'm not the only one.
    Please people stop giving us the same old-school tips. "turn off this turn off that" Seriously gives, nothing works, or nothing is stopping Android OS drainage
    08-03-2014 06:04 PM
  3. ehsaneziaei2's Avatar
    It is about one month that i bought my Moto X. It is great in every aspect but recently something strange about the battery life happens for me. when the battery percentage goes about 15-20% suddenly when my phone is in standby it jumps below 10%. and something more strange is that today when i unplug my Moto X from charger it was charged about 94% but after ten minutes that it was unplugged suddenly it shows 100% for battery percentage!!!
    does someone else experienced this situation?
    I am so confused about that...
    08-23-2014 09:52 AM
  4. 4runnerbrett's Avatar
    Hmm mine can only be set from 2g to automatic. I wish I had a 3g setting. Yes I know I can download a app to change it. But hate having extra apps for this stuff.
    08-24-2014 12:53 PM
  5. Monty Sharma1's Avatar
    There is some similar problem with my motox. Its been 3 months i have bought this phone. It like, I plug my fone for charging, it is showing 290 percent and after 10 mins it shows 100% charged. what is this problem. my battery also drains very quickly
    09-17-2014 10:15 AM
  6. Puzzlegal's Avatar
    I think my battery life got a lot worse with KitKat.
    09-18-2014 05:13 PM
56 123

Similar Threads

  1. Galaxy S3: battery saving setup
    By saab61 in forum Samsung Galaxy S3
    Replies: 4
    Last Post: 04-01-2014, 08:51 AM
  2. Battery problem
    By jennad123123 in forum AT&T Galaxy S III
    Replies: 3
    Last Post: 03-30-2014, 05:42 PM
  3. SN3, Kit Kat and battery charge
    By wendy5001 in forum Android 4.4 KitKat
    Replies: 2
    Last Post: 03-30-2014, 11:13 AM
  4. Nexus 4 draining battery while charging and in use
    By CMac o in forum Google Nexus 4
    Replies: 0
    Last Post: 03-29-2014, 06:30 PM
LINK TO POST COPIED TO CLIPBOARD