1. jmettee's Avatar
    This has been happening for about 2 weeks or so now (before the KK 4.4.4 update). I don't know what update may have changed S-to-T for the words, but it seems to be laggy now & also doesn't type the last word (or punctuation) until you start speaking the next sentence. It's like it's a whole 1 word behind in translation.

    Anyone else noticed this or know what app update caused it. My wife said she thinks she's noticed it to, but she's on a Sammy S4. Google Text-to-Speech shows being updated back in May. Google Search shows it was recently updated (8/12), but I wouldn't think that goofed up the general Speech-to-Textn Hangouts (which was updated 8/8). Gmail is doing the same exact thing, so I don't think it's related to Hangouts. I just tested it with Gmail, every time, it lags by 1 word & doesn't show it until moving onto the next word. This makes ending a sentence difficult.
    08-18-2014 01:08 PM
  2. UJ95x's Avatar
    Have you tried clearing the cache for the text to speech app/engine on your phone? It should be in settings > apps > all.
    Might be a bug with the new update, but it's worth a try to see if that works.
    08-18-2014 01:42 PM
  3. KWKSLVR's Avatar
    Have you changed the language pack? I know British English acts differently on mine in comparison to American English.

    Posted via Android Central App
    08-18-2014 09:36 PM
  4. roadrunner_clams's Avatar
    I also noticed a lag in the speech to text over the last few weeks . I just did the update to 4.4.4 and the speech to text still seems to hang up on the last word or two at the end of the sentence. I had to wipe the cache to cure another problem with the phone, but that did not solve the lag in the speech to text. Not sure what else to try.
    08-18-2014 10:42 PM
  5. jmettee's Avatar
    I tried wiping the app cache & it didn't help. I cleared a few other app caches also while I was there (Hangouts, Gmail, few others).

    Going to wipe the handset cache now after I go find the boot button sequences.

    Posted via Android Central App
    08-19-2014 06:08 AM
  6. roadrunner_clams's Avatar
    The instructions for wiping the handset cache in stock recovery are here:

    Try it, but it did not help me.
    08-19-2014 07:53 AM
  7. jmettee's Avatar
    Yeah, I had found that, but thanks. Didn't help me at all but it did take like 5 full minutes to clear the cache so hopefully it cleaned quite a bit of stuff up otherwise.

    Posted via Android Central App
    08-19-2014 04:49 PM
  8. Gordon D Miller's Avatar
    I have also been having this issue since the 4.4.4 update. Wiped app and system cache, but didn't help. For now, I have been hitting tap to pause after the dictation and it finishes the last word with punctuation.

    Posted via Android Central App
    08-19-2014 06:23 PM
  9. roadrunner_clams's Avatar
    Thanks for the tip. Tapping the pause does the finish the final word and punctuation for me also.
    08-20-2014 02:29 PM
  10. jmettee's Avatar
    I looked back through my apps for anything updated earlier this month. Ask I really find that I thought it could be was Google Search. I uninstalled all updates (back to stock), but this didn't fix it. I don't see anything else that was recently updated that the change would be related to (even on my wife's S4).

    It was nearly perfect for me & something goofed it up. I hate this seemingly little issue so much.

    Posted via Android Central App
    08-20-2014 04:00 PM
  11. oregondroid's Avatar
    I am having this issue also. vzw using stock texting. My wife has the same phone bought at the same time with no issue.
    08-28-2014 04:00 AM
  12. oregondroid's Avatar
    Has anyone had any luck fixing this?
    09-01-2014 07:06 AM
  13. hastingsmciver's Avatar
    Same issue, lagging last word/punctuation, Galaxy s5. Maddening. Used to work perfectly.
    09-02-2014 06:18 PM
  14. hastingsmciver's Avatar
    Also, is this is as close as I will come to leaving direct feedback with Google?
    09-02-2014 06:36 PM
  15. ScottMGS's Avatar
    Also, is this is as close as I will come to leaving direct feedback with Google?
    This is probably far away from Google as possible (though some might monitor it). I'd try circling Android and Google on Google+ and try there.
    09-02-2014 07:21 PM
  16. cd619's Avatar
    Anyone figure this out??
    01-30-2015 05:49 AM

Similar Threads

  1. VZWAVSService has stopped, I got it fixed.
    By Paul Giller in forum Samsung Galaxy S5
    Replies: 11
    Last Post: 06-21-2016, 08:40 PM
  2. Galaxy S5 Call waiting NOT showing up.
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 05-29-2015, 02:29 AM
  3. since 4.4.2 upgrade phone won't connect to wifi
    By granthatchett in forum AT&T Galaxy S III
    Replies: 3
    Last Post: 08-18-2014, 07:14 PM
  4. Strange problem with S3 not turning on
    By TDAYz in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 08-18-2014, 07:10 PM
  5. ssh to android with X11/GUI ?
    By gargavf in forum General News & Discussion
    Replies: 1
    Last Post: 08-18-2014, 03:24 PM