1. mkreef's Avatar
    My 2 year old, stable VZW Moto X running 4.4.4 has been having a lot of WiFi connection problems.

    It sees my home router, but doesn't auto connect. I click Connect, it says "Connecting..." and then nothing happens (no obtaining IP, not connected). I reset my router, nothing happens. I reboot my phone, and it occasionally will connect -- but will randomly drop the connection later.

    I haven't changed my router (or settings) in 6+ months, and all the other devices (iPhone 5s, Note 3, Moto G, various Kindle tables and laptops) all have rock solid WiFi with no problems. I have the same problem at work, so it appears isolated to my Moto X. I even did a full factory reset, which I thought had fixed the problem, until it started happening again about a week after reset. I'm thinking it must be hardware related.

    My monthly average of under 0.5GB data has shot up to 2GB in the last two billing cycles since this problem occurred. I'm almost always at home or at work, and I often find myself using data at home because I don't notice there is no WiFi Connection. Very annoying.

    My 2 year contract is up at VZW and I'm thinking about buying another first gen new in box Moto X off ebay. Love the new ones, but not sure I can live with such a big phone.
    09-07-2015 12:38 PM
  2. B. Diddy's Avatar
    Review this guide to see if any of the tips help: http://forums.androidcentral.com/amb...-problems.html. I'd try turning off the security on the router temporarily, to see if that's interfering. Also, make sure the DHCP range on the router isn't too narrow--you need to have enough addresses available to account for how many devices may want to connect at one time.

    Also, on the phone, go to Settings>Wi-fi, long-press your network and tap Modify Network, then Advanced, and make sure it's set to DHCP, not Static IP.
    09-07-2015 02:21 PM

Similar Threads

  1. Replies: 3
    Last Post: 09-10-2015, 08:27 PM
  2. Anyone's notifications delayed on WiFi?
    By Blipstein in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 09-09-2015, 04:27 PM
  3. Can a Jawbone Blutooth device talk to my phone if it is in airplane mode?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 09-09-2015, 12:25 PM
  4. Replies: 1
    Last Post: 09-07-2015, 02:39 PM
  5. Replies: 1
    Last Post: 09-07-2015, 02:33 PM
LINK TO POST COPIED TO CLIPBOARD