06-23-2018 06:26 PM
94 1234
tools
  1. cw89134's Avatar
    QQQAAZ,

    Thanks for the fix. It worked like a charm.
    11-03-2015 11:04 AM
  2. John_Albert Eadie123's Avatar
    It is a stupid bug. SORRY I UPDATED!
    12-24-2015 03:04 PM
  3. John_Albert Eadie123's Avatar
    Sorry for intemperance. After clearing cache and power rebooting - it is optimizing 2 of 56 apps. So it IS a bug.
    12-24-2015 04:12 PM
  4. castigs's Avatar
    My wife lost her phone and just started using my old moto x which I hadn't used in months. Installed the update did the reset and now getting this "optimizing....." bug. It is happening every time she restarts (doesn't matter if it's plugged in or not}.
    Phone worked great when I used it, regret installing so-called update.

    Posted via the Android Central App
    12-31-2015 10:23 AM
  5. rgdave's Avatar
    This post is now up to 15,000 views, so clearly not an isolated issue and unlikely related to a single corrupt app (unless it's an app we all have on our Verizon Moto X's and can't remove.) Where's Motorola/Verizon on this? I've done the cache wipe thing, as well as removed a lot of unused apps, and it still happens. I don't see the point of doing a full wipe and reset, because from reading posts about this on this forum and others, it doesn't seem to solve the problem and is just a big hassle.
    01-04-2016 10:46 AM
  6. AndreaGM's Avatar
    I've been having a similar issue since this morning. I thought I'd succesfully left my phone charging overnight but it appears that it wasn't the case because when I tried using it when I woke up, the phone would not turn on so I pressed power and the swirling dots appeared and then the "Android" welcome or whatever but then my phone went black again. After this, I figured I should try charging it again and I turned it on but the message "Android starting... Optimizing app 18 of 121." appeared. It went on like this for a while until it turned off again without ever completing the optimization. I turned it on again and now the numbers were different (i.e. 12 of 40 or whatever) and then it turn off AGAIN with completing the optimization and this for several more tries.
    Also worth noting is that the phone won't even turn on if not connected to external power, even the swirling dots won't appear.
    I don't know what's happening and I really need to fix this soon because I don't have another phone and I'm waiting for a really important call.

    Please help a user out
    01-19-2016 10:13 AM
  7. bc2k's Avatar
    If your phone won't turn on unless connected to external power, not sure there is a fix.

    Mine did the optimizing apps this morning for the first time since Lollipop upgrade late last year; I had it on charger during restart, something I don't normally do. Did another restart a little while later (not connected to charger) with no problems.
    01-20-2016 11:12 AM
  8. BiRONIC's Avatar
    [Droid Turbo user]

    i just got this thread off google after this started happening to me.
    anybody know if there is a Turbo thread for it too, or is everyone just using this thread?
    01-30-2016 07:28 PM
  9. FireFly17's Avatar
    I've been having the issue where my phone just turns off as soon as I plug it up, even if it has almost half battery! This is the first time I've had the optimizing thing... Does anyone have any idea why my phone turns off when I plug it up?
    02-05-2016 10:41 PM
  10. Dr Triffid's Avatar
    I've read elsewhere that a "feature" of the phone is that holding the power button down for eight seconds will trigger the optimization. I'll be testing that one shortly.

    Posted via the Android Central App
    02-14-2016 01:12 AM
  11. bhawdeadlydan's Avatar
    Thanks it helped, a lot !
    02-21-2016 08:06 AM
  12. Dr Triffid's Avatar
    I was able to trigger the optimation with an eight-second long press of the power button. I know it doesn't help with the random reboots, but at least here's something to avoid.
    02-22-2016 12:24 PM
  13. Irony58's Avatar
    I'm having the same problem, but unrelated to the state of charging. It doesn't happen, but once in a while my Moto X (2013) shuts off. It just happened and it's probable that the optimization was triggered my greater than eight second press of the power button. So it's good to know that may be the cause of that annoying optimization. The crash is another problem.
    03-15-2016 02:42 PM
  14. sanjith abraham's Avatar
    Method that works for me to avoid app optimization in every boot of moto x 2013 :

    " Never press power button for more than 4-5 sec. to boot it"

    I observed the screen stays dark when its charging even after pressing power button for 4-5 sec. , but keep patience and wait for at least 20-25 sec. , and you will see the boot animation , otherwise try again . Its better to wait for 25 sec. than waiting for 15 -45 min. for app optimization .

    Again " Never exceed 4-5sec. while pressing power button whether charging or not charging and whether you see boot animation or not. "
    03-18-2016 01:16 PM
  15. shubhank bhatia's Avatar
    even this didnt helped.my phones screen is stuck even after switching on, and nothing is being displayed on it , even after waiting for several minutes
    can you please help me out in this situation..
    03-25-2016 12:15 AM
  16. BPW3's Avatar
    Mine just started doing this this week. First time took more than a half hour and three restarts. Yesterday it took ten attempts before it started properly. Phone was not plugged in. I restarted the phone because it was running slowly and seemed unstable. At least it was 1 of 1 apps optimizing! I had a primo HTC1 that never had a problem and got this thing because the other could no longer be used on my network. Shouldn't look a gift horse in the mouth. I was initially satisfied but no more. Never had the problem until that stupid upgrade.
    03-25-2016 09:30 AM
  17. oresteez's Avatar
    This definitely has nothing to do with Verizon, since my phone is on Tmobile and I also have the problem.
    I wish it was because I was holding the power button in for more than 8 seconds, but I have had the phone reboot automatically in my pocket and then start optimizing apps. And it gets hot too! That's how I knew it rebooted.

    Definitely ridiculous and I'll probably never buy another Moto phone again, even though I really loved this phone in the beginning. I feel like their support is lacking. Not to mention I can no longer use my wifi and bluetooth at the same time because they have not fixed that bug either. (If I have bluetooth enabled and connected to a smart device--like a watch or step tracker, then wifi will stop working. This is not a problem if you are using something simple, like headphones. I have had Android phones for a long time and really I'm just tired of having to root them and install Roms and fix my own problems. Dare I say it, I've thought about switching to an iphone. I love Android and I know I will be limited on certain things but there's so many issues I won't have to deal with.

    Either that, or I'll just bite the bullet and get a Samsung. They seem to be a bit better than all of the other Android phone makers right now.
    04-18-2016 01:46 PM
  18. nwaves's Avatar
    I used to have the same problem until I figured out it has to do with how long I keep the power button pressed. I start counting when I press the power button and never keep it pressed past 6-7 seconds. Wait 4-5 seconds see if it starts. If it doesn't, repeat the procedure but don't keep the power button pressed for more than 6-7 seconds or it will optimize your apps. This is happening because in the latest software Motorola forgot to add the vibration to signal you the phone is turning on, so you keep the button pressed waiting for something to happen and that's what's causing the optimization to start.
    04-21-2016 02:58 PM
  19. rjohns69's Avatar
    Don't follow those steps! It will cause your device to optimize your apps because you just wiped all of the optimization information.

    I've noticed that it does the optimization when the tablet is started up after the battery dies. If you keep it charged, and do normal shutdowns or just keep it running it seems to be OK, but my son often uses the tablet until it is dead, then it takes 20 minutes for it to start while it is "Optimizing" the apps (total cr@p if you ask me).

    I'm going to try turning off the battery/power saving mode. Hopefully that will stop the 20 minute optimization.

    Can't believe Android/Verizon would force this cr@ppy update on use. Who wants to wait 20 minutes to use your tablet? Seriously!
    jj2me likes this.
    05-08-2016 11:01 PM
  20. DemonCamber's Avatar
    For what it's worth, I believe it's a bad app somewhere on my system. I'm currently having this issue, but I'm also rooted, running a custom marshmallow rom and kernel, on a moto G xt1042. I'm about to backup my system and data partitions in TWRP and try restoring them over again, that sometimes fixes things to be honest. Other than that, that's all that I can think of. It wasn't always doing this either, so it's most likely a bad app or something got corrupted. I'll report back if I figure out how to fix it.
    05-08-2016 11:45 PM
  21. pallai's Avatar
    many times phone automatically gets restart....
    05-13-2016 05:36 AM
  22. Victor Dulepov's Avatar
    My CAT S40 does exactly the same - self turn-off in the pocket, get heated like crazy, and then start optimizing the apps at startup for some 20 minutes or more before it becomes usable again. Definitely a 5.1 issue (the device came with 5.1 preinstalled, so the issue is NOT a result of an upgrade and NOT Moto-specific and NOT operator-specific).
    05-25-2016 10:23 AM
  23. jchirch's Avatar
    I've noticed that every once and a while I will get the following message when restarting the phone.

    "Android is Starting"
    "Optimizing App x of xxx"

    I know this should happen once after an upgrade, but it seems to be happening every few re-boots of the phone now.

    Anyone else seeing this behavior or know of a solution?

    Tom
    Yes. G S5 just upgraded to marshmallow, Chrome. Behaves the same way.
    06-04-2016 07:09 PM
  24. bmoolya's Avatar
    I am facing the same problem on my oneplus one. can anyone help me with a solution please
    06-10-2016 06:06 AM
  25. jgeebiz's Avatar
    I'm having the same problem with my HTC. It will start up then says Android is starting optimizing 1 of 74. It will stop at 54 then shut off. What can I do. I have already taken it in to have someone look at, but they really didn't know what to do with it except plug it in and try rebooting it by pressing the down button and the start button. What else can I do? I'm going to be out of a phone for two weeks. Not fun.
    06-16-2016 01:43 PM
94 1234

Similar Threads

  1. Why is COC just loading in my phone?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 10-08-2015, 01:43 PM
  2. Unable to boot after Update 5.1 on Verizon Moto X 2013
    By G L2 in forum Android 5.0 Lollipop
    Replies: 2
    Last Post: 09-18-2015, 12:26 PM
  3. What does clearing an apps cache do?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 09-18-2015, 02:34 AM
  4. Replies: 1
    Last Post: 09-18-2015, 02:33 AM
  5. A 900Mhz receiver for Android?
    By GideonG in forum Ask a Question
    Replies: 0
    Last Post: 09-17-2015, 11:11 PM
LINK TO POST COPIED TO CLIPBOARD