06-13-2018 04:02 AM
93 123 ...
tools
  1. TommyZ23's Avatar
    I've noticed that every once and a while I will get the following message when restarting the phone.

    "Android is Starting"
    "Optimizing App x of xxx"

    I know this should happen once after an upgrade, but it seems to be happening every few re-boots of the phone now.

    Anyone else seeing this behavior or know of a solution?

    Tom
    m.c.rime likes this.
    09-17-2015 11:18 PM
  2. wplust's Avatar
    I've noticed that every once and a while I will get the following message when restarting the phone.

    "Android is Starting"
    "Optimizing App x of xxx"

    I know this should happen once after an upgrade, but it seems to be happening every few re-boots of the phone now.

    Anyone else seeing this behavior or know of a solution?

    Tom
    I've read that it happens when you reboot while connected to charger. Might correct itself after GOOGLE play store and services update themselves in a couple of days.

    Sent from my XT1060 Moto X DE
    09-17-2015 11:34 PM
  3. Laura Knotek's Avatar
    I've read that it happens when you reboot while connected to charger. Might correct itself after GOOGLE play store and services update themselves in a couple of days.

    Sent from my XT1060 Moto X DE
    That is correct. I've never had it happen unless I rebooted my device while it was charging.

    Sent from my rooted Nexus 7 (2013) using Tapatalk
    09-17-2015 11:37 PM
  4. lonewolfarcher's Avatar
    Known lollipop on Moto X issue. Don't reboot while charging.
    09-18-2015 08:54 AM
  5. PapaGary's Avatar
    Known lollipop on Moto X issue. Don't reboot while charging.
    or-

    Just don't turn it off.
    09-18-2015 09:12 AM
  6. Pollster's Avatar
    Known lollipop on Moto X issue. Don't reboot while charging.
    Unless your apps need optimizing...lol
    09-18-2015 09:13 AM
  7. TommyZ23's Avatar
    Known lollipop on Moto X issue. Don't reboot while charging.
    I tried using the search function in this forum and didn't find any reference to this issue. I didn't know it was a known issue.

    Thank you everyone for the responses,
    Tom
    09-18-2015 10:20 AM
  8. ihateandroidupdates's Avatar
    This just happened to me and I wasn't charging. It is rebooting itself (on its own) and optimizing apps. After the optimization the phone is freezing up if I use any apps. Google Play services is also constantly crashing...useless phone...again...like every update. (it was updated a few days ago but the issue started today.)
    09-18-2015 01:50 PM
  9. lissuhllama's Avatar
    Mine does this when I am NOT charging.
    09-18-2015 03:04 PM
  10. Tom in Bristol's Avatar
    I wonder if this occurs when an app that the developer has just now converted for lollipop, submitted to Play and is then sent as an Update to us and our Google Play Service triggers the re-boot and optimization?

    Question for those that have seen the spontaneous re-boot: Do you have the Play app set up to automatically Update your apps??
    09-18-2015 03:55 PM
  11. lissuhllama's Avatar
    I wonder if this occurs when an app that the developer has just now converted for lollipop, submitted to Play and is then sent as an Update to us and our Google Play Service triggers the re-boot and optimization?

    Question for those that have seen the spontaneous re-boot: Do you have the Play app set up to automatically Update your apps??
    I have it set to yes, over wi-fi nothing else.
    09-18-2015 04:40 PM
  12. qqqaaz's Avatar
    Known lollipop on Moto X issue. Don't reboot while charging.
    That is true. After almost two years in use, today i reboot while charging, and happened the issue. I wipe cache partition, and the problem is gone! XT 1058 from BR.

    Steps by Motorola official page (Lollipop):

    1. Ensure the device is powered off, and unplugged

    2. Press and hold the Volume Down button and Power button (located on the right edge of the device) for approximately 3 seconds then release.

    3. From the "Boot Mode Selection Menu" screen, select Recovery.

    Note: Use the Volume Down button to scroll through the menu options and the Volume Up button to select.

    4. From the "No Command" screen (Android figure lying on his back), press and hold the Power button then press and release the Volume Up button to display the menu options.

    5. Select "wipe cache partition".

    Note: Use the Volume buttons to highlight and the Power button to select.

    6. "Reboot system now" will be highlighted, press the Power button to select it.

    Note: Allow several minutes for the reboot process to complete.
    10-09-2015 02:03 PM
  13. Greatsrj23's Avatar
    I've had this happen both charging and not charging. The times it happened when not charging were after the phone froze. A couple times when I tried making a call it would say dialing but I wouldn't hear the tone. I end call and it says hanging up and never hangs up. My wife said she heard me cursing at my phone lol. So apparently it connects but not on my end somehow. So when it says hanging up I can't really do anything else. It lets me back to the home screen but I can't open anything. I can switch screens but thats it. I turned it off and when it came back on it was optimizing. Very frustrating while driving and the first time it happened by wife thought something was wrong because she couldn't get through. I need to do a factory reset because i'm also having wifi connection issues but I just haven't had a good time to do it.
    10-09-2015 02:42 PM
  14. Josh Woodhead's Avatar
    I'm having the same issues but also the phone shuts off a lot immediately after plugging in any of my chargers.

    Posted via the Android Central App
    10-10-2015 01:31 PM
  15. TommyZ23's Avatar
    I just tried this and it didn't fix the issue when you reboot while charging.

    I'll just have to make sure power is not connected while re-booting.

    Thank you for trying to help.

    That is true. After almost two years in use, today i reboot while charging, and happened the issue. I wipe cache partition, and the problem is gone! XT 1058 from BR.

    Steps by Motorola official page (Lollipop):

    1. Ensure the device is powered off, and unplugged

    2. Press and hold the Volume Down button and Power button (located on the right edge of the device) for approximately 3 seconds then release.

    3. From the "Boot Mode Selection Menu" screen, select Recovery.

    Note: Use the Volume Down button to scroll through the menu options and the Volume Up button to select.

    4. From the "No Command" screen (Android figure lying on his back), press and hold the Power button then press and release the Volume Up button to display the menu options.

    5. Select "wipe cache partition".

    Note: Use the Volume buttons to highlight and the Power button to select.

    6. "Reboot system now" will be highlighted, press the Power button to select it.

    Note: Allow several minutes for the reboot process to complete.
    10-10-2015 01:35 PM
  16. lonewolfarcher's Avatar
    I've had this happen both charging and not charging. The times it happened when not charging were after the phone froze. A couple times when I tried making a call it would say dialing but I wouldn't hear the tone. I end call and it says hanging up and never hangs up. My wife said she heard me cursing at my phone lol. So apparently it connects but not on my end somehow. So when it says hanging up I can't really do anything else. It lets me back to the home screen but I can't open anything. I can switch screens but thats it. I turned it off and when it came back on it was optimizing. Very frustrating while driving and the first time it happened by wife thought something was wrong because she couldn't get through. I need to do a factory reset because i'm also having wifi connection issues but I just haven't had a good time to do it.
    Had these happen to me last week. Phone is rock solid 95% of the time but occasionally have a hiccup like this.
    10-12-2015 02:30 PM
  17. TommyZ23's Avatar
    It is a known issue which google and moto ignore.
    Here is the solution;
    [GUIDE/FAQ][XT1052] How To Downgrade From 5.… | Moto X | XDA Forums
    That's not a solution... Why would I want to downgrade from 5.1? This is the only minor issue I'm having.

    The solution, until an update is released, is to not restart the phone while it's plugged in.
    10-13-2015 10:37 PM
  18. diablo9's Avatar
    That's not a solution... Why would I want to downgrade from 5.1? This is the only minor issue I'm having.

    The solution, until an update is released, is to not restart the phone while it's plugged in.
    Tommy, there will be no update that resolves the issue. Your platform is dalvik, and the ART platformed pushed to your phone will never resolve.
    The solution is as I linked, however, you can continue to not re-boot while charging, which is a work-a-round, that doesn't resolve the issue.
    Mods please close this thread, Tommy has answered his question.
    10-13-2015 10:50 PM
  19. TommyZ23's Avatar
    I have been using ART before 5.1 and never had a problem with the re-boot. What makes this 5.1 ART different than 4.4.4's ART?
    10-13-2015 10:57 PM
  20. KWKSLVR's Avatar
    Have those with the problem done a full wipe? My device ran a whole lot better after a full wipe. Night and day difference.

    Posted via the Android Central App
    10-14-2015 05:19 PM
  21. autoanalyzer's Avatar
    I found that when starting and the moto X does show the animation screens at start up it then goes to the optimizing apps
    10-14-2015 06:24 PM
  22. autoanalyzer's Avatar
    Also with over 2000 views to this forum one would think that there would be a cure for this problem. Sorry I opened the box in which this phone came
    10-14-2015 06:26 PM
  23. KWKSLVR's Avatar
    Also with over 2000 views to this forum one would think that there would be a cure for this problem. Sorry I opened the box in which this phone came
    Typically the "cure" is to wipe the phone. This was a major OS update. It's always better to start fresh.

    Posted via the Android Central App
    lonewolfarcher likes this.
    10-14-2015 09:04 PM
  24. kms961986's Avatar
    I tried hard reset and cache clean, still its keeps restarting and optimizing the apps.. what to do?
    10-21-2015 12:33 PM
  25. jexx's Avatar
    Also with over 2000 views to this forum one would think that there would be a cure for this problem. Sorry I opened the box in which this phone came
    +1
    Same here, tried reset and cache wipe. This is why, sports fans, Lenovo/Motorola, is dead to me. I'm done, time to move on to something else. Now with over 3k views and nothing from Motorola and still now cure, sad indeed.
    10-21-2015 02:25 PM
93 123 ...

Similar Threads

  1. Why is COC just loading in my phone?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 10-08-2015, 01:43 PM
  2. Unable to boot after Update 5.1 on Verizon Moto X 2013
    By G L2 in forum Android 5.0 Lollipop
    Replies: 2
    Last Post: 09-18-2015, 12:26 PM
  3. What does clearing an apps cache do?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 09-18-2015, 02:34 AM
  4. Replies: 1
    Last Post: 09-18-2015, 02:33 AM
  5. A 900Mhz receiver for Android?
    By GideonG in forum Ask a Question
    Replies: 0
    Last Post: 09-17-2015, 11:11 PM
LINK TO POST COPIED TO CLIPBOARD