1. AC Question's Avatar
    I've got a 2013 MotoX that's on KitKat 4.4.4. I use this to stream audio to numerous Bluetooth headsets and 2 vehicles....until the past week or so.

    My problem is that when I pair my phone with any of these audio receivers, I can use Google Music, or Radio streaming apps that I've used for years and they play normally... Eventually though, typically after a few seconds to a few minutes, the audio stops. In Google Music, I can often look at the app and see the time continuing to tick on the track that is playing, but can't hear anything. If I attempt to use my phone at this point, it usually locks up and stops working, forcing me to reboot it.

    I noticed a few days ago that my phone, which had been plugged into a USB 1.0A charger was at 1% battery life. As soon as I unplugged it, it griped about the battery being low/dead. I checked the battery consumption chart and Bluetooth was listed as 33% of my battery consumption. How can I check my Bluetooth version number? I'm thinking something has pushed a newer version to me and has started causing these issues recently. I haven't been able to find a good guide because most posts in the past are all about pairing issues or possible issues with newer rollouts.

    As a second possible fix...if someone knows of a good ROM that has native wifi-tether enabled, I'll just switch ROMs. I've got a custom apk on my phone and that's the only reason I'm locked at 4.4.4. It hasn't had any issues so I've not needed to upgrade.

    Thanks.
    04-05-2016 11:56 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Do you mean that you have a custom 4.4.4 ROM installed?

    Have you already tried wiping the cache partition?
    04-05-2016 04:23 PM
  3. scarpozzi's Avatar
    Welcome to Android Central! Do you mean that you have a custom 4.4.4 ROM installed?

    Have you already tried wiping the cache partition?
    Rooted/Stock ROM that shipped with the phone. I tried wiping the cache twice, but haven't tried safe mode.
    04-05-2016 08:52 PM
  4. B. Diddy's Avatar
    Safe Mode is certainly a good idea, but you won't be able to test out any 3rd party streaming app.
    04-05-2016 10:41 PM
  5. scarpozzi's Avatar
    I did a factory reset on my phone and that appeared to fix the issue, but it only fixed it briefly. The problem returned within a few days, but it doesn't appear to be as bad. Since my phone is rooted, I've been reading up on similar issues and have figured out that the problem appears to be with Bluedroid. I have tried backing up/deleting the bt_config.xml file. That does help matters, but it isn't a real fix.

    I am wondering if this was triggered by a particular Bluetooth device that I own. I was able to stream audio on vacation last week for hours in the my 4Runner...but when I returned home and connected my phone in my truck, Ford Sync showed it was still connected, but there was no audio playing. I checked the audio player (Google Music) and it showed that it was still playing. This is one of the symptoms I've been getting....connection is there, but no sound plays. The second is that the sound stops and when I start/stop Bluetooth or do anything to attempt to fix it, the phone heats up....Bluetooth can go into wakelock and the phone either burns through its battery quickly or the Bluetooth process causes the phone to reboot. I'm going to remain persistent here and not get a new phone. The hardware and battery life are still decent on the MotoX.....this is all software.

    Should I be looking to upgrade Bluedroid somehow on my own? Is there a good source for those packages or are they too attached to the Android OS to mess with? I was a Linux admin for years so I'm not afraid to mess with it. I just don't know where to look....Google hasn't been helpful.
    05-23-2016 09:54 AM

Similar Threads

  1. Contact app crashing on Blackberry Priv, how can I fix this?
    By Keaven Bernier in forum BlackBerry Priv
    Replies: 1
    Last Post: 04-05-2016, 04:43 PM
  2. Replies: 1
    Last Post: 04-05-2016, 04:40 PM
  3. Replies: 1
    Last Post: 04-05-2016, 04:38 PM
  4. Emails popping up when type and auto fills?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 04-05-2016, 03:44 PM
  5. Gmail Notifications not working??
    By AC Question in forum Samsung Galaxy S7
    Replies: 1
    Last Post: 04-05-2016, 11:26 AM
LINK TO POST COPIED TO CLIPBOARD