1. JZohmg's Avatar
    Hi Gents/Ladies,

    Just switched back to Android from iOS. Love the Moto X. Only issue is my Wi-Fi is incredibly slow on it - e.g. taking 40m to download an app (~20mb). This is not an issue on my tablet. I tried disconnecting other devices in the house to see if it was a bandwidth issue. No go. Any ideas? Comcast is my ISP - and I'm using this router:

    NETGEAR N300 Wi-Fi Gigabit Router (WNR3500L)

    Let me know what other info I can provide.

    Thank you!

    John
    10-20-2014 07:02 AM
  2. delrey1900's Avatar
    Is it only slow at home? How does it perform at other locations whether private or public?
    10-20-2014 07:05 AM
  3. sharkita's Avatar
    Is it only slow at home? How does it perform at other locations whether private or public?
    I would have the same question. If it's that slow in other locations, then I'd be inclined to return the phone for another, since something is very wrong if it takes that long to download an app.
    10-20-2014 09:16 AM
  4. someguy01234's Avatar
    Sound like an issue with the phone. Mine Moto X does 50mbps+ download over wifi with speedtest.
    10-20-2014 10:03 AM
  5. JZohmg's Avatar
    Tested at work - works just fine - lightning fast downloads. Unsure what is going on at home. Will test around some more and let you guys know. In the mean time any thoughts based on this new data point?

    Big Thanks,

    John
    10-20-2014 02:02 PM
  6. Citizen Coyote's Avatar
    Tested at work - works just fine - lightning fast downloads. Unsure what is going on at home. Will test around some more and let you guys know. In the mean time any thoughts based on this new data point?

    Big Thanks,

    John
    If it works fine at work but is slow at home, my suspicion would be an incompatibility with your router (it's not unheard of). Check to see if there's a firmware update available for the router and see if that fixes the issue. Are your other wireless devices in your home new, or somewhat older? If they're older, that also suggests the problem lies with the router and not the phone. If newer, test the phone in more locations and see what kind of speeds you get.
    10-20-2014 03:08 PM
  7. rigg's Avatar
    Just saw this post and decided to test my new Moto X against my other devices. From left to right, Moto X, Galaxy S5, Nexus 7 & iPad Mini. I performed 3 tests and you can see that the Moto X is SIGNIFICANTLY slower than my other devices. FYI: Sitting next to the newest Airport Expreme and pay for Verizon FIOS with 75 down.
    Moto X 2014 Why is my wifi very slow when compared to other devices in house?-img_0033.jpg
    10-20-2014 03:15 PM
  8. rigg's Avatar
    Think I found the problem. I guess Android sets a default to save on battery. Go to Wifi, Advanced, then uncheck the box next to "Wi-Fi optimization." My speeds have more than doubled, ranging now between 50+ and 82.
    10-20-2014 03:34 PM
  9. Citizen Coyote's Avatar
    Think I found the problem. I guess Android sets a default to save on battery. Go to Wifi, Advanced, then uncheck the box next to "Wi-Fi optimization." My speeds have more than doubled, ranging now between 50+ and 82.
    Wow, that's quite the difference! Good to know.
    10-20-2014 07:15 PM
  10. delrey1900's Avatar
    Think I found the problem. I guess Android sets a default to save on battery. Go to Wifi, Advanced, then uncheck the box next to "Wi-Fi optimization." My speeds have more than doubled, ranging now between 50+ and 82.
    That is good info, thanks for that. However, I have Comcast 30Mps service and performance is the same no matter what setting. I wonder if this has to do with faster connections speeds only, like you have. So, I'm leaving it on.

    One suggestion I was going to make to the OP was to set the frequency band to 5Ghz only and see what you got in terms of speed.
    10-20-2014 08:08 PM
  11. JZohmg's Avatar
    Fixed the problem. Just needed a firmware upgrade on the old router. Thanks for all the help guys!
    delrey1900 likes this.
    10-20-2014 08:34 PM
  12. slh7d's Avatar
    Yeah, I learned about the WiFi optimization setting today also, turned it off.,
    10-20-2014 09:42 PM

Similar Threads

  1. Replies: 12
    Last Post: 11-11-2014, 03:10 PM
  2. Making the switch from iPad to Nexus 9
    By TarekSalama in forum Google Nexus 9
    Replies: 8
    Last Post: 11-04-2014, 06:35 AM
  3. Camera malfunction in scanner apps
    By khalfdan in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 10-29-2014, 09:33 AM
  4. Is the Note 4 better than the Galaxy S5?
    By Pollyanna Henricks in forum Ask a Question
    Replies: 2
    Last Post: 10-24-2014, 03:44 PM
  5. Can I update my Oneplus One from xnph92q to xnph22r?
    By Marios Savva in forum OnePlus One
    Replies: 0
    Last Post: 10-24-2014, 04:17 AM
LINK TO POST COPIED TO CLIPBOARD