Shop HP’s Memorial Day Sale:Save up to 61% on PCs and more!
  1. Ripper77's Avatar
    After the 5.0 update, I went to add my Moto 360 as a trusted device and when I went to the Smart Lock menu option under Security settings I was surprised that there wasn't a Smart Lock menu option in there.

    This is right out of the release notes from motorola: "Android Lollipop adds native support for allowing trusted devices to keep your phone unlocked (such as your Moto 360, a Bluetooth car kit or headset, etc.). Smart Lock replaces the prior trusted device capability in your Motorola phone. Note that you will need to add your trusted devices back after the transition to Lollipop in the Security settings menu under Smart Lock."

    Has anybody noticed this option missing when your Moto X 2014 was upgraded to Lollipop.
    shophiapena likes this.
    11-14-2014 07:25 AM
  2. Jaysson Calhoun's Avatar
    Mine is there using it with my micro power pack. Should be in Security and you will see it right below owner info.

    Posted via the Android Central App
    shophiapena likes this.
    11-14-2014 08:01 AM
  3. Ripper77's Avatar
    Its not there 😢

    Posted via my Moto X(2ndGen) 😀
    Attached Thumbnails Smart Lock menu option not found in Security setings.-6839.jpg  
    shophiapena likes this.
    11-14-2014 01:04 PM
  4. Ripper77's Avatar
    Jaysson, did you upgrade or full install?

    Posted via my Moto X(2ndGen) 😀
    shophiapena likes this.
    11-14-2014 01:05 PM
  5. shamelin73's Avatar
    Its not there

    Posted via my Moto X(2ndGen)
    Are you using an exchange account? The security policy from that may lock that setting out as mine does.

    If so, use a program like Nine to have your exchange and you can set it to have application security instead of it locking down your whole phone.
    shophiapena likes this.
    11-14-2014 01:15 PM
  6. Ripper77's Avatar
    Thanks shamelin for your response. I only use Gmail on my phone and don't have any exchange accounts.

    Im still puzzled as to why this option is not found under my security settings.

    Posted via my Moto X(2ndGen)
    shophiapena likes this.
    11-14-2014 03:07 PM
  7. googliness's Avatar
    Enable it first in

    Security -> Trust agents
    11-15-2014 04:55 PM
  8. SShadow1974's Avatar
    Enable it first in

    Security -> Trust agents
    When I first installed lollipop, I set up smart lock. I now do not have the option in my settings. Also when I go into trust agents, there is nothing there. Just a blank screen.
    The only thing I can think of that may have affected it, and I think I had this issue before I did this... I upgraded Google play services to the latest version via apk update.
    shophiapena likes this.
    11-19-2014 05:24 AM
  9. SShadow1974's Avatar
    It is the Google services update. Tried to post link to proper update for n5 but I don't have enough posts.
    Make sure you don't install a version that the last three digits starts with a 0, must be 4 or 7 for lollipop.
    shophiapena likes this.
    11-19-2014 05:44 AM
  10. fierro951's Avatar
    Mine isnt showing up either after upgrading Google Play Services to 6.5
    shophiapena likes this.
    11-19-2014 08:12 AM
  11. ChillyMutt's Avatar
    Same here .... go to Settings > Security > ... no Smart Lock
    I get similar Security screen as Ripper and blank page under Trust Agents.
    Was a fix ever found for this?
    12-03-2014 12:33 PM
  12. benhaube's Avatar
    Same here .... go to Settings > Security > ... no Smart Lock
    I get similar Security screen as Ripper and blank page under Trust Agents.
    Was a fix ever found for this?
    You need to have the proper GP Svcs installed. If you choose the KitKat APK it will make that setting disappear. By now, Google has rolled out the update fully in the play store, so just uninstall the update reinstall using the play store.
    ChillyMutt likes this.
    12-03-2014 02:01 PM
  13. jordandj24's Avatar
    Had the same issue at first: Go to settings > security, scroll down to Trust agents and turn on Smart Lock.

    Also I think you need to have Google Play Services 6.5 for it to work.
    ChillyMutt likes this.
    12-03-2014 02:03 PM
  14. ChillyMutt's Avatar
    I did have the wrong GP Svcs installed. The Lollipop one was not in Play Store so I side loaded it.
    I now have Smart Lock Option and within that I have "Trusted Devices" and "Trusted Face" .... I briefly had "Trusted Locations" ... but for some reason that is now gone. I probably changed some setting that disabled that (Trusted Location) - any ideas what that could be?
    So frustrating. I really like the power/flexibility of Android os but their user experience leaves much to be desired.
    12-03-2014 02:29 PM
  15. ChillyMutt's Avatar
    Been on iOS for a year. Forgot how challenging Android could be for non engineer types.

    Got Smart Lock and Trusted Locations working. So for anyone else who runs into this ...
    Short story - I had a KitKat version of Google Play Services installed. I "Disabled" the KitKat version ... which actually uninstalled that version and reverted back to 6.1... I then installed the correct Google Play Services for my device/Lollipop and working fine so far.

    Long story - as stated above by SShadow, you need to have the Google Play Services ending in 7xx or 4xx ... and apparently the 7,4 indicate LOLLIPOP version. The "xx" indicated which variant your need - determined by what you currently have installed. I had 6.1...738 so I looked for a 6.5 version of Google Play Services ending in "738" could not find one so I tried one ending in "438" .... apparently the 4 or 7 (indicating Lollipop) are interchangeable.

    Works now. Horrendous user experience by Google though.
    texstar420 likes this.
    12-03-2014 03:32 PM
  16. Brian Galada's Avatar
    So have Lollipop and the 6.5.87 version of Google Play services ending with 438 but Trusted Face under Smartlock doesn't work as I keep getting Google error message, "Unfortunately Google Play services has stopped". Any ideas?
    12-03-2014 05:49 PM
  17. texstar420's Avatar
    After the 5.0 update, I went to add my Moto 360 as a trusted device and when I went to the Smart Lock menu option under Security settings I was surprised that there wasn't a Smart Lock menu option in there.

    This is right out of the release notes from motorola: "Android Lollipop adds native support for allowing trusted devices to keep your phone unlocked (such as your Moto 360, a Bluetooth car kit or headset, etc.). Smart Lock replaces the prior trusted device capability in your Motorola phone. Note that you will need to add your trusted devices back after the transition to Lollipop in the Security settings menu under Smart Lock."

    Has anybody noticed this option missing when your Moto X 2014 was upgraded to Lollipop.
    Okay I had the same problem and just fixed it by going to apps >chose Google play services it uninstall updates was grey so I clicked disable >unchecked the second one forgot what it was that was using Google play services >got some error saying Google play services wasn't working >was now able to click uninstall updates >then installed the latest 434 Google play services here- won't let me post the link so Google it > then went to trusted agents I think and turned smart lock on. Then it showed up in security. Hope this helps every one and hope I'm not trying to fix something that was already fixed lol!
    12-03-2014 11:41 PM
  18. texstar420's Avatar
    I agree Google shouldn't have issues like this but glad we have a great forum support group to help with these things. We have androids cause we're smart people and can figure these things out lol! Btw I am so happy I refused my Nexus 6 delivery and got the moto x 2014 pure edition cause the software is sick and the size is perfect. Almost the same size as my Nexus 5 but better screen and features and more SLIM!
    sharkita likes this.
    12-03-2014 11:45 PM
  19. texstar420's Avatar
    Check my how to post it should help you Brian Galada!
    12-03-2014 11:46 PM
  20. texstar420's Avatar
    So have Lollipop and the 6.5.87 version of Google Play services ending with 438 but Trusted Face under Smartlock doesn't work as I keep getting Google error message, "Unfortunately Google Play services has stopped". Any ideas?
    Yeah you have to disable Google play services and unintelligible the updates then install the 434 Google play services!
    12-03-2014 11:49 PM
  21. bhardwajishu's Avatar
    To enable Smart Lock first set a password or pattern whatever you like...then only you will see smart lock option under security.
    12-11-2014 04:36 AM
  22. BHShaman's Avatar
    Thanks.
    Worked great on LG G3
    02-13-2015 12:01 PM
  23. nfornajam's Avatar
    hi,
    i hv been surfing the internet and used each n every method
    turned on smart lock in security>trust agents
    uninstalled google play services updates and then reinstalled latest version 10.0.84
    uninstalled outlook
    cleared credentials etc etc
    but smart lock is not turning on and icon is not showing up in security between owner info and encryption.
    I hv lollipop 5.1 on lenovo vibe p1m
    what to do next, plz help
    thanks
    01-14-2017 09:53 AM

Similar Threads

  1. Replies: 1
    Last Post: 11-15-2014, 05:13 PM
  2. Replies: 1
    Last Post: 11-15-2014, 02:48 AM
  3. How do I get my Hudl out of speech mode?
    By janet radburn in forum Ask a Question
    Replies: 1
    Last Post: 11-14-2014, 09:23 AM
LINK TO POST COPIED TO CLIPBOARD