1. jruzzano's Avatar
    My phone doesn't automatically connect to wifi when mobile data is on. It has been like this since day one (I believe) I got the phone around thanksgiving time. I have been searching for a fix or setting since. I cannot find an answer.

    I have ATT. My whole family has ATT. The kids both have 1st gen Moto X and my husband has Samsung, none of them have this issue and I believe we are all running the same android version.

    I have done lots of different things I have found along the way during my search for a fix but nothing has worked.

    I can tell you that if I shut my mobile off and turn my Wifi on it will connect then I can turn my mobile back on and it will stay that way until I go out of my wifi range and the mobile kicks on then when I return to wifi range it won't connect. If I try to connect it will say disabled. That is when I turn off mobile, turn on wifi and then go back and turn mobile on again. If my mobile is off and I go out of wifi range it will connect back just fine, the issue seems to be only when mobile is ON.

    I would like to be able to leave mobile on so I can receive MMS. But this is a pain because sometimes I forget that wifi didn't connect or I forget to go back in and turn mobile on and miss a lot of group texts, iphone long texts that come as MMS and pic texts until I turn my mobile on which sometimes could be days.

    any help is much appreciated TIA
    01-09-2015 11:59 AM
  2. jruzzano's Avatar
    I ended up doing a factory reset. When I started the phone I skipped the ATT Ready2Go setup (easy set up for wifi, contacts, email and other accounts) I connected to the wifi and I am able to shut wifi off and on again without having to turn mobile data off. I don't know if it was the reset or skipping the ready2go app that fixed this. Hope this may help someone else along the way.
    01-12-2015 04:31 PM

Similar Threads

  1. going back to 2013 Moto X
    By douglasbnorton in forum Moto X (2014)
    Replies: 17
    Last Post: 01-29-2015, 09:18 PM
  2. WiFi Tether Router I need help anyone please.
    By Michael Ernst1 in forum LG G2
    Replies: 1
    Last Post: 01-18-2015, 12:00 PM
  3. Replies: 3
    Last Post: 01-13-2015, 04:28 AM
  4. Plugged in while using battery hog apps?
    By tonyr6 in forum General Help and How To
    Replies: 2
    Last Post: 01-09-2015, 11:23 AM
LINK TO POST COPIED TO CLIPBOARD