1. JoeyB33's Avatar
    So I bought in December a new Moto X second gen with KitKat and loved it. Worked great!

    Then I upgraded to Lollipop and all of a sudden my phone showed and Exclamation point where my MetroPCS provider is!
    The phone could make calls and receive texts but I could not get on the internet at all with it unless Wifi was working.

    Took it to Metro they checked everything was working on their end. Phone issue I thought. Sent the phone back had a totally new one built for free by Motorola. When I got the new one back same exact issue! Has anyone else had this problem??? I saw some first gen users that had this issue and they where able to fix it by using a different sim slot. But the Gen 2 only has one!

    Anyone know why I have had this issue with 2 brand new MotoX? Was working fine with KitKat! PLEASE HELP!!!
    05-11-2015 07:43 PM
  2. jerethi's Avatar
    Have you tried selecting a different APN in settings?

    Posted via the Android Central App
    05-12-2015 12:37 AM
  3. stanleywinthrop's Avatar
    I agree its probably an APN problem. Google the correct settings or contact the carrier directly. The store personnel likely don't have the training or experience to understand that.

    Posted via the Android Central App
    05-12-2015 09:33 AM

Similar Threads

  1. Were do I find the clipboard on the Moto X 2nd generation?
    By rhonda herndon in forum Moto X (2014)
    Replies: 1
    Last Post: 06-23-2016, 05:36 PM
  2. Replies: 1
    Last Post: 05-12-2015, 01:42 AM
  3. My S6 Edge screen cracked, what are my options to get it fixed?
    By AC Question in forum Samsung Galaxy S6 edge
    Replies: 1
    Last Post: 05-11-2015, 09:21 PM
LINK TO POST COPIED TO CLIPBOARD