1. AC Question's Avatar
    I have a moto x 2nd gen, obviously. I was able to download apps at first but then recently I can't download anything from the play store. I tried while on wi-fi and while off wi-fi. I tried downloading through a pc, I tried clearing the cache memory from the play store app, resetting my phone, turning airplane mode on and off, I checked the data settings, I deleted photos and videos to make more room. It still doesn't work. Any suggestions would be really awesome.
    03-03-2016 10:46 AM
  2. Javier P's Avatar
    Hi, welcome to the forums! What error message do you get? You could try wiping the cache partition on recovery.
    03-03-2016 10:57 AM

Similar Threads

  1. How can I use my heart rate monitor during sleep?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 03-03-2016, 01:47 PM
  2. What are my upgrade options on Verizon?
    By wdeeble in forum Verizon
    Replies: 7
    Last Post: 03-03-2016, 11:52 AM
  3. Replies: 1
    Last Post: 03-03-2016, 11:37 AM
LINK TO POST COPIED TO CLIPBOARD