1. hornee's Avatar
    Hi all,
    My moto X (2nd gen) randomly turned off today, twice, and since then im facing the following issues.

    1) Unable to pull down notification pane
    2) Unlock Skipping the Pattern / Pin lock straight into Homescreen
    3) tapping on-screen Home Button (center circle) button does nothing (although it Lights up & vibrates)
    4) Battery drain has increased
    5) Factory Reset button is Greyed out, thus unable to factory reset via settings.

    I realised I do not have sufficient privs so I created a new User Profile on device and entered back in my old Profile - thus solving issues 1 & 2.

    However, 3,4,5 remain unsolved. Any ideas ?

    Regards

    EDIT : Spoke to a friend who said she suffered the same issue with her Moto G a couple of weeks back. and Only service center can resolve it ? I do not have assistance or access to one.. any ideas ?
    04-01-2016 05:20 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Can you boot into Recovery and wipe the cache partition? https://motorola-global-portal.custh...p/30,6720,9197. If that doesn't help, you can do a factory reset from that menu as well.
    Laura Knotek likes this.
    04-02-2016 02:49 AM
  3. hornee's Avatar
    Hi,
    Thankyou for responding.
    I was trying to avoid factory reset, as restoring a few GB of media plus reisntalling and signing into apps is a frustrating experience.

    Besides I dont know what exactly happened and how it broke to this point. Everything seemed absolutely flawless, till it randomly shut down yesterday.

    Just before I attempt Factory Reset / Wipe after work, I wanned to ask doesnt this seem a familiar case of permissions ? I no longer seem to have permission to do somethings.
    04-02-2016 06:42 AM
  4. hornee's Avatar
    EDIT: I just attempted it.

    I clicked on the link and followed steps to recovery. On selecting recovery, the phone attempted to boot in recovery then gives me a sleeping android mascot with a red exclamation with error "No Command".
    http://www.robschmuecker.com/wp-cont...recovery_4.jpg
    04-02-2016 06:51 AM
  5. Javier P's Avatar
    Hello homee, welcome to the forums! From the no command screen try holding the Power button and then press and release Volume up. If it doesn't work try holding both power and volume up buttons for a few seconds and then release volume up.

    There's a bug affecting a few phones after the latest system update. It seems related to the setup wizard. Take a look at this thread.

    http://forums.androidcentral.com/sho...d.php?t=651494
    04-02-2016 07:47 AM
  6. hornee's Avatar
    Hey Javier P,
    thankyou so much. This is precisely the problems im facing. I did manage to fix the notification pull down, I realized it was related to restricted permissions so created new user profile and jumped back to owner.

    - The factory reset is greyed out.
    - Im unable to boot into recovery, even after pressing and holding power + vol up combination, the phone simply boots normally.
    - I believe I will have to dig deeper into adb_cmds as factory reset via recovery is posing a challenge as well.

    Thankyou for pointing out am not alone on this . appreciate it.
    Any further help, please post. thanks. I shall update here with any progress.

    Cheers
    04-02-2016 08:01 AM
  7. hornee's Avatar
    Update | Solution | fix

    Ok this thing is driving me crazy. Phone seems functional, but on the back of my head i know there are underlying issues. What really is bothering are
    - random missing/skipping notifications
    - missing UI elements in lock screen
    - Unreasonable battery drain
    - home button broken or doesnt function correctly
    - some other nags that can be attributed to this.

    Reason : I dont really know the reason, but I believe, the "setup wizard service" which runs in the background after Updating to android 6 from lollipop crashed, which resulted in the device switching off abruptly and on switching on, the device is confused if its in setup wizard or if the user is logged in or something this sort.

    This affects several phones, not just the moto X second gen running marshmallow. The fixes are :
    1) to factory reset by hard reset following these steps (for marshmallow moto x)

    This reset will require a minimum battery level of 25%.

    - With the phone powered off, press and hold the Volume Down button and the Power button at the same time until the device turns on.
    - Press the Volume Down button to highlight "Recovery mode"
    - Press the Power button to restart into Recovery mode.
    - You'll see an image of an Android robot with a red exclamation mark.
    - While holding down the Power button, press the Volume Up button.
    - Use the volume buttons to scroll to "wipe data/factory reset" and press the Power button to select it.
    - Scroll down to "Yes - erase all user data" and press the Power button to select it
    this will reset the phone to factory state.

    HOWEVER, I chose to not factory reset as i have not backed my data, I do not believe in cloud services. So,
    This may be teh solution for those who are still reading. My phone is not rooted.


    You basically need to connect your phone to a computer / laptop, and invoke the SetupWizard, and complete the setup wizard, for the phone to recognize its completed and thus letting you in as the original owner.

    You will need ADB (Android Debug Bridge ~ 185mb
    You will need JDK (Java SE development kit ~ 175mb

    install the above, open and run SDK Manager - select and install only "android SDK Platform tools"

    install the above then, enable USB-Debugging mode on your phone
    Settings > developer options > usb debugging > on

    Now, on your PC
    1) - browse to "OS Drive"\users\user\AppData\Local\android\android-SDK >>> here enable View Hidden Files Folders
    - press & hold shift + right click on blank space in this window and click on Open Command Window Here
    - in this command window you will need to make certain associations to call 'adb' when needed, thus follow this video


    2) once that is sorted, connect your phone via usb to the pc & type in cmd

    adb shell
    am start -n com.google.android.setupwizard/.SetupWizardTestActivity


    this will invoke the setup wizard on the phone, complete it, by hitting Skip Skip Skip and done
    Done, all data is safe, phone is back to normal.
    Javier P likes this.
    04-02-2016 11:44 AM
  8. Javier P's Avatar
    Glad you managed to fix it! And thanks for this detailed feedback, it will be very helpful for other people with the same problem.
    04-03-2016 05:11 AM

Similar Threads

  1. Replies: 3
    Last Post: 04-07-2016, 10:06 PM
  2. ZenWatch 2 + Moto G LTE, 1st Generation?
    By Old Stoneface in forum ASUS ZenWatch 2
    Replies: 1
    Last Post: 04-01-2016, 03:06 PM
  3. My Samsung Galaxy Fame suddenly freezes. Any solutions?
    By sadnan_ornob in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 04-01-2016, 05:05 AM
  4. Replies: 0
    Last Post: 04-01-2016, 03:40 AM
LINK TO POST COPIED TO CLIPBOARD