1. aldo82's Avatar
    How's everyone getting on with signal strength on this phone? I noticed early on and its remained the same for the week since I've had it that I notice my phone has no signal more frequently than my previous phone. I'm surprised as moto are supposed to have the best radios. I will get it out of my pocket and see it sat with no signal at very unexpected times

    Also when I switch on the phone, it takes a good 20 to 30 seconds before it finds a signal. Does anyone else notice that behaviour? Maybe that's typical of Motorola phones?

    Posted via the Android Central App
    09-06-2015 11:30 AM
  2. Javier P's Avatar
    I haven't noticed any problem with the radios. I spend some time in areas with weak signal and reception is the same than it was with my previous phone. I just compared with other phones and no difference (Moto G, Samsung S4 and Zenfone 5).

    I've noticed an improvement in the WiFi reception, much better than my Moto G).
    09-06-2015 05:20 PM
  3. udazavlanje's Avatar
    It might be just a bad device. I had to return my 2014 Moto X for the same reason and replacement is perfect. Actually it's better than any device I was testing against on Verizon in poor signal areas (Note 4, iPhone 6 and 5s, z3c, s5, 2013 Moto X)


    VZW Moto X 2014/2013 DE
    09-06-2015 09:27 PM
  4. aldo82's Avatar
    Could anyone do me a favour and check how long the phone takes to acquire a signal when you switch it on. Is it straight away after boot up or is there a delay of say 20 seconds before it has a usable signal?

    Posted via the Android Central App
    09-07-2015 03:11 AM
  5. thespinner's Avatar
    Turned on, waited for the start up sequence to complete. Once in Android it took about three seconds to obtain a 4G signal.

    Posted via the Android Central App
    johnny.kinnunen likes this.
    09-07-2015 12:10 PM
  6. aldo82's Avatar
    Turned on, waited for the start up sequence to complete. Once in Android it took about three seconds to obtain a 4G signal.

    Posted via the Android Central App
    OK thanks. Would beat mine in a race then!

    Posted via the Android Central App
    09-07-2015 12:19 PM
  7. Devhux's Avatar
    Mine is quick to acquire a signal as well.
    09-07-2015 12:35 PM
  8. Javier P's Avatar
    Check switching aeroplane mode on and off. Mine took about 3 seconds to connect both sim cards.
    09-07-2015 12:55 PM
  9. aldo82's Avatar
    Takes mine about 27 seconds to acquire the signal! Don't know if this is a fault as when it's got it seems OK so it could be just the time it takes to register on the network but I don't feel like I've noticed this before in my previous phones

    Posted via the Android Central App
    09-07-2015 01:16 PM
  10. thespinner's Avatar
    Just tried mine at a different location (not 4G), about 25-30 seconds. You're not alone!

    Posted via the Android Central App
    09-07-2015 01:38 PM
  11. aldo82's Avatar
    Just tried mine at a different location (not 4G), about 25-30 seconds. You're not alone!

    Posted via the Android Central App
    Interesting thanks. What network? I'm on 3 UK.

    Posted via the Android Central App
    09-07-2015 02:00 PM
  12. thespinner's Avatar
    Snap. 3 in the UK.

    Posted via the Android Central App
    09-07-2015 02:06 PM
  13. aldo82's Avatar
    OK so its either a 3 thing on every phone and I've never noticed or its just a funny with this phone on 3. Do you find signal is OK the rest of the time? Thinking about it I have noticed after a flight my old phone used to take a while to pick up a signal so maybe it's always been there on 3. Don't turn my phone off that often to notice!

    Posted via the Android Central App
    09-07-2015 02:17 PM
  14. thespinner's Avatar
    Same. Rarely turn off the phone and if I do I'm not usually waiting to use it as soon as I turn it back on so haven't noticed.

    Just tried my old phone (Moto X 2014) also on 3. 3 seconds.

    Posted via the Android Central App
    09-07-2015 02:30 PM
  15. thespinner's Avatar
    Forgot to say no problem with signal strength. Apart from the office where I get no signal most of the time but we have WiFi and I use the Three in Touch app so not a big problem.

    Posted via the Android Central App
    09-07-2015 02:37 PM
  16. aldo82's Avatar
    Thanks for the replies. I'm not alone then! I'll stick to trying to sort out the Google services drain for now and will stop worrying about the signal!

    Posted via the Android Central App
    09-07-2015 03:25 PM
  17. aldo82's Avatar
    So I think I've found the reason my phone takes so long to acquire a signal and I think it's a pretty fundamental problem which I intend to speak to Motorola about. Be interested if it is the same for everyone.

    When the phone looks for a signal I think it looks for 4g first for approx 30 seconds before looking for 3g. If you're in a 4g area then you'll lock on straight away and all is great. If not though then you will have a 30 second wait without signal.

    This doesn't really matter when turning on the phone but what I have found is if I loose signal in a building or when driving then it will take much longer to reacquire the signal than other phones. This is because it wastes so much time looking for 4g first.

    For now I've switched off 4g and set to 3g only but seems a daft solution. If I always had 4g then wouldn't be an issue but where I live is mainly 3g.

    Anyone else notice this? Hope its something that can be fixed and not a hardware issue

    Posted via the Android Central App
    09-19-2015 04:37 AM
  18. Teejai80's Avatar
    I am finding my reception better than most other people around me when it gets low

    Sent from my XT1562 using Tapatalk
    09-19-2015 05:41 AM
  19. Bonovox72's Avatar
    Signal on mine is rock solid I get 3 bars of 4G in my area whereas my previous Samsung Note 4 was lucky to hang on to one bar

    Posted via the Android Central App
    09-19-2015 06:25 PM
  20. aldo82's Avatar
    Just to resurrect this thread. My moto X play takes 30 seconds to find a signal if I'm not in a 4g area. If 4g is available then it locks on instantly. If I switch to 3g only mode then it finds 3g signal instantly.

    What I find is if I loose signal then it'll have this same 30 second lag in locking onto signal again when I'm back in coverage and this lag is annoying.

    It seems to me that the phone searches for 4g for 30 seconds before switching to 3g if nothing found. I haven't observed this behaviour on my other phones.

    As marshmallow didn't change this I contacted moto and they said it may be a faulty radio so can send it in for repair. They did however suggest trying a different sim first. I spoke to my network, three UK, and they claim that this delay is normal and reckon there is no problem with my phone.

    So the question is, if you turn your phone on or switch airplane mode mode off for example, how quick does your phone lock onto a signal if in a 3g only area??

    Posted via the Android Central App
    02-08-2016 08:46 AM
  21. bembol's Avatar
    It's one of the two things I love about Motorola. The other is Voice quality.

    I picked up the Play as a back-up and wanted to take advantage of upgrade deal.
    02-10-2016 01:25 PM
  22. thespinner's Avatar
    Aldo, I get the same results as you. 30 seconds delay in a non 4G area. On Marshmallow and 3 network in the UK.

    Posted via the Android Central App
    02-13-2016 02:51 AM
  23. aldo82's Avatar
    Aldo, I get the same results as you. 30 seconds delay in a non 4G area. On Marshmallow and 3 network in the UK.

    Posted via the Android Central App
    Interesting. I think there is a problem with this phone and the three network as I don't have the same issue with exactly the same sim in a nexus 5. Anyway, Motorola support said it might be a fault so mine has gone for repair. Apparently it's repaired and been despatched back to me but no detail of what they have done yet. Half expecting them to have done nothing but if they've changed a part or updated some firmware then it'll be interesting to see if it makes any difference!

    Posted via the Android Central App
    02-13-2016 01:19 PM

Similar Threads

  1. Replies: 1
    Last Post: 09-21-2015, 05:10 PM
  2. How do I change my phone greeting
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-21-2015, 04:40 PM
LINK TO POST COPIED TO CLIPBOARD