1. AC Question's Avatar
    I just upgraded my Moto x play to marshmallow and after that when i am connecting my mobile to my laptop my sd card files are not showing there but internal storage files are showing there.
    01-06-2016 05:25 PM
  2. itguyjax8430's Avatar
    I just upgraded my Moto x play to marshmallow and after that when i am connecting my mobile to my laptop my sd card files are not showing there but internal storage files are showing there.
    Welcome to Android Central!

    You might have to actually plug your SD Card in to your computer and get the files that way. I would then put the card back in your phone and format it again.
    01-06-2016 06:21 PM
  3. nghtchld's Avatar
    Same problem here and I found and followed a fix at: forums.androidcentral DOT com/moto-g-2015/630247-pc-can-t-access-moto-g-files.html#post4937816
    This is a known issue with the Marshmallow update on G3 with SD card set as portable storage (users who switched to internal storage seem to have no issues)... Disconnect USB, then Go to Settings, Apps, and Show System Apps, then find External Storage and Media Storage, and clear data and cache on each one and reboot. Give it 5 min after full boot up to rebuild media databases and connect to USB and select MTP, should be good to go.

    Next time I rebooted and connected to PC (Win 10) it was all there! Hope this helps.
    02-15-2016 08:17 AM
  4. girinath's Avatar
    Go to developer settings and switch on usb debugging mode...

    Posted via the Android Central App
    Paul86 likes this.
    02-15-2016 10:14 AM
  5. chezm's Avatar
    Go to developer settings and switch on usb debugging mode...

    Posted via the Android Central App
    Thanks, this solved my issue. Can write to either SD portable or phone, cool.

    Posted via the Android Central App
    02-15-2016 04:26 PM
  6. wurn's Avatar
    I tried various options that are shown here with no luck. But after playing around this worked for me.
    Under "Developer Options"
    1. Turn "Legacy DHCP Client" on.
    2 Set USB configuration to MTP protocol.(Default)
    3 Turn USB debugging on.
    02-21-2016 12:58 PM
  7. treeloo's Avatar
    Thanks all
    Girinath's posting was a way I, and a blessing
    I have followed his instructions, but as it did not work, I tried other options and got it to work by using media instead of MTP protocol.(Default). Voila!
    04-24-2016 03:57 PM

Similar Threads

  1. when I put my hand over the left corner my bluetooth stops streaming
    By Jagadalic in forum Samsung Galaxy Note 5
    Replies: 6
    Last Post: 09-14-2016, 12:49 PM
  2. Anybody having an issue logging in on The Weather Channel App?
    By chuckdawg1999 in forum Ask a Question
    Replies: 1
    Last Post: 01-06-2016, 06:36 PM
  3. I keep getting pops ups on my phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-06-2016, 06:34 PM
  4. How do I uninstall FitBit on my tablet?
    By AC Question in forum Fitness Trackers
    Replies: 1
    Last Post: 01-06-2016, 06:30 PM
  5. I need help with my GalaxyS3
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-06-2016, 05:04 PM
LINK TO POST COPIED TO CLIPBOARD