1. appmy's Avatar
    I'm wondering if I got a bad charger in the box or if other people are having this issue.

    When I plug my new phone into my Aukey charger I get a pop-up on the home screen that says "TurboPower Connected". When I plug the included TurboPower 25 charger, no pop-up. Anyone having this issue?

    Here is a screen shot of the pop-up:

    Posted via the Android Central App
    Attached Thumbnails Included TurboPower 25 not working?-159.jpg  
    09-10-2015 06:50 PM
  2. dpham00's Avatar
    Probably defective charger. Contact Motorola or the place of purchase

    Sent from my Verizon Samsung Galaxy Note 5
    Ry likes this.
    09-10-2015 06:58 PM
  3. guapinoy's Avatar
    I'm wondering if I got a bad charger in the box or if other people are having this issue.

    When I plug my new phone into my Aukey charger I get a pop-up on the home screen that says "TurboPower Connected". When I plug the included TurboPower 25 charger, no pop-up. Anyone having this issue?

    Here is a screen shot of the pop-up:

    Posted via the Android Central App
    Mine shows Turbo Powered.

    Posted via the Android Central App
    09-10-2015 07:46 PM

Similar Threads

  1. Why doesn't my Note 5 get a signal when connected to a mobile network?
    By AC Question in forum Samsung Galaxy Note 5
    Replies: 2
    Last Post: 09-11-2015, 11:12 AM
  2. Replies: 1
    Last Post: 09-10-2015, 09:05 PM
  3. Replies: 0
    Last Post: 09-10-2015, 06:09 PM
  4. Can I get some help with my Calendar App, PLS HELP?
    By eneyene in forum Samsung Galaxy S6 edge
    Replies: 0
    Last Post: 09-10-2015, 05:47 PM
  5. Replies: 0
    Last Post: 09-10-2015, 05:47 PM
LINK TO POST COPIED TO CLIPBOARD