1. 65fastback's Avatar
    Anyone having this issue?

    1.5 hours of screen on time and my screen accounted for 5% battery drain and Google play services at 17%
    10-06-2015 06:45 PM
  2. jackwagon06's Avatar
    No I'm not- battery was not great initially, but has settled in pretty good in a week.

    Check for a rogue app using location or something. Sounds like that to me.

    I'm at 1.5hrs/sot and at 59%
    10-06-2015 08:15 PM
  3. Sinfu's Avatar
    I had the same issue. What I did was disable sync and see if that fixes it. Then from there slowly start enabling things to sync. I believe Google fit data was the culprit.
    Also if your still having issues go to setting>data usage and from there go to play store and play services and disable background data. Should fix your issue!
    10-06-2015 09:47 PM
  4. 65fastback's Avatar
    i disabled/uninstalled all google apps that I dont use...seems to have solved it.
    10-07-2015 09:07 AM
  5. 65fastback's Avatar
    edit, i lied...still massive drain from google play services. grrr
    10-07-2015 09:45 AM
  6. Unobtanium's Avatar
    I was having the issue with my Droid Maxx. I uninstalled Google Play Services, then reinstalled it. Note: The actual process wasn't that straightforward. I had to disable Location Services and (IIRC) Device Administrators. I started getting all kinds of error messages from Google Apps that I needed to update Play Services ("duh, I am trying to do that"). But that cleared it up for me on the Maxx. Have not seen that issue on the MXPE yet.

    Posted from my XT1575
    10-10-2015 01:45 PM
  7. lewwill's Avatar
    Check Google Now for an Android 6.0 Marshmallow Review in 7 parts, one on battery. Very informative read on advances in Android OS. Look good for battery live going forward.
    10-10-2015 06:32 PM
  8. MartinMPL's Avatar
    This is an old problem.
    Try switching location services to battery saving and if that doesn't work, switch location services off.
    This is the most common fix but obviously you lose some functionality with the second option.
    10-13-2015 11:05 AM
  9. VoltaicShock's Avatar
    This is an old problem.
    Try switching location services to battery saving and if that doesn't work, switch location services off.
    This is the most common fix but obviously you lose some functionality with the second option.
    I thought one of the fixes was to either turn WiFi on or to keep it off. All I know is that they should have done a hotfix for this. Either by fixing it in Google Play Services or a patch to the OS (not sure it if OS related or services related)
    10-13-2015 12:17 PM

Similar Threads

  1. How to interpret Antutu Tester battery test score?
    By AC Question in forum Moto G (2015)
    Replies: 9
    Last Post: 10-10-2015, 10:17 PM
  2. Replies: 1
    Last Post: 10-06-2015, 08:35 PM
  3. Replies: 1
    Last Post: 10-06-2015, 08:30 PM
  4. Replies: 1
    Last Post: 10-06-2015, 08:12 PM
  5. How can I fix an error message in Google Search?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 10-06-2015, 06:47 PM
LINK TO POST COPIED TO CLIPBOARD