06-07-2017 12:39 PM
35 12
tools
  1. bkubel's Avatar
    Hello all! I recently purchased a Moto X Pure and am using it with Cricket. I recently noticed a problem that I have been running into. When the phone is connected to WiFi, my MMS messages will not send or receive. I have to physically turn off my WiFi network for the messages to come through or to send out. This is very frustrating. Has anyone else ran into this problem? I am using the Google messaging app and not the stock messenger app. Could this be the problem?
    10-19-2015 04:15 PM
  2. colton groters's Avatar
    Welcome to Android Central! MMS messages being texts or pictures or videos? Because pictures and video MMS messages are sent over LTE, not wifi

    This isn't an issue, its just how it works

    Posted via the Android Central App
    turbo93 likes this.
    10-19-2015 05:00 PM
  3. bkubel's Avatar
    I understand, but on my previous phone (Nexus 5), even with the WiFi turned on, it would automatically send a MMS message (texts and images) through LTE. With this phone, I'm having to toggle WiFi off so that it sends through, something that should be done automatically.
    10-19-2015 05:15 PM
  4. colton groters's Avatar
    My Moto G 2015 does the same thing your Pure does. Still waiting on my Pure to arrive

    Edit: Just tried it and it sent the picture in the background on Moto G
    Posted via the Android Central App
    10-19-2015 05:22 PM
  5. Almeuit's Avatar
    Hm that's odd. My pure edition on T-Mobile will send MMS via mobile data in the background even though wifi is connected.

    Are you using a 3rd party messenger app? If so ensure it isn't trying to send via WiFi when it shouldn't.
    Laura Knotek likes this.
    10-19-2015 06:00 PM
  6. bkubel's Avatar
    Yes, it's very odd. I've been using Google Messenger forever -- since I got my Nexus 5. Just switched it back to the default Moto one and it's doing the same thing.
    10-19-2015 06:09 PM
  7. evanwhat's Avatar
    I understand, but on my previous phone (Nexus 5), even with the WiFi turned on, it would automatically send a MMS message (texts and images) through LTE. With this phone, I'm having to toggle WiFi off so that it sends through, something that should be done automatically.
    bkubel, I'm in the same boat -- really annoying as I'll end up missing a lot of group conversations, pictures, etc. Any leads on this? I'm having the same problem on my Nexus 6 on Cricket Wireless. APN settings are correct, talked with Cricket customer service (points the finger at Motorola), tried using Google Hangouts for MMS/SMS same problem, still haven't figured it out. Previously was using a Galaxy S3 on Cricket and didn't have any problems with MMS while connected to WiFi.
    12-12-2015 01:16 PM
  8. walter1832's Avatar
    Count me in as well. It's been an issue for a while now. Moto X PE on Cricket using Hangouts. I need to turn off Wifi to get it to work. I called Cricket and they said it was normal for it to do this. I had a Nexus 5 on Cricket using Hangouts, and it did not have this issue. Frustrating.
    12-14-2015 12:02 PM
  9. radgatt's Avatar
    The only app I've seen where someone could send SMS and MMS over Wi-Fi is Verizon Messages.
    Ry likes this.
    12-15-2015 08:14 AM
  10. EastCoastBuff's Avatar
    I'm having the same issue. Also on Cricket. It is definitely an issue. I was using a Moto E while waiting for my Moto X Pure to get delivered and didn't have any problems. Do you think it is a Cricket issue, Marshmallow issue, or just a Moto X issue?
    12-15-2015 02:14 PM
  11. Ry's Avatar
    Sounds like a Cricket issue.
    12-15-2015 02:20 PM
  12. evanwhat's Avatar
    After more digging, found this thread on reddit (tried posting URL, but apparently am not allowed until I've posted 10 times -- google "another day with Cricket Wireless MMS ><"). Seems like they were able to manually resolve it through custom APN settings.

    I wasn't too keen on going that route, so tried using a new SMS/MMS app and that's worked for me -- using Textra now and haven't had any problems since. Hope this helps!
    SoNic67 likes this.
    12-16-2015 08:28 AM
  13. evanwhat's Avatar
    Wow! Submitted this to Cricket's customer service email and they replied in 12 minutes confirming:
    Billy M. (Cricket Wireless)
    Dec 16, 8:46 AM

    Hello Evan,

    Thank you for contacting Cricket Support. I am sorry to hear about the troubles you are having with your MMS while on WiFi. Our network team has been made aware of this issue and is currently working on a resolution. In the meantime you can use one of the IP addresses below in your MMS proxy under the APN settings which should fix the issue.

    192.168.196.78
    192.168.196.79
    192.168.196.117
    192.168.196.118

    Thank you,
    Billy
    Looks like the reddit guys were correct and IP addresses are legit.
    12-16-2015 09:05 AM
  14. Ry's Avatar
    I'll update the thread title to reflect Cricket.
    Jaysus likes this.
    12-16-2015 01:42 PM
  15. DJB628's Avatar
    Hello all! I recently purchased a Moto X Pure and am using it with Cricket. I recently noticed a problem that I have been running into. When the phone is connected to WiFi, my MMS messages will not send or receive. I have to physically turn off my WiFi network for the messages to come through or to send out. This is very frustrating. Has anyone else ran into this problem? I am using the Google messaging app and not the stock messenger app. Could this be the problem?
    Ditch Google Messenger, try stock messenger app or Textra and problem will be solve, I had the same issue with Google Messenger, and many other have also, check their forums you will see.
    12-24-2015 09:38 AM
  16. stanleywinthrop's Avatar
    I've been having the same problem with my 2014 pure. The issue seems confined to Google Texting apps (hangouts and messenger). MMS functionality with those apps while on WiFi is spotty. Using Textra avoids the problem.

    Posted via the Android Central App
    12-24-2015 10:26 AM
  17. bkubel's Avatar
    Wow! Submitted this to Cricket's customer service email and they replied in 12 minutes confirming:


    Looks like the reddit guys were correct and IP addresses are legit.
    FIXED! Thanks for sharing this. I updated my MMS proxy to the first IP address listed and MMS now works like a charm.
    iandefilippo likes this.
    12-24-2015 01:04 PM
  18. stonekingt's Avatar
    I checked all kinds of forums to fix the MMS issue, my settings were correct. I had the stock Samsung messenger app and then tried Google Messenger with no luck. However as soon as I downloaded Textra and set it as my default messaging app everything worked normally! Also I modified the Textra settings so I could see delivery receipt. VERY handy. Hope this helps someone else! :-)
    03-01-2016 10:51 AM
  19. iandefilippo's Avatar
    Awesome I have two phones on cricket that were fixed here with the same issue as described....I also used the top IP
    Thanks man!
    03-14-2016 02:29 PM
  20. Falfonse's Avatar
    Thanks, this did the trick for me as well.
    08-14-2016 12:29 AM
  21. Becca Breann's Avatar
    FIXED! Thanks for sharing this. I updated my MMS proxy to the first IP address listed and MMS now works like a charm.
    Can someone please in detail explain how to do this switch?
    08-14-2016 10:41 AM
  22. acejavelin's Avatar
    Can someone please in detail explain how to do this switch?
    MMS Proxy is in your APN settings... Set it to the first entry in this post http://forums.androidcentral.com/sho....php?p=4897373

    Or just switch to Textra
    pankaj981 likes this.
    08-15-2016 12:12 AM
  23. telrod11's Avatar
    Tweeted with Cricket support yesterday, and they tell me 300K is the limitation for MMS with them. Could this be part of the issue?
    08-16-2016 05:30 AM
  24. Abie Gonzales's Avatar
    just download the textra sms app and life will be so much easier on cricket I did works great. set as default
    08-16-2016 12:17 PM
  25. idbl_fanatic's Avatar
    PERFECT!!! I have been trying to figure this out since we switched to Cricket
    08-31-2016 11:37 AM
35 12

Similar Threads

  1. Wifi networks not showing up
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 02-23-2016, 08:53 AM
  2. apps not updating
    By Ryp11 in forum Motorola Droid Turbo
    Replies: 4
    Last Post: 12-18-2015, 12:55 AM
  3. Replies: 6
    Last Post: 12-16-2015, 05:39 PM
  4. Replies: 1
    Last Post: 12-16-2015, 12:46 PM
  5. Where is the accessory setting
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-16-2015, 12:12 PM
LINK TO POST COPIED TO CLIPBOARD