1. reamar12's Avatar
    Hey all. So I bought the pure off amazon about a week ago when they had the 50 dollars off deal. Its just the 16 gb Pure white model number XT1575 if that helps anything.

    After receiving it I went to att to get a nano sim since the s5 I was using was a micro (?) I think. Since then my download speeds are consistently between 5-15 mb/s as opposed to the 30+ I would get normally. All of the speed tests are taken from the same spot in my home. Also using other family members phones in the same spot still show the same 30+ mb/s which was the norm before switching to this device. Tests were done using ookla app.

    To me it seems like there is something that is not allowing me to get full speeds. I have heard of others having similar problems and having to use spoof IMEI numbers or something like that, except right now I don't think att has any Motorola phones that I could even ask them to try that with. Is there anything I can do in the settings that would help? Would going to the store and telling them my problem even accomplish anything? Since I purchased a non-carrier phone I get the sinking feeling they are not going to be very helpful if they are even willing to help me at all since I didnt buy my device from them.

    Anyone? I really like this phone but Im afraid if nothing can be done I will have to return/sell it.
    12-16-2015 07:11 PM

Similar Threads

  1. Replies: 3
    Last Post: 12-18-2015, 12:44 AM
  2. Replies: 2
    Last Post: 12-17-2015, 07:43 AM
  3. Replies: 1
    Last Post: 12-16-2015, 09:37 PM
  4. How do I find out what AT&T updated on my Zenfone 2E?
    By Traijan in forum ASUS ZenFone 2
    Replies: 0
    Last Post: 12-16-2015, 06:44 PM
LINK TO POST COPIED TO CLIPBOARD