1. manhattan123's Avatar
    I've had a strange thing happen to my Contacts list and hope you guys can help. It's a little confusing but here goes: I noticed the last few contacts I had added on my phone weren't on my list when I looked for them. I thought maybe I had forgot to hit "save" - the little check mark you tap after putting in all the info - so entered one again and then as I was about to save it, I noticed the field was set to a secondary Gmail account I have on my phone, not my main Gmail name that I use. The second account is one I have for email subscriptions, commenting on boards like this online purchases, etc. so I don't get my main Gmail account cluttered with spam and newsletters.

    The problem is, I can't see a way to move a New Contact field over to my main Google account. Usually, when it's a Google product on the phone, I can choose which account I'm logged on and move between them, as I still can with my Gmail, YouTube and Google+ apps. But with Contacts it's set to that secondary account and there doesn't seem to be a way to switch it that I can see.

    Note: in Contacts settings, under "Contacts to Display" I can have it set to "All contacts" which then gives me both accounts and I can see those new contacts I've recently added, BUT that then gives me all the nonsense stuff from that secondary account which I don't want in my contacts list. So how do I get the New Contact field to be defaulted to my main Google account as it always has been until recently?
    02-26-2016 10:54 AM
  2. SpookDroid's Avatar
    You shouldn't be 'logged in' to any account in your Contacts app, but when you CREATE a contact, you should be prompted on where to save it. THAT should show all your Google Accounts (I have three on my phone!). Just make sure that you select the right account and the next time you create a contact it should be the default one (it takes whatever you used last).

    As for the contacts already created in the other account, you may be able to import them into your main account or just add them manually if they're not a bunch.
    02-26-2016 01:33 PM
  3. thejesse's Avatar
    I've experienced this issue, with Android randomly switching the account to which new contacts save. I've if there is a way to transfer contacts between Google accounts of love to know.
    manhattan123 likes this.
    02-26-2016 03:09 PM
  4. manhattan123's Avatar
    Well that's the thing. When I go to save a new contact it's now set to go into my secondary Google account and I can't see a way to change it. They were always going in to my main account until I noticed this a few days ago. I don't know how it changed and my question was how to get the default set back to be my main account.
    02-26-2016 03:39 PM
  5. SpookDroid's Avatar
    In theory once you select Google - Main Account when you create a contact, the next contact you create should be saved there by default unless you change it.
    02-26-2016 05:12 PM
  6. nturavgjoe's Avatar
    This is also happening to me. Prior to Marshmallow update I could add a new contact to my Droid Turbo 2 and have the opportunity to change which account on my device I could save to (I have multiple gmail accounts). After Marshmallow it does not let me choose. I am forced to save it to the default account. This is a pain as I am often saving contacts to multiple gmail accounts.
    04-02-2016 09:56 AM
  7. manhattan123's Avatar
    I should have updated this post, but I found out what the issue was. When you are in Add New Contact mode, you have to scroll down to the very bottom of the screen to where it says More Fields - it's actually off my screen so you have to scroll under the Email field, which is the last one you can see - and there you can change the Google accounts.

    I don't know why they make such a major field reside in the extra ones you have to actually work to get to, nor how it ever got switched from my main Google account to one of my secondaries, but now I've got it back on the main as the default setting for all new contacts.
    Doug Strohl likes this.
    04-05-2016 10:31 PM
  8. rebootfl0k's Avatar
    I should have updated this post, but I found out what the issue was. When you are in Add New Contact mode, you have to scroll down to the very bottom of the screen to where it says More Fields - it's actually off my screen so you have to scroll under the Email field, which is the last one you can see - and there you can change the Google accounts.
    Thank you so much. I have been pulling out my hair trying to figure this out. This is the solution.
    05-20-2016 07:54 AM
  9. Doug Strohl's Avatar
    Thanks. This was making me nuts too.
    05-21-2016 11:44 AM
  10. berrygood909's Avatar
    Thanks your for this solution. It must be a Marshmallow thing.
    06-09-2016 07:05 AM
  11. tastisnax's Avatar
    THANK YOU. I was just going insane trying to figure this out. You saved me a lot of frustration!
    12-24-2016 12:05 PM
  12. Chris Kutsch's Avatar
    I was quite hopeful after reading this post, Unfortunately on my ZTE this solution does not work for me. Even under the extended options there is no way for me to change which account they are going into. It used to ask me which account I wanted to save it to but now it automatically puts them in the wrong one. If anyone has an alternate solution please post.

    I should have updated this post, but I found out what the issue was. When you are in Add New Contact mode, you have to scroll down to the very bottom of the screen to where it says More Fields - it's actually off my screen so you have to scroll under the Email field, which is the last one you can see - and there you can change the Google accounts.
    01-08-2017 09:12 PM
  13. rawraj's Avatar
    Thank you so much. I have been pulling out my hair trying to figure this out. This is the solution.
    I dont see this option
    I clicked on more fields. I am using Marshmallow. Moto X play

    I reset my phone and when I saved my first contact after resetting it asked me for the account Accidentally i selected the wrong account.

    Now I dont know how to change the default I have been through all setting just cant find it.

    When I reset my phone I realized that a lot of contacts have been Randomly saving on other accounts. How to avoid that?
    I added only one account and lot of contacts were not there.
    05-30-2017 09:24 AM
  14. normofthenorth's Avatar
    This may be obvious to everybody, but in case it isn't: After you select More Fields, you should see your (wrong) Google account near the top. Click on it and the menu/list with all your accounts should appear. Select the right one and voila! (Worked for me, thanks!)
    09-13-2017 02:19 PM

Similar Threads

  1. Need help with contact clean-up
    By MikeDeTiger in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 02-28-2016, 09:59 AM
  2. How do I fix it when my phone is in FRP lock?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 02-26-2016, 10:38 AM
  3. Original Google Cardboard and Note Edge?
    By AC Question in forum VR Headsets
    Replies: 0
    Last Post: 02-26-2016, 10:37 AM
  4. Replies: 0
    Last Post: 02-26-2016, 10:23 AM
  5. How to I go from Marshmallow back to Lollipop?
    By AC Question in forum Android 5.0 Lollipop
    Replies: 0
    Last Post: 02-26-2016, 10:23 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD