1. David Rosen's Avatar
    Every Android phone I've had since the G1 (then G2, MyTouch Slide 4G, HTC One X, Galaxy S3, Galaxy Note 3, Galaxy Note 4) has started to get slow and horrible to use after a few months.

    I got the Moto X Pure at launch and it was perfect. The smoothest phone ever, despite being specced not even as good as my previous phone, the Note 4. Even smoother than my girlfriend's shiny new Note 5. And a few months later... It was still fast and smooth and perfect!

    Then Marshmallow came and introduced Bluetooth issues... I put it off and put if off but eventually begrudgingly did a pain in the **** system restore about a month ago. It didn't really help my Bluetooth issues (sure for a couple days but it didn't last). So I figure I'll survive with the Bluetooth issues... BUT now, like I said, about a month since the system restore, it's finally happening...

    Slow down. Lag. Poor performance returning to the home screen from apps. Slow to open the camera. Slow to get to the gallery. Slow to bring up the keyboard.

    Not rooted/ROM'd. No custom launcher. Barely any widgets (Chronus, Any.do and the persistent Google Search bar). Not even using half of my 64gb storage. No SD Card installed. Using almost entirely just stock Google apps (no custom keyboard, no custom SMS, no custom browsers, etc etc). Cleared my caches, but the problem returns within hours or if I'm lucky, a day or two. Mostly it gets bad when the phone starts heating up. And it gets really hot when it heats up. At first I used to think everyone was overexaggerating their overheating issues because I did feel it heat up from time to time... But not like this. Now it gets HOT. And then it gets SLOW.

    So. Any suggestions? I don't want to have to wipe again because I know that that means I'll be wiping the phone every 2 months like I had to with all my previous phones.
    ShanesHouse likes this.
    04-19-2016 12:53 PM
  2. BME_'s Avatar
    Back it up and flash a custom rom
    04-19-2016 12:55 PM
  3. David Rosen's Avatar
    Ugh... I just don't trust it. I should have added a paragraph about how I used to flash custom ROMs on all my previous phones too, but they all got slow after a couple months and required wiping and flashing another custom ROM... Which to me means that it's not the custom ROM that makes the phone run good... It's the wiping and starting all over that does.
    ShanesHouse likes this.
    04-19-2016 01:14 PM
  4. Ry's Avatar
    Not noticing any slow downs on my Moto X. Only change I've made was adding an SD card (Samsung Pro+) for photos, not adoptable storage. Wiped cache probably back in December after the Marshmallow update. Have never done a factory reset.

    The only think I could think of that I do that other people don't is clear out text messages periodically.
    David Rosen and Laura Knotek like this.
    04-19-2016 01:18 PM
  5. David Rosen's Avatar
    Not noticing any slow downs on my Moto X. Only change I've made was adding an SD card (Samsung Pro+) for photos, not adoptable storage. Wiped cache probably back in December after the Marshmallow update. Have never done a factory reset.

    The only think I could think of that I do that other people don't is clear out text messages periodically.
    Hey thanks, clearing out text messages is something I forgot about and maybe worth trying. I don't really see how it will help such overall performance issues I'm having but hey, worth a shot :-) I just said screw it and didn't even try to save pics. Deleted all threads... We'll see how it goes.
    04-19-2016 01:28 PM
  6. hrbib21's Avatar
    I know you said you "cleared caches" but, just to make sure, did you clear internal cache? Settings > Storage and USB > Internal Storage > Cached Data

    Posted via the Android Central App
    04-20-2016 01:10 AM
  7. emcmorrow's Avatar
    I know you said you "cleared caches" but, just to make sure, did you clear internal cache? Settings > Storage and USB > Internal Storage > Cached Data

    Posted via the Android Central App
    Thanks, tried this on my Pure X and seemed to work. Had 2GB cached and immediately the camera, text and switching apps was much faster.
    02-20-2018 02:00 PM
  8. Ry's Avatar
    A factory reset could do wonders.
    Laura Knotek likes this.
    02-27-2018 03:00 PM
  9. PapaGary's Avatar
    A factory could do wonders.
    Yes, a factory reset does work wonders. It made me 1st gen Moto X almost like new again.
    Laura Knotek likes this.
    02-27-2018 11:45 PM

Similar Threads

  1. Gear VR is setup but no free games found.
    By metz65 in forum Samsung Galaxy S7 edge
    Replies: 9
    Last Post: 04-24-2016, 01:32 PM
  2. Replies: 1
    Last Post: 04-19-2016, 11:58 PM
  3. how to have my samsung galaxy s6 visible to my pc
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-19-2016, 06:45 PM
  4. Replies: 2
    Last Post: 04-19-2016, 06:44 PM
  5. Replies: 1
    Last Post: 04-19-2016, 01:47 PM
LINK TO POST COPIED TO CLIPBOARD