1. itslikeimsayin's Avatar
    For about a week I've had an issue with the screen of my Moto X Pure Edition and am wondering if anyone else has experienced this or knows a fix. Here's what happens:

    Anytime I haven't used my device for a while (more than 10 minutes or so), the display appears very faint and/or has vertical stripes running through it. It also often has a very annoying flicker as if the power to the display is fluctuating. After using my device for a few minutes, however, these issues disappear and the screen displays as normal.

    Here's another interesting wrinkle: When I took a screen shot with the vertical stripes on my screen, they do not appear in the screen shot.

    I found this article with something that sounds vaguely related to my issue: Moto X Pure owners complaining of display driver issues - Android Authority, but I'm not sure this is exactly what I'm experiencing.

    I did boot into safe mode a few days ago, and it did not fix the problem.

    Does anyone have any advice for me? Luckily, the phone is within the warranty, so I can send it back I guess, but I'd prefer to find a fix without having to use an alternate phone for a while and all the hassle of sending it in to Motorola. Thanks.
    06-28-2016 01:48 AM
  2. Laura Knotek's Avatar
    I haven't had that issue on mine.

    My suggestion would be to send it for warranty service, since it sounds like a hardware problem.
    06-28-2016 01:58 AM
  3. skipatrol's Avatar
    I know it's annoying but my recommendation would be to send it back. Sounds like a hardware issue.
    06-28-2016 10:24 PM
  4. Tish Winton's Avatar
    For about a week I've had an issue with the screen of my Moto X Pure Edition and am wondering if anyone else has experienced this or knows a fix. Here's what happens:

    Anytime I haven't used my device for a while (more than 10 minutes or so), the display appears very faint and/or has vertical stripes running through it. It also often has a very annoying flicker as if the power to the display is fluctuating. After using my device for a few minutes, however, these issues disappear and the screen displays as normal.

    Here's another interesting wrinkle: When I took a screen shot with the vertical stripes on my screen, they do not appear in the screen shot.

    I found this article with something that sounds vaguely related to my issue: Moto X Pure owners complaining of display driver issues - Android Authority, but I'm not sure this is exactly what I'm experiencing.

    I did boot into safe mode a few days ago, and it did not fix the problem.

    Does anyone have any advice for me? Luckily, the phone is within the warranty, so I can send it back I guess, but I'd prefer to find a fix without having to use an alternate phone for a while and all the hassle of sending it in to Motorola. Thanks.
    Wondering what you ended up doing? Been having this on and off with my MXPE for a few months now but sometimes it goes without doing it for long enough that I forget about checking more into it, not to mention that I'd rather not have to try to deal with sending my phone in (I don't have a backup)!
    09-04-2016 10:07 PM
  5. Hardc0r3_Max's Avatar
    Hi there.I got little relaxation after watching your post.Because since 4/5 days I am facing your problems exactly.So have you found any solution?Please let me know.I am really very sad for this.From last two months I am using my Motorola X Pure Edition,64GB.Before passing at least a year how could this happen to this handset?
    10-19-2016 10:43 AM
  6. itslikeimsayin's Avatar
    My apologies for never replying to these. Maybe I started a new thread and never updated this one, but it got so bad I eventually had to send it in. Motorola fixed it or sent me a different phone back, which i never really figured out which happened. Anyway, unfortunately there was no other resolution to this.
    11-04-2016 02:08 AM

Similar Threads

  1. Replies: 2
    Last Post: 06-28-2016, 03:02 AM
  2. Replies: 0
    Last Post: 06-28-2016, 01:26 AM
  3. Lost home screen clock on my Android Galaxy Tab A, how can I fix this?
    By AC Question in forum Samsung Galaxy Tab A (8 & 9.7)
    Replies: 1
    Last Post: 06-27-2016, 10:13 PM
  4. Replies: 1
    Last Post: 06-27-2016, 10:12 PM
  5. Replies: 1
    Last Post: 06-27-2016, 10:12 PM
LINK TO POST COPIED TO CLIPBOARD