1. sodak77's Avatar
    Had the phone since Feb and no issues until today. I applied the May security patch today at lunch time without issue and when I got home from work I put it on the oem Turbo Charger while it was still on. Came back a few hours later and it was powered off and I can not get it back on. I tried holding down the power button for a few minutes and I also tried Power & Volume Down and neither worked.

    Anyone experience anything similar? I am guessing just a freak failure... Odd since my phone had been working great leading up to tonight.
    08-09-2016 11:31 PM
  2. acejavelin's Avatar
    Try a different charger and cable and see if the battery icon appears. If it is completely dead it may need to charge for 30-60 minutes before you can turn it on. It is not unheard of for the Moto factory charger to fail.
    08-10-2016 09:20 AM
  3. sodak77's Avatar
    Tried this last night as well. The OEM Turbo Charger was able to charge one my backup Moto X (2013) so I ruled that out as being an issue. I also tried a different charger for my MXP and still nothing after a few minutes. I will try leaving it on the charger for a longer time when I get home tonight as it will not hurt to try.
    08-10-2016 11:24 AM

Similar Threads

  1. Replies: 13
    Last Post: 01-20-2017, 03:05 PM
  2. No Nougat update for G4?
    By jhilker in forum LG G4
    Replies: 10
    Last Post: 08-14-2016, 11:54 PM
  3. will a lg g3 case fit the lg k4
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-10-2016, 05:46 AM
  4. i saved images on a created clipboard,how to view it & forward
    By MUHAMMAD NAWAZ1427 in forum General Help and How To
    Replies: 1
    Last Post: 08-10-2016, 12:46 AM
  5. My HTC Amaze 4g will not turn on.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-09-2016, 10:35 PM
LINK TO POST COPIED TO CLIPBOARD