1. Ccota08's Avatar
    So, I tried switching to ART and, after rebooting, I started testing all my apps to see how well they run. When I got to Whatsapp, I was getting repeated crashes. I tried uninstalling and reinstalling, but I couldn't reinstall. When I looked it up on the internet, I found that the problem was not with the app itself, but with ART in 4.4 and that the issue had been addressed in the 4.4.1 update, which isn't available for the Moto X yet. So, I tried switching back to Dalvik, but now I still can't reinstall Whatsapp even in Dalvik runtime. Anyone know how to fix this?

    EDIT: I get an error box when I try to install from the Play Store. "Unknown error code during application install: -24". I tried downloading the apk from the Whatsapp website and sideloading it, but my phone won't install that either.

    EDIT 2:I found the issue. It seems a leftover shared element from Missed It! was preventing it from installing. After I deleted the shared element, Whatsapp installed just fine.
    12-31-2013 12:42 PM
  2. srkmagnus's Avatar
    Glad to see you resolved the problem - thanks for coming back and sharing your fix!
    01-07-2014 09:48 AM

Similar Threads

  1. ASUS MeMO Pad HD7 - Cannot install apk
    By Scott Hansen2 in forum ASUS MeMO Pad HD7
    Replies: 3
    Last Post: 05-11-2014, 04:41 AM
  2. Moto G contract?
    By Bballbenb in forum Moto G
    Replies: 3
    Last Post: 01-01-2014, 06:11 PM
  3. My Evo 4g LTE has no os installed, I need help!
    By FloZell in forum HTC EVO 4G LTE Rooting, Rom's, and Hacks
    Replies: 1
    Last Post: 01-01-2014, 03:18 PM
  4. Replies: 5
    Last Post: 01-01-2014, 02:41 PM
  5. Dashclock -- Can't get Phone dialler extension to open Direct Dial
    By rb_stern in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 12-31-2013, 03:18 PM