1. randian's Avatar
    For some unknown reason my Moto X has been "stuck" in HSPA+ on T-Mobile for the last day or so. It won't catch LTE as usual. So either TM has turned off LTE, which is unlikely here in Phoenix, one of its flagship LTE areas, or there is some problem with my phone. I've tried powering on/off to no avail. I have not dropped it recently. What can I do to look at and solve this problem? I'm running unrooted 4.4 on an XT1053.
    02-04-2014 05:29 AM
  2. Aquila's Avatar
    Check Settings > More > Mobile Networks > Network Mode first and Settings .... Mobile Networks > Select Network (Usually set to Automatic).
    02-04-2014 05:41 AM
  3. itic's Avatar
    Try toggling airplane mode
    02-04-2014 11:12 AM
  4. randian's Avatar
    Did the airplane mode toggle. No dice. What fixed it was setting the Network Mode, which for some mysterious reason had Automatic turned off. Thanks for the advice everybody.
    02-04-2014 12:26 PM
  5. Rob220's Avatar
    I'm glad you figured it out because I was going to tell you I've had no issues with my LTE connection in Phoenix.
    02-04-2014 04:27 PM

Similar Threads

  1. Samsung S4 Wifi is stuck on "Turning On"
    By chris332211 in forum General Help and How To
    Replies: 11
    Last Post: 08-03-2017, 08:47 AM
  2. LS980 stuck on ZV7... HELP PLEASE
    By soulgrnd in forum Sprint LG G2
    Replies: 14
    Last Post: 02-08-2014, 12:13 AM
  3. HTML 5 Video issue in android
    By JobinKurian23 in forum General News & Discussion
    Replies: 0
    Last Post: 02-04-2014, 12:15 AM
  4. Cannot Turn on Wifi (Wifi is stuck)
    By Louis Manlangit in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 02-03-2014, 09:22 PM
  5. Replies: 3
    Last Post: 02-03-2014, 09:14 PM