1. GSOAT's Avatar
    Hey guys- I got my Moto X today, took the SIM out of my iPhone 5, put it into the Moto X, set it up, and then promptly texted my sister (who has an iPhone) using the stock messaging app. She replied, but the reply didn't come to my new Moto X- it went to my iPhone, which was on wifi despite not having a SIM card. I know little to nothing about all of the variations, like SMS and all that, plus I am new to Android.

    Can someone walk me through how I get a messaging app (I don't care which one) set up to send and receive text messages correctly? It is disappointing that something so simple doesn't work right out of the box...

    Thanks in advance!
    10-03-2014 04:41 PM
  2. mhunter6378's Avatar
    On the iPhone, open settings, Message, scroll down to Send & Receive and tap where it says "addresses", tap where you see you Apple ID, then sign out. Do the same for FaceTime, tap your Apple ID and then sign out of FaceTime. If you have an iPad, Mac or any other Apple devices that you use for iMessage, sign out on them as well. That will release your phone number from the Apple servers. You should be able to get SMS from iPhones after that. Until your number is signed out from your Apple ID, all your texts from iPhones will go to your Apple ID.
    GSOAT likes this.
    10-03-2014 04:50 PM
  3. planoman's Avatar
    You have to turn off iMessage on your iPhone before taking the SIM out and putting it into you Moto X. When using the iPhone, sign out of and turn off iMessage on the iPhone and any other i devices that use the same apple id (if you use it with apple id) i.e. iPad, then turn off and swap your SIM to the Moto X and it should work.

    I got the iPhone 6+ and was going back and forth with my Nexus 5 and and have not had any issues with text messages.
    GSOAT likes this.
    10-03-2014 04:53 PM
  4. drew_sf's Avatar
    It might be helpful to tell your iPhone user friends to change you from being listed as "iPhone" to "mobile" in their contacts list so their phone won't send you a text through iMessage.
    GSOAT likes this.
    10-03-2014 05:10 PM
  5. GSOAT's Avatar
    You have to turn off iMessage on your iPhone before taking the SIM out and putting it into you Moto X. When using the iPhone, sign out of and turn off iMessage on the iPhone and any other i devices that use the same apple id (if you use it with apple id) i.e. iPad, then turn off and swap your SIM to the Moto X and it should work.

    I got the iPhone 6+ and was going back and forth with my Nexus 5 and and have not had any issues with text messages.
    I took the SIM out before I turned off those settings. I guess that means I have to put the SIM back into the iPhone 5, turn off the messaging on my iPhone, and then put the SIM back into the Moto?

    Also, do you guys know how to:
    Remove the "AT&T" at the top of the screen?
    Include the % next to the battery logo at the top of the screen?

    Sorry if these are elementary questions, but I'm just getting my feet wet!
    10-03-2014 06:52 PM
  6. mhunter6378's Avatar
    I took the SIM out before I turned off those settings. I guess that means I have to put the SIM back into the iPhone 5, turn off the messaging on my iPhone, and then put the SIM back into the Moto?

    Also, do you guys know how to:
    Remove the "AT&T" at the top of the screen?
    Include the % next to the battery logo at the top of the screen?

    Sorry if these are elementary questions, but I'm just getting my feet wet!
    Settings>more>mobile networks - uncheck Show Mobile Network
    Have not found a native way to display battery percentage, I don't think there is a setting for that...
    And yes to putting the sim back in and turn off (sign out of) iMessage.
    planoman, sharkita and GSOAT like this.
    10-03-2014 07:07 PM
  7. GSOAT's Avatar
    Thanks guys- it seems to have worked, eventually. I think the AT&T network took a while to figure out what was happening, and suddenly, without any notice, it started working as it should.
    10-03-2014 10:28 PM
  8. thegrants82's Avatar
    This is the correct response. They key is to turn off iMessage while the sim is still in the iPhone.
    You have to turn off iMessage on your iPhone before taking the SIM out and putting it into you Moto X. When using the iPhone, sign out of and turn off iMessage on the iPhone and any other i devices that use the same apple id (if you use it with apple id) i.e. iPad, then turn off and swap your SIM to the Moto X and it should work.

    I got the iPhone 6+ and was going back and forth with my Nexus 5 and and have not had any issues with text messages.
    GSOAT likes this.
    10-11-2014 09:04 AM
  9. booboolala2000's Avatar
    Its an Apple thing. They don't want to make it easy for people to leave them. Had to walk my boyfriend through the same process. Its very shady on Apples part

    Posted via the Android Central App
    GSOAT likes this.
    10-11-2014 09:45 AM

Similar Threads

  1. New Android User
    By Nisse Tuta in forum New to the Forums? Introduce Yourself Here!
    Replies: 11
    Last Post: 10-05-2014, 10:55 PM
  2. How do I re-install OS On Android Phone?
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 10-05-2014, 10:50 AM
  3. modified update problem
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-03-2014, 05:59 PM
  4. How do I change text messages from MMS to text format?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-03-2014, 04:15 PM
  5. Is there an app that will auto send message that I'm driving?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-03-2014, 01:58 PM
LINK TO POST COPIED TO CLIPBOARD