1. AC Question's Avatar
    Yesterday, I was using my phone (Moto X 2nd Gen running Android 6.0) and it was working all right. Then suddenly the screen went all pink and the text was barely visible. I had to crank the brightness all the way up just to make out the text. Since then the phone is just on low brightness and I am unable to read anything unless the it's at full brightness. The text is still messed up and quite difficult to read. During any transits the screen tends to kinda lag behind for a millisecond taking a appearance as if there's smudge on the screen. I have soft reset and hard reset my phone. The problem is still persistent. I wish to know if it is a hardware or a software issue. If it is a software issue, I'll have to risk reinstalling the whole OS again.
    03-01-2016 05:05 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Since it persists after a factory reset, it's almost certainly a problem with the screen. You'll need to bring it to a repair shop.
    Prateek Dhanuka likes this.
    03-01-2016 12:19 PM
  3. Prateek Dhanuka's Avatar
    I have already reset my phone twice. Once using the given reset option and once from the bootloader menu but the problem is still persistent.
    03-01-2016 08:10 PM
  4. B. Diddy's Avatar
    Right, so that's why I suggested bringing it to a repair shop.
    Prateek Dhanuka likes this.
    03-02-2016 01:37 AM

Similar Threads

  1. Replies: 2
    Last Post: 03-01-2016, 03:33 PM
  2. Replies: 1
    Last Post: 03-01-2016, 04:30 AM
LINK TO POST COPIED TO CLIPBOARD