1. AC Question's Avatar
    1 day old Moto X Play, and neither of these issues were present yesterday. It would lock after pressing power button or sleeping naturally and PIN was required to wake up, and PC recognized it fine and used it to transfer my stuff to it on the first day.

    This is my first Android. I installed Nova Launcher, but didn't do much other than movie icons around. Smart Lock is off, PIN security is activated, phone is set to lock on hitting power button or if phone is asleep for five seconds. Nonetheless, it just turns the screen off no matter what, it doesn't lock, so the power button just wakes it back up to the home screen.

    As for the PC issue, it charges when plugged into my PC, so the connection is made, but they no longer recognize one another. I believe it is upgraded fully - I haven't been rolling it back or forbidding updates or anything.

    What gives? Tks.
    04-14-2016 09:22 PM
  2. Javier P's Avatar
    Welcome to the forums! About the USB connection. Once you plug your phone into the PC swipe down from the status bar, tap on the USB entry and select MTP.

    Not sure about the lock screen. You could try safe mode and see if the problem persists. This will tell you if there's a conflict with a third party app that you downloaded.

    Tell us how it goes.
    Laura Knotek likes this.
    04-14-2016 09:35 PM
  3. OfficialJab's Avatar
    Thanks for answering so quickly.

    Noob question I'm afraid - the 'Status Bar' is the notification bar at the top of the screen with my signal strengths etc? If I swipe down from there there's nothing to tap or interact with, just a message that there are no new notifications. I'm probably in the wrong spot.

    Just checked now - both problems persist in Safe Mode!
    04-14-2016 09:52 PM
  4. OfficialJab's Avatar
    Sorry, just had to pull up an account to keep replying I think, so I am thread author fyi.

    Tks again - not sure what could be causing this!
    04-14-2016 10:22 PM
  5. Javier P's Avatar
    Thanks for registering! Did you install a new system update? Which android version is your phone running? You can find this information in settings - about phone.

    Let's try something different for the lock screen. Long press on a blank spot in your screen, select widgets, first in the list will be Nova actions. Long press on it, drag it to your home screen and select 'screen lock'. This will create a shortcut on your home screen. Tap on it and see how it works.

    About the USB. Do you mean that you don't get a notification after you plug the phone into the PC? That's weird. Take a look at this article.

    Inside Marshmallow: USB connection options http://www.androidcentral.com/inside...ection-options

    If nothing works you could try clearing cache in settings - storage & usb - cached data and then restart your phone. You could also wipe the cache partition via recovery.
    04-15-2016 09:07 AM
  6. Javier P's Avatar
    Also, I'll get in touch with the moderators and see if they can move this thread to the X Play forum where you could get more feedback from other owners.
    04-15-2016 09:35 AM
  7. OfficialJab's Avatar
    I'm running 6.0

    Made the Screen Lock icon, but it did the same, just turning off the screen essentially. Power button still just wakes it up with no PIN required.

    About the USB, neither the PC or phone react, other than the phone's battery indicator getting the lightning bolt indicating charging. I'm not sure if I'm looking in the wrong spot, but there's nothing in the status/notification bar for me to tap on as it describes in the page you linked.

    I did the cache clear, and restart - both issues still present. What a pickle!

    Thanks for the thread move - do you suppose it's something particular to the Moto, or Marshmallow/Nova? Not Nova I suppose since the Safe Mode didn't change it.
    04-15-2016 10:25 AM
  8. Javier P's Avatar
    Very strange. The screen lock widget should override any smart lock setting, so we need to look in a different place. Try this. Go to settings - security - screen lock. Do you get a screen to enter your pin? If so, enter it and change it to pattern. See what happens.

    Can you use a different USB lead to connect to your computer? Also, try the cache partition wipe.

    I think this issue is particular to your phone. Never read before about this screen lock problem (Lollipop or Marshmallow).
    04-15-2016 10:35 AM
  9. OfficialJab's Avatar
    Yep I was required each time I visited the security menu to enter my PIN. I changed to pattern, now I have to enter that to go into the security menu, but the phone still won't lock.

    I've tried on two different PCs, three total USB cables. Is the 'cache partition wipe' different than the "clear cached data" that I did?
    04-15-2016 10:48 AM
  10. Javier P's Avatar
    Yeah, they are different processes. These Motorola instructions should work.


    I'm not sure what else to suggest short of a factory reset. It's a brand new phone and shouldn't present these problems. There's a chance that you've got a faulty device. Try one more thing. Go to settings - apps - three dots top right - reset app preferences, then restart.

    Just in case I would backup everything you don't want to lose and get prepared for a factory reset.
    Laura Knotek likes this.
    04-15-2016 11:01 AM
  11. Javier P's Avatar
    Forgot to mention. On the X Play the cache wipe usually takes a few seconds.
    04-15-2016 11:21 AM
  12. OfficialJab's Avatar
    No change - even tried Safe Mode again because I figure it must have been an app (only got six that were very popular) or Nova, but not luck. I guess we might be down to factory reset... thanks for your help anyway! Sorry to pretty much waste your time! If it happens again or something, I'll update this since who knows, that would be more mystery!

    Thanks again!
    04-15-2016 11:49 AM
  13. Javier P's Avatar
    No problem! Please, report back, your feedback will be very helpful for other people with a similar issue. Good luck.
    04-15-2016 11:59 AM
  14. Javier P's Avatar
    I was thinking about what else could interfere with the lock screen and I had a couple more ideas. Long shots but still worth trying before a factory reset

    In your app drawer open the Moto app, tap on the three stars top right, select Moto Display and switch it off.

    Go to settings - security - device administrators and see what apps are checked in there.
    04-15-2016 01:04 PM
  15. OfficialJab's Avatar
    Hi, thanks for sticking with it!

    Did the first bit with the Moto app (no change) and the Device Administrators menu shows Android Device Manager and Nova Launcher with their boxes checked.
    Android Device Manager
    "Allow Android Device Manager to lock or erase a lost device"

    Nova Launcher
    "Screen Lock Nova Action" (i think 'Screen Lock is the thing we used before at one point)
    04-15-2016 01:17 PM
  16. Javier P's Avatar
    Oh well! I think that was my last bullet mate
    04-15-2016 01:21 PM
  17. OfficialJab's Avatar
    Well - I did the factory reset and it's working now!

    ...except, I have a new problem I used their new feature to set the SD card as 'internal' so that I could store my Audible data on it, and when I hook up to my PC, I can transfer things to the regular internal memory, but not the SD card! It just shows 10GB folder named 'internal storage' while my SD card is 128GB.

    Lurking around trying solutions that aren't working, but thought I'd give an update here.

    Managed to sort that out by going to the SD under USB & Storage and 'migrating' which took a few minutes, now the PC sees all 100+GBs! New problem!

    Trying to transfer anything, even one folder with 12 music tracks, crashes the process (desktop running W8) in very short order and explorer reboots. It reads the folders on the phone very very slowly, minutes to open a folder, and the SD card is a recent SanDisk, the USB cable or port (3.0) I use doesn't affect this. One day my new phone will work well... right?
    04-15-2016 10:56 PM
  18. Javier P's Avatar
    Glad you managed to fix some of your issues. I posted a link from Motorola in your other thread, related to your SD card problems.
    OfficialJab likes this.
    04-16-2016 05:12 PM

Similar Threads

  1. Replies: 2
    Last Post: 04-18-2016, 11:20 PM
  2. Need a new (genuine) S-Pen - where can I buy the real deal?
    By gnGracie in forum Samsung Galaxy Note 5
    Replies: 8
    Last Post: 04-18-2016, 06:34 PM
  3. WHy will my Lg G3 not charge?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-14-2016, 09:13 PM
  4. Will the ZTE Prestige be faster than the LG Optimus L70?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-14-2016, 09:06 PM
  5. Where is the Development Application option in my Galaxy S3?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-14-2016, 08:51 PM