1. AC Question's Avatar
    Phone: Moto X (2nd generation)
    Carrier: Republic Wireless
    OS: Lollipop 5.1 (I think...I haven't checked in a while)

    Hi all,

    Any help would be much appreciated. This phone is basically where my job lives, so I'm professionally very hindered without it.

    The problem:

    I've had my Moto X (2nd gen) for about 54 weeks (which makes me think someone programmed my phone to fail just after warranty period), and it is stuck in what I believe is called "boot loop." Basically, it forever shows the very first screen you see when powering it on--the blue Motorola symbol on a white background, with "powered by android" at the bottom of the screen. It has been on this screen for about 4 hours now, and does not change unless I try to restart the phone / enter system recovery.

    By holding the power button I can get it to attempt a restart...screen goes black and then it powers up again automatically (i.e., it doesn't "turn off" as such, it turns off and then automatically powers back on), but only gets to the same screen mentioned before, and then hangs there indefinitely.

    The background to all this...

    1) Phone has not been rooted, hacked, or otherwise had its OS modified (that I know of). It is a stock Android. Android version, I think, is 5.1. It's been a while since I last looked.

    2) Phone has no apps installed that were not found on the Play Store. The most "fringe" or "risky" apps I have are CCleaner, Ever Accountable, a custom "My Church" app by Elexio, ES App Locker, ES File Explorer, Startup Manager, Web Blocker, and MTG Unofficial. I had Automate at one point, but it scared the daylights out of me and I uninstalled it without ever using it. The only game I have right now is Solitaire. I am the most boring phone owner you know.

    3) I just installed AVG Antivirus from the Play Store last week. I finally got around to activating it this morning, about 2 hours before all the trouble started. That correlation is a red flag in my mind, but I'm a total novice about phones. I remember seeing something like "1 issue detected" during its initial scan, but then the toddler needed breakfast so that went unresolved. I think the next thing that happened with the phone was taking a photo of cream cheese all over the kiddo's face. I doubt the problem is cream cheese, but I AM a novice. Maybe the virus/issue bricked my phone to protect itself from AVG and/or cream cheese.

    4) I typically run the memory margin pretty thin. I get "Phone is low on space" warnings about once/month and then have to delete photos, uninstall apps, etc. Just had one a few days ago and so I uninstalled a few apps and deleted some photos and videos.

    5) The issue began while I was doing some lengthy required reading. I needed a break (Skyrim, duh), so I grabbed my phone to set a break timer. As soon as I unlocked it (or maybe I hit the Recents button), the phone cascaded all my recent apps and an error instantly appeared: "Unfortunately, Google app has stopped." I tried to hit "Okay" several times without success, and then I hit the power button. Phone blacked out, and I hit power again. Nothing. I waited 5 seconds and tried again. Nope. I waited about 30 seconds and tried again, this time holding the power button for a few seconds. No reaction from phone. While I was wondering what the Moto X equivalent of a sternum rub might be, it suddenly powered on and then hung on the first boot screen.

    I did manage to get into the Android System Recovery menu just a bit ago. I used the volume keys to select "recovery." The phone went to that same old blue-and-white boot screen, but it was different...it didn't do the startup vibration for quite a while. Then, the screen went black. Now I just have a black screen, and occasionally a brief flashing image of a green Android man lying on the ground with his belly open and a red triangle/exclamation symbol, with text below that reads "No command." I thought ASR was supposed to show a constant image of the same, but whatever. I'm using Lollipop directions from Motorola's "global customer help portal."

    So far, so good. However, when I'm in recovery mode and do Step 4 ("press and hold the Power button then press and release the Volume Up button to display the menu options.") all I get is 2 lines of yellow text at the bottom of a black screen (looks like command prompt text) that indicate some kind of error or lack of content.

    EDIT: The text says something like "Err: can't mount cache." There's more to it, but it only flashes on screen for about 1 second and then disappears. I can only get that to happen once per boot.

    WHAT IS GOING ON???? It's like my phone just up and decided to die. I have never installed shady apps, visited shady websites (that I know of), or anything like that with this phone. I occasionally access unsecured public WiFi.

    Any help is much appreciated. Thanks!
    08-09-2016 12:02 PM
  2. mterrellg's Avatar
    Update: I just registered for androidcentral...username mterrellg. Also, the error message reads, more accurately, "Err: can't mount /cache/recovery" I think there is more after that, but again, it flashes for only a second and is gone.
    08-09-2016 12:38 PM
  3. Javier P's Avatar
    Welcome to the forums. I'll move your thread to the Moto X (2014) forum for more visibility.
    08-09-2016 12:50 PM
  4. mterrellg's Avatar
    Awesome. Thanks!
    08-09-2016 01:12 PM
  5. mterrellg's Avatar
    A brief update...I got a good look at the error...it lingered a bit for some reason on my most recent attempt:

    "E: can't mount /cache/recovery/last_log"
    "E: can't open /cache/recovery/last_log"

    A bit more came on another line after those two items, but it flashed up veeeery briefly. Might try capturing a video later.
    08-09-2016 05:21 PM
  6. mterrellg's Avatar
    Another update...hopefully this will make more sense to someone else than it does to me. Posting this basically just to ask everyone out there if I'm in the right train of thought.

    Based on some forum scuttlebut from the interwebs, it seems that my inability to solve this problem on my own actually stems from RW's unique firmware. Below quote is a forum comment from: https://theunlockr.com/2013/11/09/un...-all-versions/

    "Nice! Where did you guys get the republic wireless stock image. Thats a pretty closely held item and with a locked bootloader and no recovery its been tough to get so far. Looking to get Safestrap working so i can experiment on the ROM safely."

    This Republic Wireless community thread (below link) also sheds some light on the issue, but my novice eyes are kind of blinded by how brightly the tech-talk shines:


    Anyway, "Locked bootloader" and "no recovery" tell me that the reason I can't enter the Recovery menu and do a factory reset is because RW's custom firmware doesn't play nice with a reset from within the phone for some reason. To reset the phone using PC software (e.g., RSD Lite, mfastboot, etc.) would render it useless on the RW network UNLESS I had access to RW's custom ROM/firmware, which according to the above quoted comment (from some Android enthusiast who, I assume, knows more than me) is not to be realistically expected.

    Absent the ability to submit a RW help ticket (that website feature is apparently broken right now), perhaps I can tape a note to my phone, tie it to a brick, and throw it through a window at RW headquarters in the hope that someone with access to RW's ROM will pick it up and try to start it?

    I don't mean to slam RW...they've been amazing up to this point...but this is truly getting ridiculous.
    08-10-2016 07:50 AM
  7. mterrellg's Avatar
    Okay, got a help ticket submitted through online chat with a RW agent. Good experience and some measure of confidence restored. Hoping they'll own the issue (assuming I'm correct that my inability to factory reset is due to RW's proprietary ROM) and fix it for free. Can't be that hard for them to flash their own ROM onto the phone, right? Assuming no hardware is toast...
    08-10-2016 10:05 AM
  8. mterrellg's Avatar
    Response from RW is that Motorola flashes the ROM during manufacture. It is not handled by RW at all. Called Motorola and they refused (3 different people) to honor the warranty even though it's only 4 weeks expired (not 2 as I originally thought). $125 fee to repair (plus tax and shipping).

    A tech-savvy friend says he has uncovered a Republic Wireless ROM that we can flash to my phone. Can't hurt since the warranty is void anyway, unless we totally brick the phone.

    I'll post the RW ROM if this works, so that other RW users can find it and avoid all this hassle. Proprietary ROM, indeed
    08-10-2016 11:19 AM
  9. Damien B's Avatar
    Have you tried booting into safe mode? Turn off the phone completely, then during the boot-up hold down both volume buttons until startup. The phone should either prompt you to go into safe mode or will start in safe mode on its own. If it starts up, uninstall the last app that you installed and try to normally boot again. If not working, try clearing space on the phone if it is running low on storage.
    08-10-2016 01:06 PM
  10. mterrellg's Avatar
    @Damien B

    Thanks for the tip. I didn't know you could manually boot to safe mode. Tried it, though, and it didn't work. I tried your instructions as well as this variant: Power Up in Safe Mode - Moto X | Verizon Wireless

    I'm not with Verizon, but figured it was worth a shot.

    Anyway, the last app I installed was AVG Anti-Virus (I know, lots of people say antivirus apps are useless). Installed it a few days before the crash, and activated it literally a couple of hours before the crash. Correlation ain't causation, but it sure is suspicious. But, that's all just talk because I can't get rid of the app without recovery mode or safe mode.

    The other suspicious thing is, yes, my phone was low on storage at the time. Probably had about 400-500 MB free space.
    08-16-2016 12:40 PM

Similar Threads

  1. I've forgotten my Private Mode password for Galaxy S7 Edge
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 02-26-2017, 11:25 PM
  2. Where to check for OTA update on Moto G4 Plus?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-10-2016, 04:45 AM
  3. Replies: 1
    Last Post: 08-09-2016, 11:30 AM
  4. NO Case for Moto Z with Mods
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-09-2016, 11:12 AM
  5. Can't Make Custom Phone Type in Contacts
    By Yogi71 in forum Ask a Question
    Replies: 0
    Last Post: 08-09-2016, 10:59 AM