1. kenten23's Avatar
    I have a Moto X4. Before it upgraded to Android Pie I was able to plug it into my Windows 10 computer and transfer music files onto it, but now I can't. Since the upgrade to Pie I have re-enabled developer options, set the default USB configuration to File Transfer, and enabled USB Debugging. In windows explorer, when I navigate to MotoX4 and click Internal Shared Storage, the green progress bar in Windows explorer never gets all the way to the end and it never actually displays the folders in Internal Storage (see attached image)

    Can anyone help?
    Attached Thumbnails Windows can see Android internal storage but can't access it-android-internal-storage.png  
    02-07-2019 03:46 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try wiping the cache partition: https://www.hardreset.info/devices/m...recovery-mode/
    02-07-2019 10:34 PM
  3. kenten23's Avatar
    Thank you B. Diddy. I followed those instructions and was able to enter Recovery Mode, but there was no Wipe Cache Partition option there.
    02-08-2019 08:07 AM
  4. kenten23's Avatar
    This article seems to indicate that as of version 7.1, Android no longer has a cache partition, and therefore there is no longer an option to wipe it. Am I understanding this correctly?

    https://www.androidpolice.com/2016/1...boot-commands/
    02-08-2019 08:13 AM
  5. Javier P's Avatar
    This article seems to indicate that as of version 7.1, Android no longer has a cache partition, and therefore there is no longer an option to wipe it. Am I understanding this correctly?

    https://www.androidpolice.com/2016/1...boot-commands/
    It depends on the phone more than on the Android version. The cache partition was removed in phones that include the seamless updates/dual partition feature and the Moto X4 was one of the first non-Google models to come with this feature.
    02-08-2019 08:17 AM
  6. kenten23's Avatar
    Thank you for clarifying, Javier. Since wiping the cache partition is not an option for my phone, what else can I do to get it to interface correctly with my computer?
    02-08-2019 08:22 AM
  7. Javier P's Avatar
    Thank you for clarifying, Javier. Since wiping the cache partition is not an option for my phone, what else can I do to get it to interface correctly with my computer?
    Not sure what to suggest, the fact that the computer managed to read the phone files probably means that you have the right settings and drivers. Are you using an SD card? If so, unmount it temporarily and see if it makes any difference.
    02-08-2019 08:34 AM
  8. Javier P's Avatar
    Thank you for clarifying, Javier. Since wiping the cache partition is not an option for my phone, what else can I do to get it to interface correctly with my computer?
    I moved your thread to the X4 forum where it'll be easier getting feedback from other owners.
    02-08-2019 08:36 AM
  9. cnjvh's Avatar
    Couple things to try (which you probably already did but I'll throw it out there):

    1. When you connect the USB cable you should see some type of notice on the phone asking if you're connecting to charge or for storage access (not sure what it looks like on the Moto but all my Android phones have had some variant of this message). Make sure you select storage.

    2. Make sure the phone is unlocked and awake when you attempt to access the folder, it may hide the contents if the phone is locked (I know iPhone does this).
    02-08-2019 09:12 AM
  10. kenten23's Avatar
    Thank you cnjvh, I did both of those things.

    Javier, I am not using an SD card.
    02-08-2019 10:50 AM
  11. B. Diddy's Avatar
    Thank you B. Diddy. I followed those instructions and was able to enter Recovery Mode, but there was no Wipe Cache Partition option there.
    Ah bummer -- Javier P already mentioned this, but I had forgotten that the X4 has the duplicate system partitions.

    Javier P's question about the SD card may be important, especially if you formatted it as Internal Storage (since Lenovo/Moto has had a somewhat spotty record when it comes to implementing Adoptable Storage correctly).
    02-08-2019 02:13 PM
  12. kenten23's Avatar
    I am not using an SD card in this phone.
    02-09-2019 05:48 AM

Similar Threads

  1. It's my birthday today
    By robinhelenehebert in forum Samsung Galaxy Note 9
    Replies: 22
    Last Post: 02-08-2019, 09:20 PM
  2. How to get rid of android.process.media on note 3
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-07-2019, 10:35 PM
  3. I can't swipe right or left to browse through my camera modes and settings on Huawei mate 10 pro
    By Android Central Question in forum Huawei Mate 10 & Mate 10 Pro
    Replies: 2
    Last Post: 02-07-2019, 05:08 PM
  4. Erasing my data using find my device - how do I know if it has worked?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-07-2019, 03:15 PM
  5. Replies: 1
    Last Post: 02-07-2019, 01:38 PM
LINK TO POST COPIED TO CLIPBOARD