1. prettylights808's Avatar
    So I just upgraded from the Iphone 5 to the Z force. I'm not able to receive any texts from other iphone users. Their texts are trying to send as an imessage, which is what it would do if I still had an iphone...

    How can I start receiving texts from iphone users?
    12-03-2016 12:46 PM
  2. Ry's Avatar
    So I just upgraded from the Iphone 5 to the Z force. I'm not able to receive any texts from other iphone users. Their texts are trying to send as an imessage, which is what it would do if I still had an iphone...

    How can I start receiving texts from iphone users?
    Did you disable iMessage before switching?
    Laura Knotek likes this.
    12-03-2016 12:52 PM
  3. prettylights808's Avatar
    not before switching. I wasn't aware this would be an issue at the time. I've disabled it now, after the issue was present, but I'm still not getting texts from iphone users.
    12-03-2016 12:57 PM
  4. Laura Knotek's Avatar
    Please see the following article. https://www.google.com/amp/amp.andro...ere-s-easy-fix
    12-03-2016 01:19 PM
  5. Mattsg430's Avatar
    When I switched from apple back in 2014 I had to call apple and tell them to remove my number from their servers. Just ridiculous.
    maxman1 likes this.
    12-03-2016 02:07 PM
  6. 11B1P's Avatar
    Your friends need to change in THEIR phone, your number from imessage to regular SMS. It has nothing to do with you changing your imessage setting.
    Laura Knotek likes this.
    12-03-2016 02:09 PM
  7. CrazyRussian007's Avatar
    Your friends need to change in THEIR phone, your number from imessage to regular SMS. It has nothing to do with you changing your imessage setting.
    Please research before giving advice - this is a clear iMessage issue that is going on for many years. The user switching from Apple to Android has to disable iMaessage - not the other users.

    For your reference: https://support.apple.com/en-us/HT204270
    maxman1 and Gebo like this.
    12-03-2016 03:55 PM
  8. doogald's Avatar
    Right, Apple added that web page to remove your phone number from iMessage a year or two ago. Before then it was really a pain in the neck.
    maxman1 and Gebo like this.
    12-03-2016 08:10 PM
  9. prettylights808's Avatar
    So the issue is fixed. It took about 12 hours from the point of me turning off imessage from my old iphone until it went into effect.
    12-03-2016 08:36 PM
  10. anon(10099834)'s Avatar
    Google "deregister iMessage"
    Click on the Apple Self Solve site
    Scroll down and enter your phone number
    You'll get text with a code
    Enter that in the website
    Your phone number will be deregistered.
    Tell friends to delete threads and start new convos with you
    Gebo likes this.
    12-03-2016 08:50 PM
  11. anon(10099834)'s Avatar
    Please research before giving advice - this is a clear iMessage issue that is going on for many years. The user switching from Apple to Android has to disable iMaessage - not the other users.

    For your reference: https://support.apple.com/en-us/HT204270
    Not entirely true. The iPhone user should always SELECT "Send as SMS if iMessage is unavailable". This from the iPhone users side ensures that regardless of whether their phone or the other users phone is the issue it goes through. Not relevant to this Android issue per se but in situations where iMessage is unavailable to iPhone user like poor service areas, their messages should go through as SMS anyway. But I digress. Yes, as you said it is the new Android owners responsibility to to remove iMessage correctly but also requires old messages to be deleted and new threads to be started.
    Gebo likes this.
    12-03-2016 08:56 PM
  12. 11B1P's Avatar
    Please research before giving advice - this is a clear iMessage issue that is going on for many years. The user switching from Apple to Android has to disable iMaessage - not the other users.

    For your reference: https://support.apple.com/en-us/HT204270
    Guess you missed the part that stated: because they're still being sent as iMessage. So, like I said. If the "sender" will simply change the phone number setting imessage to sms, it immediately solves the issue.
    12-03-2016 10:32 PM
LINK TO POST COPIED TO CLIPBOARD